entropy update 1.0rc_21 to rc_25 impossible

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

entropy update 1.0rc_21 to rc_25 impossible

Postby raifi1234 » Mon Jul 11, 2011 21:12

Update stops as follows:

(107/212) Installiere: sys-apps/miscfiles-1.5
## Entpacke Paket: sys-apps:miscfiles-1.5~0.tbz2
## Installiere Paket: sys-apps/miscfiles-1.5
## [Miscellaneous files]
## Aktualisiere Datenbank: sys-apps/miscfiles-1.5
Traceback (most recent call last):

File "/usr/lib/entropy/sulfur/sulfur/__init__.py", line 2436, in spawn_install

selected_by_user = selected_by_user)

File "/usr/lib/entropy/sulfur/sulfur/entropyapi.py", line 296, in run

rc = pkg.run()

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3561, in run

rc = self._stepper(xterm_header)

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3527, in _stepper

rc = steps_data.get(step)()

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3431, in do_install

return self._install_step()

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3092, in _install_step

rc = self.__install_package()

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 1786, in __install_package

self.pkgmeta['installed_package_id'] = self._add_installed_package()

File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 2007, in _add_installed_package

forcedRevision = data['revision'], formattedContent = True)

File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 2496, in handlePackage

"cannot execute handlePackage on this repository")

PermissionDenied: cannot execute handlePackage on this repository

!!! Systemdatenbank nicht gefunden oder beschaedigt, laufe im abgesicherten Modus und verwende temporaeres, leeres Repositorium

engl.: using temporary & empty repository

Solution??
raifi1234
Simple Hen
 
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby genfool » Mon Jul 11, 2011 22:08

Strange error, are you sure you are root?
I would first try
Code: Select all
equo update --force


Code: Select all
equo install equo entropy


If these fail. the commands below should work fine.

Code: Select all
emerge --sync
layman -a sabayon
layman -s sabayon
emerge equo entropy
equo install equo entropy
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby raifi1234 » Mon Jul 11, 2011 23:13

1st: I am root
2nd: after equo update --force I receive the following

>> ++ (1/106) >>> sys-libs/db-4.8.24
>> ## Entpacke Paket: sys-libs:db-4.8.24~1.tbz2
>> ## SPM: Vorinstallations-Phase
Traceback (most recent call last):
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 2062, in _pkg_setup
licenses = package_metadata.get('accept_license'))
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 1797, in _portage_doebuild
mysettings = self._get_portage_config(os.path.sep, root)
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 3556, in _get_portage_config
raise SPMError("SPMError: %s" % (repr(e),))
SPMError: SPMError: ParseError()
>> ## QA: Kann Schalter des QuellPaketmanagers nicht ausfuehren fuer sys-libs/db-4.8.24.
>> ## Bitte dies melden. Haenge dies an: /var/log/entropy/entropy.log [setup]
>> ## Installiere Paket: sys-libs/db-4.8.24
>> ## [Oracle Berkeley DB]
>> ## Aktualisiere Datenbank: sys-libs/db-4.8.24
>> * cannot execute handlePackage on this repository. Kann nicht weiterarbeiten.

"Bitte dies melden" i.e in English: Please report (this).

3rd: emerge --sync results in the following message:
"No such file or directory: ´/var/lib/layman/make.conf´ in /etc/make.conf

How should a file ´make.conf´ in /etc look like?
raifi1234
Simple Hen
 
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby genfool » Mon Jul 11, 2011 23:42

what version of sabayon is this? trying to understand the errors, using google translate to help me.
Since you have entropy rc_21 I suspect this is a fresh install of sabayon 6

I am also seeing python errors, and looks like maybe a 5.5 being updated, *just thinking out loud*

What does this show?
Code: Select all
eselect python list


A fresh 6 you should have
Available Python interpreters:
[1] python2.7 *

The * means that 2.7 is set, if you have a upgraded older system, you will also have python 2.6 in the list, need to make sure 2.7 is set.

also, in a root terminal,
Code: Select all
sulfur

This will simply start the gui package manager, does it show any errors?
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby raifi1234 » Tue Jul 12, 2011 9:57

Yes, it was a fresh install, leaving my home partition (from the preceeding 5.x) untouched and moving
the /var partition to a new (2nd) harddisk (for saving space).

So only python2.7 is shown by the eselect python list command and marked
by a ´*`.

At the first time sulfur started from a root terminal, only glibc 2.12.2 was offered
for updating (from 2.11.2-r3). This was done WITHOUT ERRORS ;-)).

After that I updated stepwise, and entropy became updated to rc_25. Hurray!

At this moment further updating is performed finishing without errors, hopefully.

BTW: Changing the timeout in /etc/default/grub from 5s (i.e. default) to -1
(never ending) seems to effect nothing. Why that?

Thanks for help!
Rainer
Last edited by raifi1234 on Thu Jul 14, 2011 10:37, edited 1 time in total.
raifi1234
Simple Hen
 
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: entropy update 1.0rc_21 to rc_25 impossible [Solved]

Postby Fitzcarraldo » Tue Jul 12, 2011 20:40

raifi1234 wrote:BTW: Changing the timeout in /etc/default/grub from 5s (i.e. default) to -1
(never ending) seems to effect nothing. Why that?

Thanks for help!
Rainer

I have to ask just in case: You are aware that, after editing /etc/default/grub, you have to run grub-mkconf -o /boot/grub/grub.cfg?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: entropy update 1.0rc_25 to rc_26 impossible

Postby raifi1234 » Thu Jul 14, 2011 9:39

Yes, I did so, but this grub problem has been solved by updating to entropy rc_25.

BUT TODAY THE OLD PROBLEM RETURNED - updating to rc_26 is not possible,
and the system base backed up yesterday has vanished ;-)).

Seems I need help once more.

Rainer

I tried to solve the problem by using emerge & Co. without success.
Here come some error messages:

>> :: (41/41) >>> 2 Pakete
>> ## Paketprüfsumme stimmt überein: app-shells:bash-completion-1.3~0.tbz2
>> ## Paketprüfsumme stimmt überein: app-shells:gentoo-bashcomp-20101217~0.tbz2
>> ++ (1/122) >>> sys-kernel/linux-headers-2.6.38
>> ## Entpacke Paket: sys-kernel:linux-headers-2.6.38~0.tbz2
>> ## SPM: Vorinstallations-Phase
Traceback (most recent call last):
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 2062, in _pkg_setup
licenses = package_metadata.get('accept_license'))
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 1797, in _portage_doebuild
mysettings = self._get_portage_config(os.path.sep, root)
File "/usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugin/__init__.py", line 3556, in _get_portage_config
raise SPMError("SPMError: %s" % (repr(e),))
SPMError: SPMError: ParseError()
>> ## QA: Kann Schalter des QuellPaketmanagers nicht ausführen für sys-kernel/linux-headers-2.6.38.
>> ## Bitte dies melden. Hänge dies an: /var/log/entropy/entropy.log [setup]
>> ## Installiere Paket: sys-kernel/linux-headers-2.6.38
>> ## [Linux system headers]
>> ## Aktualisiere Datenbank: sys-kernel/linux-headers-2.6.38
>> * cannot execute handlePackage on this repository. Kann nicht weiterarbeiten.

amd64 rainer # emerge --sync
[Errno 2] No such file or directory: '/var/lib/layman/make.conf' in /etc/make.conf
amd64 rainer # layman -a sabayon
* Program "/usr/bin/git" not found
* Failed to add overlay "sabayon".
* Error was: Adding overlay "sabayon" failed!

Rainer
raifi1234
Simple Hen
 
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby albfneto » Sat Jul 16, 2011 1:37

You need the package GIT also. try this:

Code: Select all
emerge --sync
    emerge git
    layman -d sabayon
    layman -a sabayon
    layman -S
    emerge equo entropy
    equo install equo entropy
    equo update --force
    equo libtest && equo deptest
   


but i have in mind that you have also a Python problem. See if you have different versions of python, i entropy and in portage, with these commands:

Code: Select all
emerge -s python
equo search python


for good working, both may be the same version 2.7. You tried to update python with portage? If no, NOT try, install
python with portage
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: entropy update 1.0rc_21 to rc_25 impossible

Postby joost » Sat Jul 16, 2011 18:07

and equo install git after you are done.
:D
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests