Trouble updating repos in Sabayon 6 32bit [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Trouble updating repos in Sabayon 6 32bit [Solved]

Postby serenicom » Thu Jul 07, 2011 4:40

I am trying to update and add software to a S6, Gnome, 32bit desktop... Other threads about this seem old or related to driver issues. These are the steps I try:

1) Click on entrophy store
2) Message " The repositories listed below are configured but not available. They should be downloaded. (sabayonlinux.org shows below)
3) Click "download now"
4) Progress dialog appears showing:

Repository sabayonlinux.org hasn't been downloaded yet.
Repository sabayonlinux.org is not available. Cannot validate
RepositoryError()
!!! Please update your repositories now in order to remove this message!
Exception in thread Thread-5:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 530, in __bootstrap_inner
self.run()
File "/usr/lib/entropy/libraries/entropy/misc.py", line 353, in run
self.__rc = self.__function(*self.__args, **self.__kwargs)
File "/usr/lib/entropy/sulfur/sulfur/__init__.py", line 1594, in run_up
rc = repoConn.sync()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/repository.py", line 296, in sync
rc = self._run_sync()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/repository.py", line 120, in _run_sync
repo, self.force, self._gpg_feature)
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 2398, in update
force, gpg).update()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 1756, in update
locked = self.__handle_repository_lock()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 399, in __handle_repository_lock
unlocked = self._is_repository_unlocked()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 882, in _is_repository_unlocked
rc = self._download_item("lock", disallow_redirect = True)
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 868, in _download_item
rc = fetcher.download()
File "/usr/lib/entropy/libraries/entropy/fetchers.py", line 317, in download
status = downloader()
File "/usr/lib/entropy/libraries/entropy/fetchers.py", line 517, in _urllib_download
req = urlmod.Request(url, headers = headers)
File "/usr/lib/python2.7/urllib2.py", line 205, in __init__
origin_req_host = request_host(self)
File "/usr/lib/python2.7/urllib2.py", line 179, in request_host
host = urlparse.urlparse(url)[1]
File "/usr/lib/python2.7/urlparse.py", line 134, in urlparse
tuple = urlsplit(url, scheme, allow_fragments)
File "/usr/lib/python2.7/urlparse.py", line 182, in urlsplit
raise ValueError("Invalid IPv6 URL")
ValueError: Invalid IPv6 URL

@@ Repositories synchronization ...
# Sabayon Linux Official Repository
# Repository URL: http://pkg.sabayon.org[/standard/sabayonlinux.org/database/x86/5
# Repository local path: /var/lib/entropy/client/database/x86/sabayonlinux.org/standard/x86/5
# Repository API: 2

5) Nothing happens after this, and attempt to upgrade or install leads me back to this point.

Am I missing something obvious?
Last edited by serenicom on Thu Jul 07, 2011 12:37, edited 1 time in total.
serenicom
Baby Hen
 
Posts: 6
Joined: Fri Aug 17, 2007 12:35

Re: Trouble updating repos in Sabayon 6 32bit

Postby genfool » Thu Jul 07, 2011 4:58

http://wiki.sabayon.org/index.php?title ... t_to_do.3F

We like to help, follow the link above, if you still have questions, ask.
Any questions, not just updating.
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: Trouble updating repos in Sabayon 6 32bit [Solved]

Postby serenicom » Thu Jul 07, 2011 12:37

Thanks for the link. It suggests running
# equo update
# equo update --force

This resulted in more error messages and requests to download the repositories. I skipped to the next part out of frustration and ran:
# equo install entropy sulfur equo --relaxed
# equo conf update


This seemed to run OK so I went back to:
# equo update
# equo update --force

The response was that everything was up to date. (I did not record the specific wording)

I then proceeded with the next steps:
# equo update
# equo upgrade --ask


This is running in the background at reasonable download speeds without error, so I seem to be back on track. I am not quite sure why, and the update is still running, but I seem OK so I shall mark this as solved and say thank you again

Regards to all, Phil S.
serenicom
Baby Hen
 
Posts: 6
Joined: Fri Aug 17, 2007 12:35


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 0 guests

cron