Ati Radeon HD 5450 Driver Problem

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: Ati Radeon HD 5450 Driver Problem

Postby Fitzcarraldo » Wed Jul 06, 2011 1:52

Don't worry about the numbers; they'll likely be different from machine/installation to machine/installation.

The lack of KWin Desktop Effects with the open-source driver may be because you need different parameters in xorg.conf for the two different drivers. For example, for my previous laptop with ATI Mobility Radeon X1600, xorg.conf for the Radeon driver is listed in my post: Re: ATI drivers < 9.6 for 2.6.29, whereas the xorg.conf I used for the FGLRX driver (until AMD stopped FGLRX driver support in 2009 for that older GPU) is listed in the post: Re: ATI fglrx drivers won't work. If you compare them (forget the comments in the files) you can see that I used several different parameters depending on which driver I was using.

Backup your existing xorg.conf and then generate a new one using the Xorg -configure command (as root user). Google will show you examples of using the command.

Also try googling "ati radeon HD 5450 kwin xorg.conf" etc. to see what you find. Here's one example: https://bbs.archlinux.org/viewtopic.php?pid=943311 but you'll probably need to read some more. Pity no one else with your GPU and using the Radeon driver has posted in this thread. If you have a look in the Gentoo Forums you might find someone with the same GPU as you using the Radeon driver.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Previous

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron