equo upgrade error [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

equo upgrade error [Solved]

Postby pajamabama » Sat Jun 25, 2011 21:36

I submitted the bug report via the ever-so-helpful equo 'Bug Reporter'. I just want to see if anyone else has seen this and/or has a solution. I'm concerned that even if there is a fix in a new version, I won't be able to install it because apparently entropy is currently broken on my system.

Code: Select all
[email protected] ~ $ sudo equo install entropy equo sulfur
>>  @@ Calculating dependencies ...
>>  ## [U] [sabayonlinux.org] sys-apps/entropy-1.0_rc17|0   [1.0_rc14|0]
>>  ## [U] [sabayonlinux.org] app-admin/sulfur-1.0_rc17|0   [1.0_rc14|0]
>>  ## [U] [sabayonlinux.org] app-admin/equo-1.0_rc17|0   [1.0_rc14|0]
>>  ## [U] [sabayonlinux.org] sys-apps/entropy-client-services-1.0_rc17|0   [1.0_rc14|0]
>>  @@ Packages needing to be installed/updated/downgraded: 4
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 1.2MB
>>  @@ Used disk space: 248.0b
>>  @@ You need at least: 2.4MB of free space
>>  :: (1/2) >>> 3 packages
>>    ## Downloading: 3 archives
>> Hi. My name is Bug Reporter. I am sorry to inform you that Equo crashed. Well, you know, shit happens.
>> But there's something you could do to help Equo to be a better application.
>> -- EVEN IF I DON'T WANT YOU TO SUBMIT THE SAME REPORT MULTIPLE TIMES --
>> Now I am showing you what happened. Don't panic, I'm here to help you.
Traceback (most recent call last):
  File "/usr/bin/equo", line 1046, in <module>
    main_rc = main()
  File "/usr/bin/equo", line 1029, in main
    rc = cmd_cb(main_cmd, options)
  File "/usr/bin/equo", line 413, in _do_text_ui
    return text_ui.package([main_cmd] + options)
  File "/usr/lib/entropy/client/text_ui.py", line 209, in package
    recursive = e_req_recursive)
  File "/usr/lib/entropy/client/text_ui.py", line 1653, in install_packages
    multifetch, dochecksum)
  File "/usr/lib/entropy/client/text_ui.py", line 1122, in _fetch_packages
    rc = Package.run(xterm_header = xterm_header)
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3554, in run
    rc = self._stepper(xterm_header)
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3520, in _stepper
    rc = steps_data.get(step)()
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 3378, in do_multi_fetch
    return self._multi_fetch_step()
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 2950, in _multi_fetch_step
    self.pkgmeta['checksum']
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 248, in _download_packages
    uris = self.__build_uris_list(original_repo, repo)
  File "/usr/lib/entropy/libraries/entropy/client/interfaces/package.py", line 877, in __build_uris_list
    uri, product, original_repo)
  File "/usr/lib/entropy/libraries/entropy/tools.py", line 2294, in expand_plain_package_mirror
    return mirror + os.path.sep + product + os.path.sep + repository_id
TypeError: cannot concatenate 'str' and 'NoneType' objects

Frame expand_plain_package_mirror in /usr/lib/entropy/libraries/entropy/tools.py at line 2294
               repository_id = None
                     product = 'standard'
                      mirror = 'http://pkg.sabayon.org'
Last edited by pajamabama on Sat Jun 25, 2011 22:37, edited 1 time in total.
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: equo upgrade error

Postby joost » Sat Jun 25, 2011 22:02

I ran into this too....

What I did:
Code: Select all
emerge --sync
layman -a sabayon
layman -s sabayon
emerge equo entropy
equo install equo entropy


I was not able to repair this with Entropy :x
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: equo upgrade error [Solved]

Postby pajamabama » Sat Jun 25, 2011 22:35

Splendid...

I guess that's an advantage of having two separate but compatible package management systems running - if one breaks, you can use the other to reinstall it.

Thanks!! :) :) :)
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: equo upgrade error [Solved]

Postby lxnay » Sat Jun 25, 2011 23:16

A workaround is to download the repositories disabling the differential sync:
Code: Select all
FORCE_EAPI=2 equo update --force && equo upgrade


Sorry, it's all fixed in >1.0_rc17. The faulty package lasted 20 minutes on our repos, sigh.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron