Intel Centrino Wireless-N 1000 [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Intel Centrino Wireless-N 1000 [Solved]

Postby Kizo » Thu Jun 02, 2011 19:16

Hi,
I'm not very new to Linux, but you may think of me as a beginner...

I recently bought a laptop with this Intel wireless adapter, and decided to go with Sabayon CoreCDX 5.5.
I installed it successfully, but this adapter is not immediately recognized.

ifconfig only returns: eth0 (the gigabit ethernet with realtek driver) and lo.
lspci recognizes the card nicely and returns the full name...

The kernel settings are the default ones (IWLWIFI, IWLAGN settings are to their default).

I tried copying the firmware code from http://intellinuxwireless.org/ to /lib/firmware and starting the iwlagn module ("modprobe iwlagn"), and it didn't help, still only eth0 and lo appear.

Am I missing something about all this, I am really not very experienced with this, but hopefully when I get internet sorted, I'm gonna improve. :)

Thanks for any help

EDIT:
Apparently I have just answered my own question...
Being inexperienced, I forgot to look at dmesg.

There I saw that the driver expected the older iwlwifi-1000-3.ucode instead of the new iwlwifi-1000-5.ucode, which is not supported by the version of the driver that ships with Sabayon CDX 5.5.

So i downloaded it, pasted in /lib/firmware, setup the wpa-supplicant, and bam, all works well... :)
Kizo
Baby Hen
 
Posts: 1
Joined: Thu Jun 02, 2011 15:57

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron