bind9 and ldap

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

bind9 and ldap

Postby sabayonuser2 » Thu Nov 23, 2006 15:07


I installed SabayonLinux 3.1 from the full DVD on my server.
Then I configured everything I need.

works fine!!!

I installed openldap, now I want to configure bind to use ldap as backend... worked on my system before (suse)....
When I start bind (/etc/init.d/named start) there is an error post (/var/log/messages): unknown database type: ldap.

Well.. recompile with the right Useflags.... USE="ldap" emerge bind .....

When I start bind..... same error.....

then I read about that bind does not support ldap an about bind-sdb (
so I tried this... but now when I try to compile bind from source there are also errors with the ldap libraries..... (whicht have to be manually written in the

Is there any easier or working way to get bind run with ldap as backend??

Baby Hen
Posts: 6
Joined: Thu Oct 19, 2006 20:41

Postby lxnay » Thu Nov 23, 2006 16:57

This might help you:
Join us on IRC ( #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby sabayonuser2 » Thu Nov 23, 2006 18:51


but this is not my main problem... to get ja bind running is easy... only how to access ldap as backend is my problem...... :(
Baby Hen
Posts: 6
Joined: Thu Oct 19, 2006 20:41

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests