Wired Internet connection [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: Wired Internet connection

Postby dunsurfin » Wed Apr 20, 2011 18:49

I've just had a look at my three machines. 2 have a firmware version given but one doesn't and it works OK so I assume it's not a necessity.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Wired Internet connection

Postby onyx » Thu Apr 21, 2011 0:13

Yeh, no need for firmware version to be reported.
My results:

# ethtool -i eth0
driver: r8169
version: 2.3LK-NAPI
firmware-version:
bus-info: 0000:02:00.0

The Ubu-nutters are having fun with your laptop trying to get Wifi working http://ubuntuforums.org/showthread.php?t=1707814, but seem to have no issue with Ethernet.

What do you have as a kernel? It would appear most of these hassles stop with version 2.6.38.
uname -r (in the terminal will tell you)

If that is not your version, then I highly suggest downloading the Sabayon daily ISO of your choice, so you get 2.6.38 baked in. I am using the AMD64 KDE daily of a week ago, and it is sweet :D
onyx
Baby Hen
 
Posts: 13
Joined: Thu Jan 13, 2011 10:54
Location: NZ

Re: Wired Internet connection

Postby orange_angel » Thu Apr 21, 2011 12:29

I have the latest kernel, but now I also have a wireless router here, so I'm once again able to use the Internet in Sabayon. The wired connection is still useless. Thanks for all the help, it will be nice to have a router here so that more than one computer can be connected to the Internet, so at least some good has come of this.
orange_angel
Young Hen
 
Posts: 22
Joined: Tue Jun 29, 2010 16:37

Re: Wired Internet connection

Postby Fitzcarraldo » Thu Apr 21, 2011 14:45

I haven't read through this thread, but have you tried reducing the MTU? On one of my machines (an Acer SA90 tower) I have to reduce the MTU to 1492 in order to enable SL to access the Internet via the wired Ethernet connection. On another of my machines (an old Gateway solo 9300 laptop) I have to reduce the MTU to 1464 in order to enable SL to access the Internet via the wireless connection.

If pinging is working on your wired connection, you can find out the correct MTU using the following method:

Code: Select all
# ping -M do -s packet_size_in_bytes www.cisco.com


e.g.

Code: Select all
# ping -M do -s 1472 www.cisco.com

I just vary the packet size in the ping command until “Frag needed and DF set” is not displayed.

You can reduce the MTU to e.g. 1492 as follows:

Code: Select all
# ifconfig eth0 mtu 1492

The MTU is the maximum packet size in bytes that does not fragment + 28 bytes. So, for example, if you were to find that:

Code: Select all
# ping -M do -s 1464 http://www.cisco.com

does not cause fragmented packets, but:

Code: Select all
# ping -M do -s 1466 http://www.cisco.com

does cause fragmented packets, then the MTU would be 1464 + 28 = 1492.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Wired Internet connection

Postby orange_angel » Thu Apr 21, 2011 15:09

That actually worked! Thanks so much Fitzcarraldo.
orange_angel
Young Hen
 
Posts: 22
Joined: Tue Jun 29, 2010 16:37

Re: Wired Internet connection [Solved]

Postby Fitzcarraldo » Thu Apr 21, 2011 15:23

You're welcome. If you want to run that ifconfig command automatically every time you boot your machine, you can put it in the file /etc/conf.d/local. However, if you have openrc-0.8.0 or later installed then instead create the file /etc/local.d/ifconfig.start and put the ifconfig command in that file instead, and make ifconfig.start executable (see /etc/conf.d/local is gone [Solved], as version 0.8.0 of OpenRC has changed the way the local initscript runs user-specified commands at start up). An alternative way of achieving the same thing would be to add the line mtu_eth0=”1492″ (replace the 1492 with whatever your MTU is) to the file /etc/conf.d/net instead.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Previous

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest