User Accout Corrupt

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

User Accout Corrupt

Postby Privateer187 » Tue Nov 21, 2006 20:13

Hello. This is my first time positing in these forums, so I hope I have the right room. I have recently given Sabayon a try, and I must say I was impressed. I have been running it dual booted on my system for the last four days or so, and everything has been peachy until now.

Now, however, I have a corrupted user account. I was playing with it this morning trying to get mysql to work, and when I logged out of it to boot a recovery distro (I'm a pc technician), everything was fine. No errors, nada. When I tried to log back into it, though, it just crashes back to the login prompt.

The Root account works perfectly though.

Any ideas on how to fix this?

I'm sorry for this brief, choppy message, but I'm still at work and I have to go on a service call. Any help that can be provided would be great, and anything I forgot to mention, just tell me.
Privateer187
Baby Hen
 
Posts: 3
Joined: Wed Nov 15, 2006 23:06
Location: Arkansas

Postby cvill64 » Tue Nov 21, 2006 20:57

did you do anything else other than just playing with mysql?
cvill64
Sagely Hen
 
Posts: 2185
Joined: Fri Dec 30, 2005 10:03
Location: Virginia, USA

Postby Privateer187 » Tue Nov 21, 2006 21:28

Not to my knowledge. I had trouble getting mysql to function, so I removed and emerged it a couple of times. Finally I got it to work (not quite sure how), finished the MythTV config, and then I had to log out. I shut the system down, booted into a different distro because Sabayon wouldn't read the hard drive I was trying to recover.

After I finished working on that, I booted into Windows, and worked in it for a while. When I tried to boot back into Sabayon, the user account just dropped me back to the login screen.

The only other thing I did beyond following the Gentoo MythTV config instructions was attempt to access my hard drives from the other distro. I suppose its possible that it might have corrupted the system, but to my way of thinking, that would more then likely have damaged the partition or the entire install, rather then just that one account.
Privateer187
Baby Hen
 
Posts: 3
Joined: Wed Nov 15, 2006 23:06
Location: Arkansas

Postby cvill64 » Tue Nov 21, 2006 22:00

mythtv requires xorg configuration if I'm not mistaken, that is most likely you're area of error

look in your xorg and xorgsession logs and errors to see why kdm is failing to boot up :)
cvill64
Sagely Hen
 
Posts: 2185
Joined: Fri Dec 30, 2005 10:03
Location: Virginia, USA

Postby Privateer187 » Wed Nov 22, 2006 17:10

I checked the system logs as you suggested. I didn't see anything odd in the xorg log, and as much as it embarasses me to admit it, I couldn't find the xorgsession log in the few minutes I had to spare yesterday. On a lark, though, I checked the kdm log, and this was end ouput:

(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc/pc(pc105)+pc/us" };
xkb_geometry { include "pc(pc105)" };
AUDIT: Tue Nov 21 14:13:52 2006: 10977 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Tue Nov 21 14:13:52 2006: 10977 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc/pc(pc105)+pc/us" };
xkb_geometry { include "pc(pc105)" };


I see two things I've never seen before, and for all I know it could be just another part of Sabayon's xorgconfig. It says something about a "client 2", and a MIT-MAGIC-COOKIE-1. What are these?

I'm also wondering, is it possible that I could fix it by just dropping to console and redoing xorg?
Privateer187
Baby Hen
 
Posts: 3
Joined: Wed Nov 15, 2006 23:06
Location: Arkansas

Postby lxnay » Wed Nov 22, 2006 17:30

What's the error?
we need log files or error outputs :)
Paste here the content of $HOME/.xsession-errors and "cat /var/log/messages | tail --lines 50"
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron