wifi etho connection [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

wifi etho connection [Solved]

Postby Austlig » Fri Mar 18, 2011 1:47

I can't seem to find anything on this, my broadband connection doesn't connect automatically on boot, I have to right click the task bar icon and the connection name and a connection page appears, the password is there and if I click OK it connects. Is this normal? Or is it possible to connect auto on boot. I'm running openSUSE 11.4 and it connects auto on boot. Is it configured wrong?
Last edited by Austlig on Mon Mar 21, 2011 22:57, edited 1 time in total.
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: wifi etho connection

Postby packetknife » Fri Mar 18, 2011 7:01

I had that problem in KDE when I didn't opt to setup the key store up-front. For me that was my first and only KDE experience as after a few minutes of stumbling I decided to stick w/ Gnome and LXDE.

At a lower level did you already check /etc/conf.d/net and network to see if your interface is set to auto_<YOURSSID>=True and such? ifconfig -a shows the interface UP at boot but you're not connected?

Which desktop manager are you using? What is the card? uname and lshw information? -Pk
packetknife
Baby Hen
 
Posts: 14
Joined: Thu Mar 03, 2011 4:57

Re: wifi etho connection

Postby Austlig » Fri Mar 18, 2011 9:51

Thanks for the help - here's what I've got

Code: Select all
01:00.0 Ethernet controller: Atheros Communications AR8132 Fast Ethernet (rev c0)
03:02.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)


net

Code: Select all
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
dhcp_wlan0="nosendhost"
dns_domain_wlan0="localdomain"
nis_domain_wlan0="localdomain"
dhcp_eth0="nosendhost"
dns_domain_eth0="localdomain"
nis_domain_eth0="localdomain"


network

Code: Select all
# Assign static IP addresses and run custom scripts per interface.
# Seperate commands with ;
# Prefix with ! to run a shell script.
# Use \$int to represent the interface
#ifconfig_eth0="192.168.0.10 netmask 255.255.255.0"

# You also have ifup_eth0 and ifdown_eth0 to run other commands when
# eth0 is started and stopped.
# You should note that we don't stop the network at system shutdown by default.
# If you really need this, then set shutdown_network=YES

# Lastly, the interfaces variable pulls in virtual interfaces that cannot
# be automatically detected.
#interfaces="br0 bond0 vlan0"

# You can also use files instead of variables here if you like:
# /etc/ifconfig.eth0 is equivalent to ifconfig_eth0
# /etc/ip.eth0 is equivalent to ifconfig_eth0
# /etc/ifup.eth0 is equivalent to ifup_eth0
# /etc/ifdown.eth0 is equivalent to ifdown_eth0
# Any files found will automatically be put into the interfaces variable.
# You don't need to escape variables in files, so use $int instead of \$int.

# If you require DHCP, you should install dhcpcd and it to the boot or
# default runlevel.

# NIS users can set the domain name here
#domainname="foobar"

# You can assign a default route
#defaultroute="gw 192.168.0.1"
#defaultroute6="gw 2001:a:b:c"

# ifconfig under Linux is not that powerful and doesn't easily handle
# multiple addresses
# On the other hand, ip (iproute2) is quite powerful and is also supported
#ip_eth0="192.168.0.10/24; 192.168.10.10/24"

# You can also use ip to add the default route.
#defaultiproute="via 192.168.0.1"
#defaultiproute6="via 2001:a:b:c"

# ip doesn't handle MTU like ifconfig, but we can do it like so
#ifup_eth0="ip link set \$int mtu 1500"

# Create a bonded interface
#interfaces="bond0"
#ifup_bond0="modprobe bonding; ifconfig \$int up; ifenslave \$int bge0"
#ifconfig_bond0="192.168.0.10 netmask 255.255.255.0"
#ifdown_bond0="rmmod bonding"

# Create tap interface and a bridge interface.
# We add the tap to the bridge.
# An external program, like dhcpcd, will configure the IP on the bridge
#interfaces="tun0 br0"
#ifup_tun0="tunctl -t \$int"
#ifdown_tun0="tunctl -d \$int"
#ifup_br0="brctl addbr \$int; brctl add \$int eth1; brtctl add \$int eth2"
#ifdown_br0="ifconfig \$int down; btctl delbr \$int"

# Create VLAN
#interfaces="eth0_2 eth0_3 eth0_4"
#ifup_eth0="vconfig add \$int 2; vconfig add \$int 3; vconfig add \$int 4"
#ifconfig_eth0_2="192.168.2.10 netmask 255.255.255.0"
#ifconfig_eth0_3="192.168.3.10 netmask 255.255.255.0"
#ifconfig_eth0_4="192.168.4.10 netmask 255.255.255.0"
#ifdown_eth0="vconfig rem \$int.2; vconfig rem \$int.3; vconfig rem \$int.4"

# Normally you would use wpa_supplicant to configure wireless, but you can
# use iwconfig also
#ifup_wlan0="iwconfig \$int key s:secretkey enc open essid foobar"


Desktop manager is KDE

It's more a nuisance than a problem - otherwise Sabayon rocks
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: wifi etho connection

Postby Fitzcarraldo » Fri Mar 18, 2011 10:02

I have to ask the obvious question just to rule it out: You do have 'Connect automatically' ticked in 'Manage Connections', I take it?

Have you tried the following openSUSE KDE solution on your SL KDE installation?: opensuse 11.2 KDE does not autoconnect (always ask for pwd).

Moving this to the Networking and Wireless shed (forum).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wifi etho connection

Postby Austlig » Sun Mar 20, 2011 1:09

Apologies for taking some time to get back, I've had a look at everything I can (not that I know a great deal), the 'connect automatically' is ticked, I even unticked it and rebooted and re-ticked it and rebooted, When I boot up I get the "connections secrets" screen, the password is already in there, when I click OK, nothing happens, I then have to click the task-bar icon, bring up that screen, click on the vendor's name, bring up the "connections secrets" screen again, click OK and it connects. I checked that link, Fitzcarraldo, but I could not find an "Other" in System Settings-Network and Connectivity, I checked Opensuse 11.4 and the System Settings screen is the same as SL, maybe 11.2 is different. As I said it's more of a nuisance than a problem. Is there a file or something that needs modifying with the password or SSID to connect automatically?
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: wifi etho connection

Postby Fitzcarraldo » Sun Mar 20, 2011 2:57

Austlig wrote:I checked that link, Fitzcarraldo, but I could not find an "Other" in System Settings-Network and Connectivity, I checked Opensuse 11.4 and the System Settings screen is the same as SL, maybe 11.2 is different.

openSUSE 11.2 used KDE 4.3. The option has been moved in KDE 4.6. Do the following:

1. Click on Kickoff
2. Click on System Settings
3. Double-click on Account Details
4. Click on KDE Wallet in the left pane of the window
5. Make sure 'Enable the KDE wallet subsystem' is not ticked
6. Click Apply

1. Click on the Network Management icon in the System Tray
2. Click on Manage Connections...
3. Click on Other in the left pane of the window
4. If not already selected, select '"in file (unencrypted)" for 'Store connection secrets:'

However, I've just tried to connect to my WPA-encrypted home wireless network using kDE 4.6.1 in SL instead of wired Ethernet and experience the same behaviour as you do, even with KWallet disabled and the connection secrets stored in an unencrypted file. So it looks like a bug in KDE 4.6.1 to me (openSUSE 11.4 shipped with KDE 4.6.0).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wifi etho connection

Postby Austlig » Sun Mar 20, 2011 6:16

Thanks, Fitzcarraldo and packetknife, for the help. I connected via cable and the problem does fix for me also. But ethernet cable is not convenient, so I'll bear with wifi until the fix.
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: wifi etho connection

Postby Fitzcarraldo » Sun Mar 20, 2011 6:19

I've just noticed the thread knetworkmanager-4.4.0_p201102 no longer automatic connect which is about the same problem.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wifi etho connection

Postby Fitzcarraldo » Sun Mar 20, 2011 8:30

Well, I've managed to get my nettop working like my main laptop: When I log in to KDE I am prompted for the KWallet password (which I made the same as my user account password, for convenience) and, once I have entered the KWallet password, Network Management connects automatically to my WPA-encrypted wireless network.

I did the following to reset KWallet and Network Management:

1. log out.
2. Press Ctrl-Alt-F1 to get to a virtual terminal.
3. Log in to my user account.
4. Enter the following commands:
Code: Select all
rm -rf ~/.kde4/share/apps/networkmanagement
rm -rf ~/.kde4/share/apps/kwallet
rm ~/.kde4/share/config/networkmanagementrc
rm ~/.kde4/share/config/kwalletrc

5. Log out.
6. Press Ctrl-Alt-F7 to get back to the KDE log in screen.
7. Log in to KDE.
8. Kickoff > System Settings > Account Details > KDE Wallet shows that the KDE Wallet subsystem is enabled. Leave it that way.
9. Right-click on Network Management and select Network Management Settings.
10. Click 'Add' under the Wireless tab.
11. Enter all the wireless network details under the three tabs, tick 'Connect automatically' and click 'OK'.
12. A KDE Wallet Service wizard pops up.
13. Select 'Basic setup' and click 'Next'.
14. Select 'Yes' and enter a password of your choice (twice), then click on 'Finish'.
15. A KDE Wallet Service window will pop-up. Re-enter the password you just specified.
16. Another window pops up with the message "The application 'KDE Daemon' has requested access to the open wallet 'kdewallet'". Click 'Allow Always'.
17. Click 'Apply' and 'OK'.

Now, whenever you log in to KDE, you will also be prompted by a KDE Wallet Service pop-up window to enter your KDE Wallet password. Once you have entered that, the wireless connection will be made automatically.

Note: If you want the connection to be made without being prompted by the KDE Wallet Service after you log in to KDE, don't enter a password in Step 14 above; just click on 'Finish'. Hey presto, you will be connected automatically to your wireless network every time you log in.

There are two warnings I must give you:

1. If you decide to specify no password for the KDE Wallet Service, you must not use it to store passwords for other applications, as they will not be secure.

2. Notice how easy it is to wipe out your KWallet wallet in Step 4. So anyone with access to your user account password could wipe out your wallet with all your stored passwords. So it is important to have a strong password for your user account as well as the root account.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wifi etho connection

Postby Austlig » Mon Mar 21, 2011 22:56

For me, this the best option, it means that my wireless connection can only be accessed with a password - better security all round. Problem solved for me - I hope future update won't change this, although it could easily be re-configured. I've marked this solved. Thanks again, Fitzcarraldo
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Next

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 0 guests

cron