Disable wifi button [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Disable wifi button [Solved]

Postby dabbill » Fri Feb 11, 2011 16:53

I am trying to find a way to disable my touch sensitive wifi/bluetooth button on my notebook.
There is no options in the bios to disable it. Also it just started yesterday after running for over a week with out changing any software. It does it randomly so i cant tell if something else is causeing it. Running tail -f /var/log/messages shows the same messages when i hit the button or when it disables on its own.

Here is pastbin of it

http://pastebin.com/kvCQrfFF

Thanks.
Last edited by dabbill on Fri Mar 04, 2011 19:34, edited 1 time in total.
dabbill
Baby Hen
 
Posts: 6
Joined: Sun Feb 06, 2011 5:28

Re: Disable wifi button

Postby Fitzcarraldo » Fri Feb 11, 2011 17:37

I'm not sure, but you may be able to disable it by rebuilding the kernel if there happens to be a kernel configuration parameter for it. Presumably you want to disable the ability to switch off WiFi? What model is your wireless controller? Post output of the command lspci run as root user.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Disable wifi button

Postby dabbill » Fri Feb 11, 2011 18:40

Yea, i want it so that you cant turn the wifi off with the button, and hopefully it will stop turning off by it self.
Here is the output of lspci

http://pastebin.com/25ZZma8Z

Here is another output from /var/log/messages

http://pastebin.com/GXBTWv3J
http://pastebin.com/wHaEJq2b
dabbill
Baby Hen
 
Posts: 6
Joined: Sun Feb 06, 2011 5:28

Re: Disable wifi button

Postby Fitzcarraldo » Sat Feb 12, 2011 7:37

Try installing and using the rfkill utility (as root user):

Code: Select all
* net-wireless/rfkill
     Available versions:  (~)0.1 (~)0.2 0.4
     Homepage:            http://wireless.kernel.org/en/users/Documentation/rfkill
     Description:         Tool to read and control rfkill status through /dev/rfkill

Version 0.4 is in the Entropy repository.

Code: Select all
rfkill list all
man rfkill
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Disable wifi button

Postby dabbill » Mon Feb 28, 2011 19:51

A update for network manager come through and havent had the problem in a few days, so not sure what was going on.
dabbill
Baby Hen
 
Posts: 6
Joined: Sun Feb 06, 2011 5:28

Re: Disable wifi button

Postby Fitzcarraldo » Fri Mar 04, 2011 19:29

Is it still working correctly?

If not, probably the easiest thing to do would be to rebuild the kernel (see SL Wiki article HOWTO: Upgrade kernel using genkernel) with CONFIG_RFKILL_INPUT not set (i.e. not "y" and not "m"), and then use the userspace net-wireless/rfkill tool that I told you about in an earlier post to enable/disable wireless.

If your problem is solved, please mark the thread solved. To do this click on the EDIT button in the first post and append " [Solved]" to the Subject text. Thanks. Why, and how to add "[Solved]" to your post. Please read.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Disable wifi button

Postby dabbill » Fri Mar 04, 2011 19:33

Gave it a few more days and seems to be still working fine. Thanks for the help, tho not sure what actually was done to fix it.
dabbill
Baby Hen
 
Posts: 6
Joined: Sun Feb 06, 2011 5:28

Re: Disable wifi button [Solved]

Postby Fitzcarraldo » Fri Mar 04, 2011 21:25

My guess is that there was a bug in Intel's microcode (net-wireless/iwl5000-ucode) for your model of wireless controller (Intel PRO/Wireless 5100) or in the kernel module iwlagn for your model, or in the RFKILL driver, as Google shows some problems with the RFKILL driver for the 5100 model a few months ago.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Disable wifi button [Solved]

Postby dabbill » Fri Mar 04, 2011 21:35

Yea i am not sure, but it seems to be working now so i will just leave it alone. :)
Thanks for the help.
dabbill
Baby Hen
 
Posts: 6
Joined: Sun Feb 06, 2011 5:28


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 0 guests