Problema actualización kde 4.6

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Problema actualización kde 4.6

Postby daniel23 » Tue Feb 01, 2011 13:48

acabo de actualizar todo el sistema y se me ha actualizado kde, pero al reiniciar y iniciar sesión arranca kde y luego me da el siguiente error: kdeinit4 PID: 7208 Señal: Segmentation fault (11) . desaparece la barra de abajo, los iconos de ven raros ....
¿hay alguna forma de arreglar los problemas o almenos dejar la instalación como me venia de serie recién instalada la 5.5?
gracias por adelantado
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby daniel23 » Tue Feb 01, 2011 15:20

se me acaba de ocurrir que quizás reinstalando kde 4.6 de nuevo se me solucionaría el problema pero no se como se hace¿es buena idea?
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby DHalens » Tue Feb 01, 2011 17:23

kdeinit4 pertence al paquete kdelibs
Para reinstalar todo los paquetes ya instalados de kde-base:
Code: Select all
equo install -a `equo query installed kde-base -q`


A mi personalmente me parece mas un problema al cargar la sesión guardada. Quizás simplemente seleccionando que inicie una sesión nueva en "arranque y apagado, gestión de sesiones" del panel de control y entrando de nuevo a kde lo arregle. Si con eso va, puedes reactivarlo de nuevo, si te gusta tenerlo activado.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Problema actualización kde 4.6

Postby joost » Tue Feb 01, 2011 21:01

Sorry for the English but maybe you understand it:

To be sure, try this:
Code: Select all
equo update
equo upgrade


Due a small problem serverside for s short time there were 2 KDE versions in the repository. This has been corrected shortly after. Above command should make sure you have everything installed correctly.

Also you want to reload dbus after a KDE migration to a new version. (Or simply reboot!)
joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Problema actualización kde 4.6

Postby daniel23 » Fri Feb 04, 2011 15:34

siento haber tardado tanto en responder pero no he tenido mucho tiempo hasta ahora, muchas gracias a los 2, ya me funciona todo perfectamente, pero tengo 2 pequeños problemas algo molestos: no se por que no me funciona smooth-tasks en kde 4.6 :s y me salen siempre 2 applets de magneto al iniciar el sistema, ¿desinstalo magneto y vuelvo a instalarlo a ver si asi solo me sale una vez?
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby daniel23 » Fri Feb 04, 2011 18:44

¿es posible que tenga magneto instalado en 2 versiones distintas? es una idea que se me acaba de pasar por la cabeza
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby DHalens » Fri Feb 04, 2011 22:55

Parece que hay mas gente con el problema ese con magneto.
Los paquetes de magneto instalados puedes verlos con equo query installed magneto -q

Respecto a smooth-tasks, en mi caso mata el escritorio... Voy a ver si reporto el problema con la traza inversa o veo una solución por ahí.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Problema actualización kde 4.6

Postby daniel23 » Fri Feb 04, 2011 23:30

parece que solo tengo instalado magneto una vez:
[email protected] ~ $ equo query installed magneto -q
app-misc/magneto-loader-1.0_alpha9
kde-misc/magneto-kde-1.0_alpha9-r1
sys-apps/magneto-core-1.0_alpha9
¿que hago para que solo me salga un solo magneto? ¿ elimino sys-apps/magneto-core, # kde-misc/magneto-kde y app-misc/magneto-loader:0? me da miedo borrarlos y que luego no me arranque ninguno :s.
Lo de smooth ojalá descubras la solución, para mi kde no es lo mismo sin ese gestor y me pasa exactamente lo mismo que a ti xD
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby daniel23 » Sat Feb 05, 2011 14:15

reinstalar magento no sirve de nada,:s ya no se que hacer
daniel23
Simple Hen
 
Posts: 95
Joined: Sat Oct 10, 2009 22:16

Re: Problema actualización kde 4.6

Postby DHalens » Sat Feb 05, 2011 18:19

Según el programador, es cosa de KDE: http://bugs.sabayon.org/show_bug.cgi?id=2144 :roll:
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Next

Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest

cron