problema Compiz

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

problema Compiz

Postby BoTters » Wed Dec 08, 2010 1:48

hola amigos, hoy martes 7 de diciembre instale las actualizaciones disponibles
y cuando todo termino reinicie sabayon (5.4 gnome x86), luego quise activar el compiz
como siempre lo hago pero no se me activaron los efectos. Trate de
reconfigurarlo pero nada, el compiz estaba muerto, si me aparecia el icono al lado de la hora pero
al tratar de cambiar alguna configuracion nada hacia efecto.

fui al sulfur, en aplicaciones puse compiz, salia una lista seleccione todo para reinstalar.
luego reinicie y no obtuve ningun resultado. intente desintalando el compiz(se borro el icono en el escritorio
y en la barra de aplicaciones) despues instalarlo nuevamente
todo esto con sus respectivos reinicio de sistema, pero aun asi nada consigo

que podra ser amigos, estoy que instalo sabayon 5.4 otra vez... que me recomiendan que haga?

saludos cordiales
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08

Re: problema Compiz

Postby DHalens » Wed Dec 08, 2010 12:39

Inicia el fusion-icon desde una consola. Debería de poner algún tipo de error.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: problema Compiz

Postby BoTters » Wed Dec 08, 2010 17:41

DHalens wrote:Inicia el fusion-icon desde una consola. Debería de poner algún tipo de error.



tomé un pantallazo y esto me mostro cuando lo inicie por la consola
Image
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08

Re: problema Compiz

Postby DHalens » Wed Dec 08, 2010 17:58

Comprueba que el driver de la tarjeta gráfica esté bien instalados. Como root en una consola:
glxinfo |grep direct tiene que poner direct rendering Yes
eselect kernel list tiene que coincidir en número con uname -r
eselect opengl list tiene que ser el de tu tarjeta gráfica.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: problema Compiz

Postby BoTters » Wed Dec 08, 2010 20:19

DHalens wrote:Comprueba que el driver de la tarjeta gráfica esté bien instalados. Como root en una consola:
glxinfo |grep direct tiene que poner direct rendering Yes
eselect kernel list tiene que coincidir en número con uname -r
eselect opengl list tiene que ser el de tu tarjeta gráfica.



esto me aparecio

mike@Mike ~ $ su
Contraseña:
Mike mike # glxinfo |grep direct
Error: couldn't find RGB GLX visual or fbconfig
Mike mike # eselect kernel list
Available kernel symlink targets:
[1] linux-2.6.34-sabayon *
Mike mike # uname -r
2.6.34-sabayon
Mike mike # eselect opengl list
Available OpenGL implementations:
[1] xorg-x11 *

datos adicionales de mi notebook

dell inspiron 1420
2 gb de ram
250 gb disco duro
targeta grafica integrada GMA
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08

Re: problema Compiz

Postby DHalens » Fri Dec 10, 2010 19:48

Buscando por ahi, he visto que parece que lo que tienes que hacer es desinstalar los drivers de nvidia y ati y quizas reinstalar los de intel.
Code: Select all
equo remove ati-drivers nvidia-drivers
equo install xf86-video-intel
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: problema Compiz

Postby BoTters » Sat Dec 11, 2010 20:38

DHalens wrote:Buscando por ahi, he visto que parece que lo que tienes que hacer es desinstalar los drivers de nvidia y ati y quizas reinstalar los de intel.
Code: Select all
equo remove ati-drivers nvidia-drivers
equo install xf86-video-intel


realice esos pasos y todabia no consigo nada... nose que podra ser
desde que actualice que no tengo los efectos del compiz.
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08

Re: problema Compiz

Postby BoTters » Thu Dec 16, 2010 0:41

finalmente reinstale sabayon 5.4 x86 gnome, los efectos del compiz muy bien
todo sin ningun problema pero al momento de hacer un sudo equo update
me actualiza todo... despues me pregunta que ejecute equo conf update

despues reinicio me carga el sistema y antes de entrar al escritorio
me aparece este mensaje diciendo "falló al iniciar el servidor X, parece como si no estuviera
configurado correctamente" doy enter me aparece mucha informacion
del diagnostico, todo que ver con xorg.conf.d o /etc/X11/xorg.conf


entonces debe ser un error en la actualizacion por ello que el compiz no me funcionaba
y es con la tarjeta de video. luego por consola puse los comandos que anunciaste mas arriba
equo remove ati-drivers nvidia-drivers
equo install xf86-video-intel

reinicie y me salio el siguiente error al entrar e iniciar sesion

"ocurrio un error al cargar el tema sabayon linux
no se a podido reconocer el formato de imagen del archivo /usr/share/backgrounds/kgdm.jpg"

despues me dice que se cargara un tema basico... despues entro a linux y la grafica es muy precaria
pero algo es algo...

entonces supongo que los drivers que se actualizan de mi notebooks no son los correctos, ya que cuando instalo sabayon anda muy bien, pero al momento de actualizar es en donde estan los problemas

lo otro que encontre raro es que en esta version de no encuentro la configuracion para los efectos del compiz,
esto a que se debe?

saludos

caracteristicas de mi notebook

procesador: intel dual core de 2.0 ghz
tarjeta grafica_ Intel Graphics Media Accelerator X3100
disco: 250 gb
memoria ram: 2gb
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08

Re: problema Compiz

Postby BoTters » Fri Dec 17, 2010 2:01

solucione el problema. despues de muchos intentos instalando y desintalando los drivers
de la tarjeta de video finalmente consegui dar con el indicado y ahora
se arreglo el problema, desintale los drivers, luego los instale otra ves

lo raro es que ya lo habia intentado antes pero sin exito, me cambie a sabayon 5.4 g x64
pense que instalando esa arquitectura se me iba a solucionar, pero paso lo mismo
y luego realice las instucciones de los drivers..

muchas gracias..

una ultima consulta, por que no esta la opcion para editar los efectos del compiz, como el fuego editar el cubo etc?
lo tuve que instalar aparte.. bueno

ya solucione todo :D

gracias again
BoTters
Simple Hen
 
Posts: 96
Joined: Mon Aug 25, 2008 18:08


Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest

cron