Issue with equo/sulfur since recent update

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Issue with equo/sulfur since recent update

Postby thorizal » Thu Oct 21, 2010 19:13

Dear all,

On my wife laptop running sabayon 5.4 gnome edition Magneto/sulfur/equo doesn't launch anymore returning me the same message:
"invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo
Cannot automatically recover from this."

This issue appear since last update throug sulfur which ask me to remove gnome-aspell if I remember well and I've done it oddly.
Since that gnome have gnome bar in english that's not a big issue but it seems it gives many problem with my locale, even if my locale.gen seems OK.

Any idea?

Thanks in advance
thorizal
Baby Hen
 
Posts: 5
Joined: Sun Oct 10, 2010 18:07

Re: Issue with equo/sulfur since recent update

Postby lxnay » Thu Oct 21, 2010 21:48

Your environment is misconfigured or you messed up LC_ALL, LANGUAGE, LANG variables (or maybe, you're hitting a corner case bug?). What's the output of "env" and what's the content of /etc/env.d/02locale
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Issue with equo/sulfur since recent update

Postby thorizal » Thu Oct 21, 2010 23:15

here's the output of the env command
Code: Select all
MANPATH=/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.20.1/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.4.2/man:/etc/java-config/system-vm/man/
ORBIT_SOCKETDIR=/tmp/orbit-myriam
SSH_AGENT_PID=6547
TERM=xterm
SHELL=/bin/bash
XDG_MENU_PREFIX=gnome-
XDG_SESSION_COOKIE=c783803966318cbeaefb380046e9bafa-1287706117.865098-1716641386
GTK_RC_FILES=/etc/gtk/gtkrc:/home/myriam/.gtkrc-1.2-gnome2
WINDOWID=44040195
SYSFONT=latarcyrheb-sun16
GNOME_KEYRING_CONTROL=/tmp/keyring-W0hn33
USER=myriam
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
PRELINK_PATH_MASK=/usr/lib/libfreebl3.so:/usr/lib/libnssdbm3.so:/usr/lib/libsoftokn3.so
GDK_USE_XFT=1
SSH_AUTH_SOCK=/tmp/keyring-W0hn33/ssh
SESSION_MANAGER=local/Deathstar:@/tmp/.ICE-unix/6510,unix/Deathstar:/tmp/.ICE-unix/6510
USERNAME=myriam
PAGER=/usr/bin/less
CONFIG_PROTECT_MASK=/etc/gentoo-release /etc/sandbox.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/ca-certificates.conf /etc/texmf/web2c /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/revdep-rebuild /etc/splash
XDG_CONFIG_DIRS=/etc/xdg
DESKTOP_SESSION=gnome
PATH=/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.4.2:/usr/games/bin
HG=/usr/bin/hg
GDM_XSERVER_LOCATION=local
PWD=/home/myriam
JAVA_HOME=/etc/java-config-2/current-system-vm
EDITOR=/bin/nano
XCURSORS_THEME=Blue
JAVAC=/etc/java-config-2/current-system-vm/bin/javac
LANG=fr_FR.UTF-8
GDM_LANG=fr_FR.UTF-8
GDMSESSION=gnome
HOME=/home/myriam
JDK_HOME=/etc/java-config-2/current-system-vm
SHLVL=1
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
LOGNAME=myriam
PYTHONPATH=/usr/lib/entropy/libraries
LESS=-R -M --shift 5
CVS_RSH=ssh
XDG_DATA_DIRS=/usr/share:/usr/local/share:/usr/share/gdm
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-a9LCOuHCKm,guid=863a72dfaee73b2fe77d91b14cc0d606
LESSOPEN=|lesspipe.sh %s
INFOPATH=/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.20.1/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.4.2/info
WINDOWPATH=7
DISPLAY=:0.0
USB_DEVFS_PATH=/dev/bus/usb
OPENGL_PROFILE=xorg-x11
LADSPA_PATH=/usr/lib/ladspa
SANE_CONFIG_DIR=/etc/sane.d
CONFIG_PROTECT=/etc/entropy /usr/share/X11/xkb
COLORTERM=gnome-terminal
XAUTHORITY=/tmp/.gdm68TDLV
_=/usr/bin/env


and the /etc/env.d/02locale seems coherent:
Code: Select all
LANG="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"


I'm a bit surprise as the only thing I've done is to follow what sulfur told me.
thorizal
Baby Hen
 
Posts: 5
Joined: Sun Oct 10, 2010 18:07

Re: Issue with equo/sulfur since recent update

Postby lxnay » Thu Oct 21, 2010 23:22

what happens if you type "LC_ALL=en_US.UTF-8 equo match --installed glibc" for example ?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Issue with equo/sulfur since recent update

Postby thorizal » Thu Oct 21, 2010 23:26

Same error:
invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo match --installed glibc
Cannot automatically recover from this.
thorizal
Baby Hen
 
Posts: 5
Joined: Sun Oct 10, 2010 18:07

Re: Issue with equo/sulfur since recent update

Postby lxnay » Fri Oct 22, 2010 7:26

Then I suppose your glibc package is broken (or you did something you don't want to tell us...).
open /usr/lib/entropy/libraries/entropy/const.py and delete the line containing "raise SystemExit(1)". Then reinstall glibc:
Code: Select all
equo install glibc
and see if the nag message goes away
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Issue with equo/sulfur since recent update

Postby thorizal » Fri Oct 22, 2010 17:55

Ok, I'm a bit surprised that you suggest I could have hide some other mistakes, it is not in my interest as I'm requiring your help.

Perhaps I've done something else wrong, but I'm used with linux for 7 years now (I use Slackware on my laptop since the begining), and even if I'm not a geek, I generally touch only the files I know, and with distribution that have GUI package/config management I genrally don't touch anything since It can break the config files.

Nervertheless thanks for your answer, I manage with the change in the config file to launch equo/sulfur/magneto but, the error steal there.

As told previously, this message error occurs since sulfur ask me to remove, I believe: gnome-aspell (I'm not so used with gnome as it is not supported in Slackware) but I can't find it anymore in the repository.

So at the end, I'm able to launch equo/sulfur/magneto but I still have my gnome bar in English (I will search on gnome help how I can change that) and when I launch equo through the command line, I still have the error message.

Perhaps simply I need to reinstall the locales, can you tell me through which package it is installed?
thorizal
Baby Hen
 
Posts: 5
Joined: Sun Oct 10, 2010 18:07

Re: Issue with equo/sulfur since recent update

Postby lxnay » Fri Oct 22, 2010 22:09

You either broke glibc or glibc itself got broken. That's why Entropy crashes and your apps are not localized! PLEASE follow my directions and try to reinstall glibc.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Issue with equo/sulfur since recent update

Postby thorizal » Sat Oct 23, 2010 18:24

Sorry, I wasn't clear in my last answer, with the change in the conf file, I manage to lauch equo but I still have the error message even with reinstall glibc.

I have launched an equo libtest to see if I got some other libs broken or missing.
thorizal
Baby Hen
 
Posts: 5
Joined: Sun Oct 10, 2010 18:07

Re: Issue with equo/sulfur since recent update

Postby Fitzcarraldo » Sat Nov 27, 2010 19:28

Did you ever solve your problem? I experienced the same thing after installing SL 5.4 E17 x86 (I selected English and UK keyboard during installation), upgrading and using the E17 Settings Panel to try to change the locale and keyboard to English|Great Britain. I followed the Gentoo Localization Guide which didn't get rid of the error message (but did change my keyboard mapping from US to UK, as I wanted) so I used the shotgun approach of adding all the following to /etc/env.d/02locale and rebooting:

Code: Select all
#LANG="en_GB.UTF-8" # Changed by me from en_US to en_GB after installation. Then commented out when I added the long list below.
#LC_COLLATE="C" # Added by me after installation? Anyway, commented out when I added the long list below.
SYSFONT="latarcyrheb-sun16"

# Added all these because I was fed up with:
# a) the locale command returning everything as "en_US" despite me following the Gentoo Localization Guide;
# b) the error message "invalid filesystem encoding..., must be UTF-8. ...
# ....Please execute: LC_ALL=en_US.UTF-8 /usr/bin/equo" when I used the equo command.
LANG="en_GB.UTF-8"
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"

After that the error message went away. So give those a try, replacing en_GB.UTF-8 with fr_FR.UTF-8 in your case.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 5 guests