Sabayon XFCE - Wireless Manager?

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
spatialminds
Baby Hen
Posts: 18
Joined: Wed Aug 11, 2010 20:51

Sabayon XFCE - Wireless Manager?

Post by spatialminds » Sat Aug 28, 2010 20:42

Does the XFCE version of Sabayon come with a GUI utility to manage wireless networks?

I'm setting up an older laptop for my son. We first tried the KDE version of Sabayon which ran a bit slow, so we are now trying the XFCE version instead. The KDE version of Sabayon recognized our wireless network out of the box and offered a UI for configuring it. XFCE runs a lot snappier, but we are having trouble figuring out the best way to configure our wireless network.

Should we just "emerge -av wicd"?

Thanks for the help.

spatialminds
Baby Hen
Posts: 18
Joined: Wed Aug 11, 2010 20:51

Re: Sabayon XFCE - Wireless Manager?

Post by spatialminds » Sat Aug 28, 2010 20:47

OK.. we found that if we right click on the network item in the XFCE bar and select "Edit Connections" that there is a tab for wireless connections. It doesn't seem to be autodetecting our network the way it did under KDE. Is there a good FAQ that will walk us through troubleshooting this?

Thanks again!

rac
Baby Hen
Posts: 5
Joined: Thu Aug 06, 2009 2:30

Re: Sabayon XFCE - Wireless Manager?

Post by rac » Sun Aug 29, 2010 9:58

hi, i only installed the gnome network manager, and works fine.

equo install nm-applet

PD: i use corecdx
don't index
(identica-rac)

DontPanic
Old Dear Hen
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Sabayon XFCE - Wireless Manager?

Post by DontPanic » Mon Aug 30, 2010 23:00

I'd suggest installing wicd (equo will do it faster than 'emerge').

Wicd has a fairly good reputation for being a lightweight network configuration tool for wireless.

Using nm-applet (which will also pull in networkmanager) is also a good solution.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU [email protected] 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM

spatialminds
Baby Hen
Posts: 18
Joined: Wed Aug 11, 2010 20:51

Re: Sabayon XFCE - Wireless Manager?

Post by spatialminds » Thu Sep 30, 2010 7:12

Thank you both for your replies. I apologize for not responding sooner. I forgot to turn email notifications on for this forum and had the project on the back burner for a couple of weeks.

Today I tried both of the suggested options:

The nm-applet option isn't showing anything in XFCE. I don't see any applets to add to my XFCE toolbar, and nothing was configured to appear on its own. I'm not sure how to proceed with this option.

The wicd option had better luck, but still isn't working for me. When I login I get prompted for roots password to access the wireless devices, which I provide. I then receive an error message, "Could not connect to wicd's D-Bus interface. Check the wicd log for error messages." When I check the wicd error log I looked in /var/log/wicd/ and found no log files.

Any ideas on how to debug this particular problem?

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8113
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Sabayon XFCE - Wireless Manager?

Post by Fitzcarraldo » Thu Sep 30, 2010 11:46

D-Bus is causing problems for several people at the moment (see e.g. Re: Set up system time and Re: Can't login).

Did you do the following after installing the package?:

Code: Select all

equo conf update
also, have you removed NetworkManager from the default runlevel and added Wicd to the default runlevel? See the SL Wiki article HOWTO: Replace NM with WICD for details.

If those don't solve your problem, you might want to try the fix I gave in that system time post (see link above) as that involved networking.

Don't use Wicd myself *(NetworkManager works fine for me on my PCs), but Google throws up quite a few pages of posts with this error message for Wicd. Some other fixes to try include: a) editing /etc/wicd/wired-settings.conf and removing a redundant pair of square brackets at the end of the file; b) adding Wicd to the boot runlevel instead of the default runlevel; c) if it's not already there, adding the line sed -i 's/^\[\]$//' /etc/wicd/wired-settings.conf to the init file /etc/init.d/wicd just after the do_start() {.

Post Reply