Sabayon 5.3 KDE installer crash/partition problem [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby DontPanic » Thu Aug 26, 2010 3:25

I was also wondering if the issue wasn't somehow due to extended partitions.

I often install into my extended partitions, so I know it's possible. But we may have picked up a regression or ran into a new combination that is confusing the installer.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby light » Thu Aug 26, 2010 3:58

You know before I was installing Sabayon on the drive where previously another distro resided. I wanted to use just Sabayon and wipe the other distro. However, when I was trying to delete all the partitions on the drive through installer, it couldn't delete logical ones. I guess I might need to try on a completely empty drive, or use another option where installer just shrinks other distro's partitions and then installs itself on the empty space.
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby light » Thu Aug 26, 2010 8:42

Just a thought. Maybe I can just wait for the 5.4 Sabayon, maybe (hopefully) anaconda will be changed from its current form, give more options. Judging from the past releases it takes around 3-4 months for the next release to come out. So In June we had 5.3, so very soon there should be 5.4.
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby wolfden » Thu Aug 26, 2010 9:19

try one of the daily iso, they will be 5.4 and have most of it implemented
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby light » Fri Aug 27, 2010 3:12

Hi wolfden,

Actually what you saying might be a good idea. I didn't want to try nightly/daily builds because I didn't have a DVD disk to spare. I'll get one today and will try the newer version 5.4. I would really like to also say good stuff about Sabayon to my friends, just like what I hear and read from users who enjoy it everyday. But now I can only drool over reviews and not over my own Sabayon.




**Mounting a damaged Ext3 file system with only "-o ro" option will result in data modification during the recovery process. For mounting in forensically sound manner use "ro, loop". ~ITDefence**
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby DontPanic » Fri Aug 27, 2010 13:08

If your computer can boot from a USB, our DAILYs have been working pretty well with unetbootin.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Sabayon 5.3 KDE installer crash, grub/parition problem.

Postby light » Wed Sep 01, 2010 1:16

Sorry for a long delay, I finally found some time to download daily and unetbootined it on usb. I have to say that daily looks much better than official 5.3 (I downloaded x86_K). Also, I was surprised to see E17 version too. I wonder if it is as polished as KDE or GNOME version. I am not sure if ibus works with it or not (well, one day I can try to figure it out, I am sure it can be done).
Anyway as per the problems with installation. There were none. I installed it without any crashes, new anaconda is way faster (and little bit prettier too). I didn't boot into Sabayon on my hard drive yet, so I can't say that all is perfect there, but I think it should be ok.

I installed grub not into mbr (/dev/sda), but into Sabayon's partition. I didn't want to mess with my Slackware (it is my primary distro), and it uses LILO. I was not sure Sabayon's grub would pick it up or not.

So now I just need to figure out how to include entry for Sabayom into LILO. Form what I heard there is need for some trickery. In any case, I think I can mark this thread as [SOLVED]

Thank you wolfden and DontPanic!
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Re: [SOLVED] Sabayon 5.3 KDE installer crash/partition probl

Postby DontPanic » Wed Sep 01, 2010 4:37

We concentrate our effort on the Gnome and KDE versions. The E17 spin is fairly experimental. But now that you know how to put it on a USB, you can make your own decision. :)

AFAIK, lilo should work just fine with Sabayon. Although, I don't think there are any tools to auto-configure lilo for you in Sabayon.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: [SOLVED] Sabayon 5.3 KDE installer crash/partition probl

Postby light » Wed Sep 01, 2010 5:19

Yeah, I thought that E17 was experimental, it wasn't mentioned on the website (well, maybe I missed it), and you can find it only in the /daily branch in the mirrors. E17 has its merits, but if I want to use it, then I guess I can get Elive, or GoblinX (can't remember, now) or even MacPup. They are not so experimental anymore and quite stable.

You know, until you guys mentioned unetbootin I didn't even consider it. I didn't have it on my distro at that time and I completely forgot about it. Shame on me. :o

Hey, no worries about lilo conf. Yes, it should work, but adding entries in it is different than in grub. I hope I will succeed. At this point there is no auto-conf tools for chain-loading grub in lilo. Sad, though.
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Re: Sabayon 5.3 KDE installer crash/partition problem [Solve

Postby light » Thu Sep 02, 2010 1:40

Just an update.

I tweaked lilo to boot Sabayon. It boots fine without problems. So just to confirm the problem is truly solved.

I can say that I was surprised to see Sulphur's layout and progress output. And I actually enjoyed it. It is refreshing.
light
Young Hen
 
Posts: 35
Joined: Fri Aug 20, 2010 3:49

Previous

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest