Problems installing linux

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Post Reply
Young Hen
Posts: 30
Joined: Mon Aug 18, 2008 0:07

Problems installing linux

Post by calebs » Wed Jul 21, 2010 19:22

Hello all i have a problem that i'll try to explain the best i can.
I used to had an 500 gb hard drive, a primary partition to boot win vista/7, an extended partition with the rest, 6 logical units to use with windows and 3 more to use with linux (20 gb root, 10 gb home and 4 gb swap)
I used to had opensuse then.
I buyed new hard drive (1,5 gb) and with ghost, cloned it changing the size of partitions for windows leaving the same size for linux.
This is the partition layout with cfdisk

Tabla de particiones para /dev/sda

Primer Último
Nº Tipo Sector Sector Despl. Longitud Tipo sist. fich. (ID) Indicad.
-- ------- ----------- ----------- ------ ----------- -------------------- ----
1 Primari 0 225295559 63 225295560 HPFS/NTFS (07) Inicio
2 Primari 225295560 2930272064 0 2704976505 W95 Ext'd (LBA) (0F) Inicio
5 Lógica 225295560 242083484 63 16787925 HPFS/NTFS (07) Ninguno
6 Lógica 242083485 2832966359 63 2590882875 HPFS/NTFS (07) Ninguno
7 Lógica 2832966360 2834653184 63 1686825 W95 FAT32 (0B) Ninguno
8 Lógica 2834653185 2836131164 63 1477980 W95 FAT32 (0B) Ninguno
9 Lógica 2836131165 2837753729 63 1622565 W95 FAT32 (0B) Ninguno
10 Lógica 2837753730 2839424489 63 1670760 HPFS/NTFS (07) Ninguno
11 Lógica 2839424490 2900953439 63 61528950 Linux (83) Ninguno
12 Lógica 2900953440 2920488479 63 19535040 Linux (83) Ninguno
13 Lógica 2920488480 2930272064 63 9783585 Linux swap / So (82) Ninguno

I used to had the grub on sda11 and modified the boot of windows to add a line there to choose linux. (the dd thing)
Downloaded new opensuse 11.3 and tried to install because old linux doesn't boot. When i do the installation went all fine but when i get to the grub installation step it says it can find the disk.
After trying several times and read some forums, booted with live cd's to try to fix grub gived up. Even tried to install grub on MBR and not on sda11 but didn't work either, and then back to my old (i mean new) sabayon linux.
Downloaded last x86 version burned, booted and installed.
It asked me where do i want to put the grub, i answerd in /dev/sda11, installation went fine (i don't see any errors, but the installer closed alone after finishing instal (don't know if that's the way should work), then did again the dd if=/dev/sda11 /mnt/sda1/linux.bin bs=512 count=1 to make the file and...
when i restarted and choose linux on win menu, rebooted again and again.
Booted again with live cd, tried to fix or see what's the grub problem but i can't solve it, tried to chroot to the linux partition, the files are there, grub.cfg is not on /boot/grub (don't know why).

Any ideas, any log that i can bring here? Or is a problem with grub that doesn't boot on a partition so far from the beginning of the disk?
Any help could be apreciated.
Ps. Excuse my english

User avatar
Sagely Hen
Posts: 1875
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Problems installing linux

Post by albfneto » Thu Jul 22, 2010 19:18

at the level of my knownledge, the Grub should be made even in the MBR, in all conditions that you can not use an external bootloader...
when the Grub is saved in a linux root partition, the boot not occurs!

is you Windows Vista or Seven?

in these windows, the boot sector should be in the master HDD, first sector, primary partition or sometimes problems may occurs.

also, vista and seven , reserves an small portition in the HDD, this is called "reserved space" and could not be removed, also, if the windows after installed, made a sector o "unalocated space" this is also used by windows itself cannot be use for "augments" an existing partition
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

Young Hen
Posts: 30
Joined: Mon Aug 18, 2008 0:07

Re: Problems installing linux

Post by calebs » Fri Jul 23, 2010 16:36

I don't think that was the problem, open suse 11.2 was working well before. With windows xp, vista and 7 (the one i have now). And before, sabayon and ubunto were working well too with that method. Yesterday tried with ubuntu 10.04 and same problem, installed fine with no errors but when it boot it restarts.
Could this be related to the disk size (1,5 tb), the bios of the mobo? Was working well with the 500 gb hd, also all 3 distros i've tried use different version of grub (opensuse 11.3, ubuntu 10.04 and last sabayon).
And yes, i've tried to install grub on mbr too but no luck too

User avatar
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Problems installing linux

Post by Fitzcarraldo » Fri Jul 30, 2010 13:13

Grub2 had (still has?) a problem with logical partitions (see Item 1 in Questions regarding the functional design of Grub2). I wonder if that is your problem.

Have you tried installing re-installing the Windows 7 bootloader in the MBR and using it to chainload Grub2 in a separate (primary) boot partition? You have so much space that a small (e.g. 100 MB) primary boot partition should not cause you any grief. See the SL wiki article HOWTO: Dual boot Sabayon Linux and Windows for the method I use. See also my post Re: Questions regarding the functional design of Grub2 regarding the correct syntax to use for the Grub2 commands.

Young Hen
Posts: 30
Joined: Mon Aug 18, 2008 0:07

Re: Problems installing linux

Post by calebs » Fri Jul 30, 2010 23:44

Hello again, thanks for your reply, it seems to be a common grub problem (1 and 2) because i've tried with many linux distros that had grub 1 and grub 2 and none worked.
The last thing i've done is get and old 30gb hard disk and plugged on the computer and installed linux there, installed grub in the mbr of that disk.
I still have the problem that windows boot menu doesn't chain very well with grub on the second disk, but if in boot time i choose to boot on the linux disk boots well.
It seems that grub confuses the order of the disk, and that's why doesn't start. If windows boots, then windows disk is sda (hd0,0) and linux is sdb(hd1,0) and when i boot with linux disk, the 30gb disk is sda and windows is sdb.
Well it is working now but not very well, i keep trying but now i had 30gb unused on my new disk, and had to use another disk that my poor psw has to deal with.
I'll wait for an grub update it seems.

Baby Hen
Posts: 6
Joined: Thu Oct 07, 2010 5:00

Re: Problems installing linux

Post by slbmeh » Thu Oct 07, 2010 6:16

I'm not sure if this is the exact line you had used or if it was just a typo posting to the forums...
dd if=/dev/sda11 /mnt/sda1/linux.bin bs=512 count=1
You're missing the outfile parameter, you need an 'of='... It should instead look something more like:

Code: Select all

dd if=/dev/<linboot> of=<winroot>/linux.bin bs=512 count=1
Replacing <linboot> with the partition that has grub installed to it's superblock, and <winroot> with a mount point of the partition that has the windows kernel on it.

From there you edit 'boot.ini,' or run 'bcdedit.exe' if you're using Windows Vista or later, to point the Windows Bootloader to the location of the grub bootloader file.
It seems that grub confuses the order of the disk, and that's why doesn't start. If windows boots, then windows disk is sda (hd0,0) and linux is sdb(hd1,0) and when i boot with linux disk, the 30gb disk is sda and windows is sdb.
Some BIOS handle drive numbering different than others. Some go by distance from the bridge, others consider master/slave, and others put the boot drive first. It may even be any combination of those and more. My best guess for the drives changing is either that Windows is Drive 1 the whole time and pretends to see itself as Drive 0 for it's own sanity purposes... Or, when the bootloader loads into memory and then is replaced by another by another bootloader's stage on another MBR the BIOS takes the drive with the most recently accessed MBR and calls that Drive 0. The second scenario is the least likely of the two I had mentioned.

Post Reply