en_GB.UTF-8 doesn't exist. [Solved]

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

en_GB.UTF-8 doesn't exist. [Solved]

Postby pepe999 » Tue Jun 29, 2010 21:48

Hi all,
I have installed SL 5.3 Gnome x64 and when I'm logging on, it says that en_GB.UTF-8 doesn't exist. While installing the system I have set all language/keyboard settings to UK. Has anyone experienced the same problem? I have done some research on the internet but haven't found any solution yet. It's not a huge issue but a bit annoying.. :)
Dell L502X - Core i7-2840QM/8GB DDR3/GF 540M 2GB/Corsair GT 240GB/Full HD
Debian 7
Win 7 still installed
Linux user no. 491024
pepe999
Advanced Hen
 
Posts: 258
Joined: Fri Mar 06, 2009 19:24
Location: Manchester

Re: en_GB.UTF-8 doesn't exist.

Postby Fitzcarraldo » Thu Sep 09, 2010 19:33

Did you ever solve this? Have a look in the /etc/env.d/02locale and ~/.bashrc files. My guess is that one or more of the locales is specified in those (or another config file somewhere) as en_GB.UTF-8 instead of en_GB.UTF8 or en_GB.utf8 (see Gentoo Linux Localization Guide for more information).

I see that the environment variable LANG on my laptop is also set to en_GB.UTF-8 but all the others are en_GB.UTF8. Have not noticed any error messages, but then I haven't been looking hard.

Code: Select all
$ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF8"
LC_NUMERIC="en_GB.UTF8"
LC_TIME="en_GB.UTF8"
LC_COLLATE="en_GB.UTF8"
LC_MONETARY="en_GB.UTF8"
LC_MESSAGES="en_GB.UTF8"
LC_PAPER="en_GB.UTF8"
LC_NAME="en_GB.UTF8"
LC_ADDRESS="en_GB.UTF8"
LC_TELEPHONE="en_GB.UTF8"
LC_MEASUREMENT="en_GB.UTF8"
LC_IDENTIFICATION="en_GB.UTF8"
LC_ALL=en_GB.UTF8
$ locale -a
C
en_GB
en_GB.iso88591
en_GB.utf8
en_US
en_US.iso88591
en_US.utf8
POSIX
$
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: en_GB.UTF-8 doesn't exist.

Postby Fitzcarraldo » Thu Sep 09, 2010 21:37

Actually, your problem has made me curious. Here's another official Gentoo document: Using UTF-8 with Gentoo. Notice it refers to UTF-8, not UTF8. So I think the correct locale should be defined as en_GB.UTF-8. I imagine that it does not matter whether one's installation uses en_GB.UTF-8 or en_GB.UTF8 (or en_GB.utf8, come to that), providing that it's done consistently throughout all config files and that the form of locale chosen has also been created using the locale-gen or localedef commands (see the Gentoo links I gave). Looking in my config files:

Code: Select all
# cat /etc/locale.gen
en_US.UTF-8 UTF-8
en_US ISO-8859-1
en_GB.UTF-8 UTF-8
en_GB ISO-8859-1
# cat /etc/env.d/02locale
LANG="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LANGUAGE="en_GB.UTF-8"
GDM_LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
SYSFONT="latarcyrheb-sun16"
# cat ~/.bashrc
#

I've just remembered that, when I last installed SL, I hacked /etc/profile to force the en_GB locale because the Thunderbird e-mail client would not display the date in UK format, despite me having set up the locale to en_GB via the Installer and KDE System Settings, so I added the following at the end of the /etc/profile file:

Code: Select all
# Following three lines added by Fitzcarraldo on 30.03.10 to get Thunderbird to display UK date format:
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF8"
LANGUAGE="en_GB.UTF8"

I see now that I made an error and assigned LANG as en_GB.UTF-8 but LC_ALL and LANGUAGE as en_GB.UTF8. So I'm going to fix what I've done in /etc/profile (i.e. set LC_ALL and LANGUAGE en_GB.UTF-8) and reboot to see what happens.

EDIT: Yep, I'm consistent now:

Code: Select all
$ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8

I'm not sure why locale -a returns en_GB.utf8, though.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: en_GB.UTF-8 doesn't exist.

Postby pepe999 » Fri Sep 10, 2010 15:04

Hi Fitzcarraldo,
I haven't solved it yet. I have reinstalled that system so the problem was gone. This problem has occurred because I have used / and /home on different partitions. I have installed just system before and left /home without formatting to keep my system settings. When I did a fresh install including formatting the /home partition, the problem disappeared. I think that the new install didn't like my old settings..
Dell L502X - Core i7-2840QM/8GB DDR3/GF 540M 2GB/Corsair GT 240GB/Full HD
Debian 7
Win 7 still installed
Linux user no. 491024
pepe999
Advanced Hen
 
Posts: 258
Joined: Fri Mar 06, 2009 19:24
Location: Manchester


Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 1 guest