TFTPD has adress troubles

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

TFTPD has adress troubles

Postby bartman » Wed Jun 16, 2010 21:11

HI,

Did not saw this elsewhere in the forum, seems not so much use it.

I try to get a tftp server going up, gentoo show 3 but I choose the one in the sulfur proposal : tftpd-hpa.

changed the

etc/conf.d/in.tftpd to point to the existing dir /tftpboot/

but when I do a

Code: Select all
/etc/init.d/in.tftpd start


there is a "failed to start" that seems to be due to the

"cannot bind to local IPv4 socket: Address already in use"

in /var/log/messages.

I'm near to be crazy as I uninstall and reinstall it, and the other two.
bartman
Simple Hen
 
Posts: 46
Joined: Thu Feb 22, 2007 10:08

Re: TFTPD has adress troubles

Postby Fitzcarraldo » Tue Sep 14, 2010 16:03

Not that I'm using TFTPD but is the following post any help to you: tftpd-hpa fails to start.?

Andrew Reid wrote:I ran into this recently -- it turned out that the non-hpa TFTP
had previously been installed on the machine, but even though it
had been removed and purged, there was still a tftp entry in
/etc/inetd.conf. Consequently, inetd was listening on the tftp
port, and prevented the tftp-hpa from starting.

I only found it by doing "netstat" -- because it's inetd
triggered, the "bad" tftp doesn't show up in the process list.
The fix, of course, is to just remove that line from
inetd.conf.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron