No Sound [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 11
Joined: Wed Oct 07, 2009 12:07

No Sound [Solved]

Post by nikhil » Sun May 23, 2010 11:19

i've just installed the 64 bit sabayon 5.2 kde edition on my laptop.
but i cant seem to get any sound on it

i've tried to follow a few guides and it seems that my sound card is recognized but for some reason there is no sound

here's something that may be useful

Code: Select all

leonardis ~ # lsmod | grep snd
snd_seq_dummy           1118  0 
snd_seq_oss            22287  0 
snd_seq_midi_event      4117  1 snd_seq_oss
snd_seq                38851  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4075  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            29511  0 
snd_mixer_oss          11047  1 snd_pcm_oss
snd_hda_codec_atihdmi     1830  1 
snd_hda_codec_realtek   232142  1 
snd_hda_intel          18693  2 
snd_hda_codec          54382  3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4532  1 snd_hda_codec
snd_pcm                54854  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              14076  2 snd_seq,snd_pcm
snd                    42593  15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc          5835  2 snd_hda_intel,snd_pcm

could somebody help me with this please.
Last edited by nikhil on Sun May 23, 2010 15:06, edited 1 time in total.

Simple Hen
Posts: 44
Joined: Sat Feb 14, 2009 23:20
Location: Scotland

Re: No Sound

Post by dannii2 » Sun May 23, 2010 11:32

Do you know if you have pulseaudio running somewhere in there? I know every time I do a fresh install I have to remove it and reboot. Then things tend to start working, but until I've removed it nothing audio works.

Someone in the forums came up with a suggestion a while back to just rename pulseaudio as it's not very easy to uninstall/remove. This works on all my laptops for a while now, so much so that the first thing I do after a fresh install is execute that command - just in case it's running or being used.

Code: Select all

sudo mv /usr/bin/pulseaudio /usr/bin/pulseaudio.old

Fitzcarraldo has done an excellent writeup on getting pulseaudio to work if you wanted to go down that route though. ... +cooperate

Baby Hen
Posts: 11
Joined: Wed Oct 07, 2009 12:07

Re: No Sound

Post by nikhil » Sun May 23, 2010 15:06

thanks a lot
that did the trick.

Post Reply