grub2 problem (unpopulated list) [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 13
Joined: Sat Apr 03, 2010 13:22

grub2 problem (unpopulated list) [Solved]

Post by xdemo » Wed May 19, 2010 22:32

EDITED: Solution >> i simply re-installed grub2 ($ sudo equo install grub) and then merged the auto generated config file that was created, all seems back to normal. sorry for the confusing post aswell lol.

A while back (maybe 2-3weeks ago) there was a grub2 update in entropy and after installing it + a fresh reboot i got the "splash daemon 256 error" as explained in this thread:

It didn't bother me for a while not having a background image etc, but i decided to fix it today, and followed some of the posts in the mentioned thread on how to restore it.

Code: Select all

zeta demo # grub2-install /dev/sda
Installation finished. No error reported.
zeta demo # grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found background image: default-splash.png

I didn't realise until trying those commands above^ for the second time, that grub2 didn't recognize my sabayon install (the only thing on my computer), therefore leaving an unpopulated grub menu(?) with the minimal bash command line message and the "grub >" text.

Is it supposed to output similar to:

Code: Select all

Generating grub.cfg ...
Found background image: default-splash.png
Found linux image: /blah/*linux2.6.blah-generic

So after going through alot of blank cd's i managed to find a copy of super-grub2-disk, and managed to boot into sabayon by recovering a previous menu.lst.

I've now got my system up and running again, but need to boot from super-grub2-disk everytime to get to a populated grub :?

I have tried various things like:

Code: Select all

zeta demo # update-grub2
bash: update-grub2: command not found

but i've heard from a friend thats a debian based script?

Here is my /etc/default/grub file

Code: Select all

[email protected] ~ $ cat /etc/default/grub 
# /etc/default/grub
# If you change this file, run 'grub-mkconfig -o /boot/grub/grub.cfg' afterwards to update
# /boot/grub/grub.cfg.


# Add your extra parameters here below

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
[email protected]

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entrys


# Default wallpaper image path

# Boot menu option normal color

# Boot menu option "highlight" color

[[ -z "${GRUB_CMDLINE_LINUX}" ]] && GRUB_CMDLINE_LINUX="`cat /proc/cmdline`"

How can i update my grub menu automatically on sabayon? Or have i missed something/done something wrong.
Thanks for any help. I can't seem to work this out, been a few hours now o.o
Last edited by xdemo on Thu May 20, 2010 17:56, edited 1 time in total.
Sabayon 5.2 x86_64 w/ fluxbox

Technological Hen
Posts: 344
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: grub2 problem (unpopulated list)

Post by genfool » Wed May 19, 2010 22:46

not sure but, after you run the grub-mkconfig -o /boot/grub/grub.cfg did you run grub-install /dev/sda or whatever your dev is?
A little reading for you

Once you have grub2 installed and run grub-mkconfig you will see that you need to install grub2 /dev/sda?
On sabayon you should already have grub2 installed, the link is for reference only.
grub2 is pretty good once you get the hang of it...I made many mistakes and learned the hard way.

Baby Hen
Posts: 13
Joined: Sat Apr 03, 2010 13:22

Re: grub2 problem (unpopulated list)

Post by xdemo » Wed May 19, 2010 23:08

thanks for reply i have had a read of the page, the only thing useful though is the command to verify grub2 loads the cfg in qemu correctly:

Code: Select all

sync ; echo 3 > /proc/sys/vm/drop_caches ; qemu -hda /dev/sda

helpful to see if cfg is working correct, this is what i'm getting:


i don't have a clue whats wrong, btw i also rm'd grub.cfg and re-ran `grub-mkconfig -o /boot/grub/grub.cfg` but no changes.

I'm off to bed now, been bothering me for too long :|
Hoping someone can work out whats happened by the time i wake up :D
Sabayon 5.2 x86_64 w/ fluxbox

Post Reply