Problems with Sabayon Install

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Problems with Sabayon Install

Postby BHReach » Mon May 10, 2010 3:17

I just installed Sabayon Linux 5.2_x64.

Several problems arose.

First, I tried running it from the live DVD. It worked (btw, the graphic configuration works but is pig slow, it took so long I left the room and did something else while it finished) but I ran into one problem, after running unattended for several days the monitor was in blanked mode and I could not get it to resume normal mode. Usually, I just move the mouse or press a key on the keyboard and it comes right back but this time I had to reboot.

I tried installing with the Graphical Installer but that failed. After answering all the questions and it started the install, it aborted and wanted to write a dump file to the HD. I tried it several times with the same result each time.

I next tried the Text Installer. That worked. I rebooted, logged in and ran startx. It brought up twm <rant> why do distro developers love twm so much? It is very awkward to use. Fluxbox is slightly better but icewm is clearly superior to either of them, it has a smaller footprint than twm, has very few dependencies, is lightning fast and functions very much like a normal desktop. <end rant>. I was surprised to see twm because I chose the KDE installation.

After fumbling around with twm for a few minutes, (and discovering that mc and konqueror are not installed by default), I exited twm, switched to root and ran kdm. It brought up the KDE login screen and I logged in and KDE loaded.

I had been a Gentoo user for a while but ever since Daniel Robbins left the project, it has deteriorated. 2 years ago I decided I needed to switch to something else. I tried Sabayon then but had to 'jump through hoops' to get it installed and still had some problems with it (I don't recall the details), I decided it was not ready for prime time (yet). In the interim, I've gone through Debian, Frugalware, Arch, Suse, Fedora, Slackware and several others whose names I don't remember.

Lately I've been using Slackware but it has some problems. It is very fast and stable but it no longer supports Gnome so if you use any Gnome programs, you are on your own installing them and it has a limited selection of software so I have to install and maintain 80-100 packages on my own which is very time consuming.

Hopefully Sabayon is mature enough now that I can run it on my production boxes.
Growing Hen
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: Problems with Sabayon Install

Postby wolfden » Tue May 11, 2010 7:09

The anaconda log file would of been nice to get and submit. Hard to fix stuff without errors. Have you tried one of the daily iso files? It has a new installer, maybe that would work better?
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Problems with Sabayon Install

Postby BHReach » Thu May 13, 2010 2:37

I don't have a lot of time to work on this but I ran the installer several times under different conditions and discovered what is causing the problem.

The graphics installer does not like one of my HDs. I have a 150GB and a 300GB HD in the system. It installs on the 150GB but not the 300 GB.

I was somewhat surprised because the text installer does not have a problem with the 300 GB HD. I had assumed the only difference between the 2 was the UI.

Below is the dump file the installer prompted me to save. It looks the the error output from a Python script.

Hope that helps.

Component: PreInstaller
Version: 2.0
Summary: TBbdb92a12 lvcreate failed for LogVol00

Traceback (most recent call last):
File "/opt/anaconda/usr/lib/anaconda/", line 1059, in handleRenderCallback
File "/opt/anaconda/usr/lib/anaconda/iw/", line 162, in renderCallback
File "/opt/anaconda/usr/lib/anaconda/", line 906, in nextClicked
File "/opt/anaconda/usr/lib/anaconda/", line 172, in gotoNext
File "/opt/anaconda/usr/lib/anaconda/", line 240, in moveStep
rc = apply(func, self.bindArgs(args))
File "/opt/anaconda/usr/lib/anaconda/", line 62, in turnOnFilesystems
File "/opt/anaconda/usr/lib/anaconda/", line 1559, in createLogicalVolumes
File "/opt/anaconda/usr/lib/anaconda/", line 2234, in setupDevice
raise SystemError, "lvcreate failed for %s" % (,)
SystemError: lvcreate failed for LogVol00

Local variables in innermost frame:
devPrefix: /dev
device_path: /dev/VolGroup01/LogVol00
self: <fsset.LogicalVolumeDevice instance at 0x10ad170>
cmd: ['lvm', 'lvcreate', '-L', '155968M', '-n', 'LogVol00', '-An', 'VolGroup01']
chroot: /mnt/sabayon
enf_setup: 1
rc: 1280
Growing Hen
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: Problems with Sabayon Install

Postby wolfden » Sat May 15, 2010 5:49

If the problem still persists with the new installer that came after 5.2, please file a bug if so. Currently the daily isos have the new installer.
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 7 guests