5.1 (5.2?) Doesn't shut down cleanly [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

5.1 (5.2?) Doesn't shut down cleanly [Solved]

Postby sproot » Fri Apr 23, 2010 13:42

I don't know how to find out what version it is :oops: It started out as 5.1 and is completely updated, does that make it 5.2?

Don't know if it's relevant or not either way but: It no longer shuts down by itself, it gets as far as 'unmounting filesystems' and hangs. This is after syslog-ng has been stopped so there's nothing in the logs about it, and I can't log in on another terminal to find out what's running.
The only workaround I have is Alt-SysReq (S,U,E) which presumably kills the hanging process and the shutdown seems to complete cleanly.

Anyone familiar with the shutdown process, or know how I might capture some logs?

TIA
sproot
Last edited by sproot on Mon Apr 26, 2010 13:20, edited 1 time in total.
sproot
Simple Hen
 
Posts: 46
Joined: Wed May 06, 2009 16:20
Location: London, UK

Re: 5.1 (5.2?) Doesn't shut down cleanly

Postby Fitzcarraldo » Fri Apr 23, 2010 14:02

If you installed SL 5.1 and then updated using the Entropy commands equo update && equo upgrade then you're actually running SL 5.2++ because there have been updates to packages since SL 5.2 was released. So you're bang up to date.

You can tell what kernel and edition of SL you're running by using the command uname -a

If you have kde-base/konqueror installed and also kde-misc/kio-sysinfo from the Sabayon overlay installed, then you can launch Konqueror and enter sysinfo:/ into the address bar and you will see a nice summary titled 'My Computer' with some information about your installation.

About your PC hanging when shutting down, try using the SL Search facility with keywords "shut down hangs" and see if the threads that come up help you.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: 5.1 (5.2?) Doesn't shut down cleanly

Postby sproot » Fri Apr 23, 2010 17:46

I must be up to date then, I missed a load of updates because I hadn't switched my sources.list (didn't RTFM!) but I did that recently and got several hundred MB worth of updates. It was working fine up to that point :roll:

uname -a says I'm on kernel 2.6.31-sabayon, I guess that's right?

I had a search before I posted, and I could only find one thread (from 2008) where someone had the same issue, there wasn't a resolution though. I'm going to try leaving a terminal logged in as root to try to see what's happening, but I'm not hopeful - I think it'll be killed before it hangs.
sproot
Simple Hen
 
Posts: 46
Joined: Wed May 06, 2009 16:20
Location: London, UK

Re: 5.1 (5.2?) Doesn't shut down cleanly

Postby Fitzcarraldo » Fri Apr 23, 2010 23:28

Why don't you check the Press Release shed (forum) for the details of the packages (including kernel) for SL 5.2? Then you'd see that kernel 2.6.31 is not the latest. You need to upgrade the kernel, make sure the kernel sources symlink is pointing to the latest kernel and reinstall the video driver for the latest kernel. See the first part of e.g. the thread World Updating 101 Pre 4.2 -- Read before World Updating -- for details of what to do w.r.t. the kernel and video driver.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: 5.1 (5.2?) Doesn't shut down cleanly

Postby sproot » Mon Apr 26, 2010 13:12

I'd never looked in there tbh, I usually get the release announcements from the front page of SL.org!

I expected that equo would keep the kernel up to date along with everything else, I didn't realise it had to be done manually. Was that always the case? I don't remember having to do it in SL4, although that's as likely to be a problem with my memory. I suppose it's entirely possible I never upgraded it 'til I switched to 5 :lol:

I digress, it's done now:
Code: Select all
$ uname -r
2.6.33-sabayon

It still boots pretty cleanly, now to see if it stops :roll:
sproot
Simple Hen
 
Posts: 46
Joined: Wed May 06, 2009 16:20
Location: London, UK

Re: 5.1 (5.2?) Doesn't shut down cleanly

Postby sproot » Mon Apr 26, 2010 13:19

Happy days, it shut down cleanly, and I can mount removable media with the kde widget again. I was having to do it manually before. A Twofer 8)

Cheers :salut:
sproot
Simple Hen
 
Posts: 46
Joined: Wed May 06, 2009 16:20
Location: London, UK

Re: 5.1 (5.2?) Doesn't shut down cleanly [Solved]

Postby wolfden » Tue Apr 27, 2010 5:38

We don't auto upgrade the kernel, it causes too much havoc and people were booting up to several problems as they didn't understand how to manage kernel upgrades. It's best for the user to update the kernel and driver, than there is no wicked surprises after a reboot on fresh updates.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests