Unable to login in Sabayon 5.2 amd64 K

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Unable to login in Sabayon 5.2 amd64 K

Postby dark-soul » Sat Mar 27, 2010 10:01

After the distro has been installed I am unable to login.

I received this error message "Call to lnusertemp failed {temporary directories full?}. Check your installation." on login.

This happens beacause the /var/tmp directory is missing. After I created this directory with the correct permissions I can login.


Anyone has the same problem?
dark-soul
Baby Hen
 
Posts: 1
Joined: Sat Mar 27, 2010 9:53

Re: Unable to login in Sabayon 5.2 amd64 K

Postby Fitzcarraldo » Sat Mar 27, 2010 13:31

If that happens with a fresh install then it sounds like a bug to me. If so, I suggest that you file a bug report (see link Bugs at the top right of this page) to bring it to the attention of the developers.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Unable to login in Sabayon 5.2 amd64 K

Postby stefan9 » Sat Mar 27, 2010 18:54

After a successful installation on my Desktop PC with Sabayon_Linux_5.2_amd64_K.iso ,I just tried to install
Sabayon_Linux_5.2_x86_K.iso on my Notebook.

I get the same error message...

Login to XBMC works, just KDE not...
stefan9
Young Hen
 
Posts: 36
Joined: Sun Nov 22, 2009 20:24

Re: Unable to login in Sabayon 5.2 amd64 K

Postby stefan9 » Sat Mar 27, 2010 22:15

I just opened a new Terminal (Ctrl+Alt+F1)

Login: root
Password: *******

equo update
equo upgrade

After I was able to login to KDE...
stefan9
Young Hen
 
Posts: 36
Joined: Sun Nov 22, 2009 20:24

Re: Unable to login in Sabayon 5.2 amd64 K

Postby throdon » Sat Mar 27, 2010 22:21

i just relogged in about 3 or 4 times it always kicked me back to the log in and on the 3rd or 4th time it gave me a bad resolution. it then alowed me to get to the desktop. logged out resolution was then fine and went to KDE desktop. now onto fixing my sound
Troll hunter with an overzealous nature
throdon
Advanced Hen
 
Posts: 229
Joined: Mon Aug 20, 2007 13:06
Location: Central valley, California

Re: Unable to login in Sabayon 5.2 amd64 K

Postby alcalde » Sat Apr 03, 2010 13:09

Here's a fix for the problem (I don't know the cause of the problem, but it's reproducible with a fresh install of 5.2 x86 in Virtualbox).

log in via console with root access and type:

chmod 1777 /tmp
chmod 1777 /var/tmp
alcalde
Simple Hen
 
Posts: 69
Joined: Sun Jul 29, 2007 18:59

Re: Unable to login in Sabayon 5.2 amd64 K

Postby alcalde » Sat Apr 03, 2010 19:21

Forgot to add, you may need to create /var/tmp first:

mkdir /var/tmp
alcalde
Simple Hen
 
Posts: 69
Joined: Sun Jul 29, 2007 18:59

Re: Unable to login in Sabayon 5.2 amd64 K

Postby chickaroo » Mon Apr 12, 2010 0:10

I experienced this too. why isn't this bug fixed yet?

a "equo update" and "equo upgrade" (as posted above) did fixed the lnusertemp issues, but I still could not log in. it would start loading kde and then kick me back to XDM login screen again over and over.

i realized there was LibGL linking issues after checking the xorg log, so on a hunch i tried reselecting OpenGL with eselect and it worked. (this kind of stuff you'd expect to already have been done from a fresh isntall...)

here's what I did, hope it helps someone:

Code: Select all
# eselect opengl list
Available OpenGL Implementation:
     [1]    Xorg-x11 *
     [2]    ati
     [3]    nvidia


I don't have a ati or nvidia, so it should be set on xorg-x11, so i set it to xorg-x11 with this :

Code: Select all
# eselect opengl set 1
Switching to xorg-x11 OpenGL interface... done


(NOTE: if you have ati or nvidia you'd obviously want to switch to those instead)

and that fixed my issue. (also if it's already on the one you want, you may need to switch to another and then back to the one you want to get it to work)
Last edited by chickaroo on Sun May 09, 2010 12:20, edited 1 time in total.
This post was most likely written under the influence. I am in no way affiliated with Sabayon Linux, or the Sabayon Linux development team. My views are my own, and very well may offend people. If you're offended by anything I say, feel free to fsck off:)
chickaroo
Young Hen
 
Posts: 24
Joined: Sat Sep 23, 2006 10:07
Location: NY

Re: Unable to login in Sabayon 5.2 amd64 K

Postby joost » Tue Apr 13, 2010 15:20

I experienced this too. why isn't this bug fixed yet?


Did somebody file a bug for this then?
joost
Sagely Hen
 
Posts: 2548
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Unable to login in Sabayon 5.2 amd64 K

Postby donnie » Tue Apr 13, 2010 16:31

I installed Sabayon 5.2 KDE twice, from the same HDD partition. There was no problems for the first time (only a message about not correct video mode, I just waited a bit and it was gone). But for the second time I decided to split sda5 and sda6 into one 16 GB sda5 and install SL there. Partition manager did all things to mess me up, and SL installer displayed the same message There is a serious error during installation and restarted 3 or 4 times. After installed, Sabayon refused to boot with that message. I logged in to console and edited /etc/fstab, removing 2 odd swap partitions (I have 3 swap on my HDD). Maybe this helped?

/dev/sda5 / ext4 user_xattr,noatime 1 1
/dev/sda10 /home ext4 user_xattr,noatime 1 2
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/sda7 swap swap defaults 0 0
donnie
 

Next

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 2 guests