Sort of new user...

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Sort of new user...

Postby dteam85 » Wed Dec 16, 2009 4:21

Hi,
I've been using linux for a few years and sabayon for a few months, got it on my PC and laptop and I have to say it is a damn good OS both in looks and features, thanks to all those involved in it! =)
But... I've had some issues with it (5.0 and 5.1 gnome) whilst using it:

1) The sound output (right hand side one) which is linked with the keyboard up&down volume buttons always resets to the wrong output device on reboot (I've got dmix0, internal audio stereo and internal audio digital [it reverts to this]) even if I change it (Happens in both 5.0 and 5.1)

2) Congrats on fixing the nvidia bug that prevents 5.0 from booting on an nvidia 6200 because 5.1 boots fine! But when using compiz (nice one for fixing that too), it works fine on my PC with an ATI x1650 PRO but on my laptop with an NVIDIA Go 6200, it messes up. Open a terminal and mozilla and mozilla will never update (the screen will be white), open another terminal and it'll be blank, no user line or anything, pressing keys does nothing but if you minimise and expand the window it refreshes, but that's the only update that happens, if you type more keys you won't see anything new until you do it again

3) World of Goo installs even if the games package isn't selected...?

4) With 5.1, I've edited both FDI files in /etc/hal/fdi/policy and /usr/share/fdi/policy for synaptic keypads but they don't seem to make any difference; touchpad tapping still works :( [I can disable using synclient but I have to do that on each reboot]

5) I don't know if this is just my laptop or what (maybe even disk space) but hibernate never works; it just instantly comes back to the desktop, and with problems like no sound or whatnot (8GB partition, 1GB RAM)

Other than that; marvellous! Thank you for an awesome OS! =)
dteam85
Baby Hen
 
Posts: 3
Joined: Wed Dec 16, 2009 4:09

Re: Sort of new user...

Postby Fitzcarraldo » Wed Dec 16, 2009 12:41

dteam85 wrote:3) World of Goo installs even if the games package isn't selected...?

It's a demo, not the full program. You could file a bug report if you think its installation is a bug if games are not selected during SL installation: see the link "Bugs" at the top right of this page. If you want to uninstall the demo, you can use the following command as root user in a Terminal window:

Code: Select all
equo remove world-of-goo-demo

-------------------------------

dteam85 wrote:1) The sound output (right hand side one) which is linked with the keyboard up&down volume buttons always resets to the wrong output device on reboot (I've got dmix0, internal audio stereo and internal audio digital [it reverts to this]) even if I change it (Happens in both 5.0 and 5.1)

Have you tried using the PulseAudio utilities to configure your audio settings? See the thread: Getting PulseAudio to cooperate.

-------------------------------

dteam85 wrote:4) With 5.1, I've edited both FDI files in /etc/hal/fdi/policy and /usr/share/fdi/policy for synaptic keypads but they don't seem to make any difference; touchpad tapping still works :( [I can disable using synclient but I have to do that on each reboot]

I don't use GNOME any more, but have you tried the GNOME utility GPointingDeviceSettings?

Code: Select all
# eix gpointing
* gnome-extra/gpointing-device-settings
     Available versions:  1.3.2
     Homepage:            http://gsynaptics.sourceforge.jp/
     Description:         A GTK+ based configuration utility for the synaptics driver

# equo search gpointing
>>  @@ Searching...
>>   #1 Sabayon Linux Official Repository
>>  @@ No matches.
#

As you can see from the output above, it's not in Entropy at the moment (you can put in a request for it to be added to Entropy: Requesting Packages for Entropy - New Policy) so you would need to use the Portage source package manager to install it. As root user in a Terminal window enter the following commands:

Code: Select all
emerge --sync
layman -S
emerge -1v gpointing-device-settings

Also enter the following command after installation has completed, so that Entropy is made aware of what you have done via Portage:

Code: Select all
equo database gentoosync

Had you been using KDE 4 I would have recommended the GUI utility synaptiks.

-------------------------------

dteam85 wrote:5) I don't know if this is just my laptop or what (maybe even disk space) but hibernate never works; it just instantly comes back to the desktop, and with problems like no sound or whatnot (8GB partition, 1GB RAM)

I assume by "8GB partition" you are referring to your root partition? For hibernation to work, the swap partition on the HDD has to be at least as large as the amount of RAM. Is that the case on your laptop?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Sort of new user...

Postby dteam85 » Thu Dec 17, 2009 3:08

OK managed to fix that mouse problems!

I've tried many things with sound, even switched over to pulse audio as suggest (5.1 has the bug described here https://bugs.launchpad.net/ubuntu/+sour ... bug/240761 in that avahi-daemon needs to be restarted else padevchooser won't run and gives an error) but some things (such as flash in firefox) ignore pulseaudio, and other things (like pidgin) cause sound glitches when they play sounds and other things are playing sound such as audacious.

Graphics problems still occur :(

I had already removed world of goo just found it annoying that it is automatically installed even if games are not selected

Ah hibernate stores in SWAP, thought it'd have been in temp. Would explain it; 1GB RAM & 200MB SWAP!
dteam85
Baby Hen
 
Posts: 3
Joined: Wed Dec 16, 2009 4:09

Re: Sort of new user...

Postby Fitzcarraldo » Thu Dec 17, 2009 5:54

If you find a bug -- and the padevchooser problem you mentioned looks to me like a bug in SL 5.1 -- then do not hesitate to file a bug report. You can file a bug report by clicking on the link 'Bugs' at the top right of this page, but please first use the bug reporting page's Search facility to check the bug has not already been reported.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron