Mouse gone mad after updates

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Mouse gone mad after updates

Postby Petrivs » Tue Dec 15, 2009 18:26

Hello fellows!
I just made a fresh install of SL, and everything was working fine. Updated my package management system (don't remember the name, duh) through equo, got everything up to date through sulphur and restarted my comp.
But now, my mouse has gone mad. Everytime i move it my cursor goes to the very bottom of the screen. That doesn't happens if I don't move the mouse nor if i move it through the keyboard.
No, It's not a mouse problem, it works just fine on Windows.

Using 5.0 SL, 2.6.31-sabayon kernel, KDE 4.3 (it doesnt works on the other window managers too, neither on the login screen).
Petrivs
Baby Hen
 
Posts: 3
Joined: Tue Dec 15, 2009 18:21

Re: Mouse gone mad after updates

Postby Petrivs » Tue Dec 15, 2009 18:54

I just found out that it's a common A4Tech mouses bug on Linux, although I don't know how to apply the patch that the guy provided on this link:
https://bugs.freedesktop.org/show_bug.cgi?id=24737

[Edit]
Ok, I've managed to download the evdev.tar.bz2 package, extracted it, and patched it.
However, I don't know how to install the directory I've patched. I did tried ./configure, ./Make and ./make install, it "did installed", but the fix didn't worked and i'm pretty sure that it's not the way it's supposed to be installed.
Petrivs
Baby Hen
 
Posts: 3
Joined: Tue Dec 15, 2009 18:21

Re: Mouse gone mad after updates

Postby Fitzcarraldo » Tue Dec 15, 2009 23:40

You'll need to do this using the Portage source package management system. I'm not on a Linux PC at the moment, but looking at the patch file (via the link 'alternative patch' on the FreeDesktop Bugzilla page you referenced), it's a single-line edit and thus easy to perform manually. Locate the source code tarball for xf86-input-evdev-2.3.2 (or whatever the latest version of evdev is) in the directory /usr/portage/distfiles/ (if it's not there already then download the tarball for the correct version of evdev and copy it to that directory), open it, find the file /src/evdev.c, apply the patch manually using a text editor of your choice and save it in the tarball. Then cd to the directory of the ebuild file for evdev (it'll probably be /usr/portage/x11-drivers/xf86-input-evdev/), create a new manifest and, if there are no error messages, merge the package. The procedure is shown below:

Code: Select all
emerge --sync
layman -S
cd /usr/portage/x11-drivers/xf86-input-evdev
ebuild xf86-input-evdev-2.3.2.ebuild manifest
emerge -1v =xf86-input-evdev-2.3.2
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Mouse gone mad after updates

Postby Petrivs » Wed Dec 16, 2009 3:24

Ok, well.
I searched for the newest evdev package.
http://gentoo-portage.com/x11-drivers/xf86-input-evdev
Found it here. But, when I go "emerge xf86-input-evdev-2.3.2" it tells me that the package doesn't exist. Should I add some repository?
I'm following this guide:
http://wiki.sabayonlinux.org/index.php? ... tage_Guide
Petrivs
Baby Hen
 
Posts: 3
Joined: Tue Dec 15, 2009 18:21

Re: Mouse gone mad after updates

Postby Fitzcarraldo » Wed Dec 16, 2009 12:32

Not sure what you are doing. First you need to synchronise with the Portage ebuild repository, which will download all the latest ebuilds automatically to your PC:

Code: Select all
emerge --sync

Then you need to synchronise with the Sabayon ebuild overlay, which will download all the latest Sabayon overlay ebuilds automatically to your PC:

Code: Select all
layman -S

Then the latest ebuild of evdev will be in the directory I mentioned in my previous post. Is that the case? Have you looked to see if the ebuild file is in the directory /usr/portage/x11-drivers/xf86-input-evdev/? And what message was displayed when you entered the command to generate the manifest after you had updated the source code tarball in the /usr/portage/distfiles/ directory?

EDIT: If xf86-input-evdev-2.3.2 is not in the repository yet, but you see xf86-input-evdev-2.3.1 is there, then perform the procedure for version 2.3.1 instead of 2.3.2. I notice from the package list in the Press Release for SL 5.1-r1 that the version of evdev shipped with SL 5.1-r1 is evdev-2.3.0, so try the procedure for 2.3.1 if 2.3.2 is not in the repository yet (but you still should check what's in the directory /usr/portage/x11-drivers/xf86-input-evdev/).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Mouse gone mad after updates

Postby Thev00d00 » Sun Dec 20, 2009 15:08

Please report a bug for this, we can get it fixed on our overlay then
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Mouse gone mad after updates

Postby axolos » Sat Feb 06, 2010 20:06

Is there anything new to this issue? I have just started to install the 5.1 K on my desktop machine and get this error each time. It actually does turn me off from using the distro and maybe going for an other one... (I like Sabayon though, so let me keep my hopes that this is somehow being cared for?) :)

I am using a Trust Predator USB wired mouse.

Btw, this behaviour even persists after unplugging and replugging the mouse.
Also, not plugging the mouse in at the boot does not have any effects on the mad behaviour.
axolos
Baby Hen
 
Posts: 16
Joined: Fri Nov 09, 2007 7:53
Location: Marburg, Germany

Re: Mouse gone mad after updates

Postby jspeybro » Wed Feb 10, 2010 21:55

Hi,

I'm also experiencing this problem using a targus wireless usb mouse. is there a package that we can update to get this fixed?

thanks,

Johan
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34

Re: Mouse gone mad after updates

Postby jspeybro » Fri Feb 12, 2010 18:57

maybe better question, did anyone already file a bug for this, or does this stil need to be done?
jspeybro
Simple Hen
 
Posts: 48
Joined: Fri Dec 28, 2007 14:34


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests