Upgrade Time [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
Young Hen
Posts: 20
Joined: Mon Dec 14, 2009 4:18

Upgrade Time [Solved]

Post by rj_whitten » Mon Dec 14, 2009 9:05

Let me start by saying I love sabayon. I have to many issues on to many machines to sort out and would like some guidance as to where to start looking to fix them. I have tried my best to find fixes for these problems with no luck so this is my last resort as I try not to bother you guys with small problems.I have been using 3.3 - 4.2 without an issue (except 4.0) on 2 of my laptops and installed it on my girlfriends as well. Now 5.0 and 5.1 came out and things are just chaotic. Examples below:

Acer Aspire one D250:
I. Microphone doesn't work out of the box, got it to finally hear my voice and show on the volume meter but no program wants to use the settings.

II. NTP was removed - Reinstalled it and got it working again

III. Was forced to use USB stick to install the 5.1 because the 4.2 would not connect to http://pkg.sabayon.org and never found a update for sulfur. Equo didn't either.

IV. gnome-power-applet etc. keeps cutting the computer off when the power cord is removed or the gnome-power-manager resets it. (Cutting off about every 5-10 min)

V. Compiz becoming jumpy and laggy when the computer is left on for more then 24 hours.

And this is just one computer. I have been tempted to install ubuntu on this one since everything works out of the box but I have been faithful to sabayon for a few years. I have not had to post anything on here before bc any issue I had I went out researched and fixed on my own. For someone who knows little about the Linux os as I do I would say I have done pretty well.

IBM z61m:

I. Sulfur / Equo will say it updated repositories but does not show the new Equo / Sulfur in updates. It is still stuck on 4.2 like the rest where.

II. Everything else works fine since this one is on 4.2 but since I have had so many issues with my g/f brothers and my computer I dare not upgrade my main laptop.

Acer Aspire One ZG5:

I. Was faithful for a long time for my g/f. She couldn't get hers to update from 4.2 either same issue as the two above.

II. She turned on her computer one day and Magneto applet, Applications, nm-applet, and gnome-power-applet where all missing. She brought it to me and I restored the Applications menu but could not get magneto, nm-applet and gnome-power-manager to reappear.

I have a brother that uses a dell in another state that has 4.2 on it as well. We all did fine with 4.2 but it won't update itself to 5.0 / 5.1 so we had to go manual.

Ubuntu is the easy way out but I am trying to stay far away from that as possible. I do like some challenge after all.
Last edited by rj_whitten on Wed Dec 23, 2009 3:55, edited 1 time in total.

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: upgrade Time

Post by wolfden » Mon Dec 14, 2009 9:48

so u take the time to make that post but provide nothing to work with.

no errors
no hardware
no logs

download 5.1 and install?

updating from 3.3 not gonna happen

updating from 4.0 gonna be tough

updating from 4.2 gonna be tough also

What is the issues with 5.1 and please provide required information?

4.2 requires a branch hop to get to 5.1, see wiki on this

again anything below <5 needs a branch hop, see wiki as u are in branch 4, not 5

knowing your package manager is vital, can't stress that enough.

you need to hop to 5 and get the latest entropy before doing any updates

I suggest downloading 5.1, backup your stuff, fresh install, install 5.1, restore backup and keep up to date with package manager

Young Hen
Posts: 20
Joined: Mon Dec 14, 2009 4:18

Re: upgrade Time

Post by rj_whitten » Mon Dec 14, 2009 11:39

Keep in mind that this is a fresh install with very minimal added. Skype, opera, cheese added. Firefox removed. The problems are listed in the above article but I will resay them... I will not list the IBM as it is my main pc and I have no desire to upgrade it to 5.1. Nor will I list the other acer aspire one as we are going to wipe it and probably place a diffrent distro on it for her. My brothers dell can be fixed by wiping the old os as well. However none of us like the idea of wiping the old OS to put the new one on but I prepared for it in advance w/ the partitioning scheme.


Introduced September 2008
HDD (Upgraded) 500 gb sata WD500
Ram (Upgraded) 2 gb
Wireless Atheros Communications Inc. AR5001 Network Adapter (rev 01) Mod= ath 5k
Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Sound - Plays audio well except sometimes skype skips when doing test call. NO Microphone response unless i tweak the settings. Default settings produce NO error. When I get the mic to respond and see it moving to my voice in the "Pulse Audio Volume Meter" the programs say that the settings are not correct.

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:022f]
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 96340000 (64-bit, non-prefetchable)
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Next issue: gnome-power-applet etc. keeps cutting the computer off when the power cord is removed or the gnome-power-manager resets it. (Cutting off about every 5-10 min)

Errors that I could produce are in attached file. Nothing pops up error wise so I just ran the applet from the shell and got these. From the research I did I can only gather it has something to do with ACPI. I will say again I don't know as much as you do about linux to know what or how ACPI works. 4.2 didn't have this issue and actually everything worked in 4.2 except the microphone but I gave up on that because the mic's worked on my other two computers.

Final issue: Compiz Jumpy / laggy after leaving PC on. I do not know how to produce logs for this at all. It happens on all 4 of the PC's and 4.2+ It goes away after a restart but happens again if you leave the computer on for a while.
when I origanally found this issue I thought it was because of my graphic card in one pc. But the event happened on all the installs. Each computer has diffrent install Media / verified md5 iso's and diffrent versions of sabayon. All the issues here where after fresh installs and little to no software was added to the machines. When software was added or the programs where upgraded no improvement or change happened.

Current Operating System: Sabayon Linux x86 5
Current Edition: Sabayon Linux 5.1-r1 x86 G

xsession: http://www.sabayonlinux.org/pastie/2626
Dmesg: http://www.sabayonlinux.org/pastie/2627
Messages: http://www.sabayonlinux.org/pastie/2628
rc.log: http://www.sabayonlinux.org/pastie/2629
Hardware info: http://www.sabayonlinux.org/pastie/2630

Young Hen
Posts: 20
Joined: Mon Dec 14, 2009 4:18

Re: upgrade Time

Post by rj_whitten » Mon Dec 14, 2009 11:48

BTW forgot to mention that the way I know it's gnome-power-manager causing the standby issue When I unplug the cord is bc after cutting off several times while I was using it I killed it and removed it from the startup applications and my computer doesn't turn off every 5-10 min anymore. However I do need the Power manager so it can shut off the screen when I close my laptop, and to control brightness when I unplug the cord. ( not put it in stand by like it does.)

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: upgrade Time

Post by wolfden » Mon Dec 14, 2009 12:13

well, unfortunately snd-hda-intel is always a battle of tweaking and now we use pulseaudio in the > 5 releases
you may want to see:
http://forum.sabayonlinux.org/viewtopic ... 56&t=18789

for skype, may want to see:

The compiz thing I do not experience here at all and I can have my computer up for days. I wonder if it isn't related to hibernation or something. I turn off all power management features, but may not be desirable for a laptop. Are you using a swap? I recall see on the forum about hibernation issues. http://forum.sabayonlinux.org/viewtopic ... 9&p=106234

With the 5.0 release, you should be able to roll along and stay current. Anything prior to 5 is in a different branch, hence the equo hop 5 needed to continue updates. At this point and time, I would not recommend doing it, but you are free to try it. Just make sure you have the latest entropy all the time.

Most days for me start out with,
equo update
equo install entropy equo
equo world
equo conf update

This will keep my computer rolling along, which I have been doing since I installed 4.0 MCELite edition. I had to jump branches to 5 and my rolling system has been pretty much error free and I run Limbo repo on top of it.

Maybe someone with similar hardware will run across this and post their experiences.

Simple Hen
Posts: 63
Joined: Thu Aug 20, 2009 3:55
Location: Gladstone, Tasmania, Australia

Re: upgrade Time

Post by catalyst » Mon Dec 14, 2009 15:25

Your audio issues are felt by all who have HDA-Intel, myself included.
HDA-Intel is unfortunately not limited to a single chipset architecture, there are many different makes, models & chipsets, all requiring their own unique configuration.
What I'm about to tell you is seen by some as being akin to heracy but I don't use sabayon to win popularity contests.
Firstly by the look of it you appear to have a Realtek HDA chipset, if this is the case then you can forget about the " How to get pulse audio to co-operate " Wiki, this will only add to your woes because 2 of the application tools listed are no longer supported by pulse audio & havn't been for some time, they are PAMAN & PADEVCHOOSER, this info is readily available on the pulse audio site.
Whilst I would not think of telling you to cease using an application on my say so alone, I can tell you how I solved my audio issues & leave you to judge for yourself.
let's try the following as root in terminal run

Code: Select all

Just select all the defaults until you are returned to the # prompt then run

Code: Select all

Play around with alsamixer for a while to see if it can resolve your issues.
If the above 2 commands resolve nothing then we march on the gates of HELL
So let's find out what chipset you have, as root in terminal run

Code: Select all

cat /proc/asound/card0/codec#* | grep Codec
In my case this returns : Codec: Realtek ALC880 : Yours may be different, armed with this info head to
http://wiki.sabayonlinux.org/index.php? ... ound_Cards
Follow the instructions there, before saving settings be sure & read the edits at the bottom of the page.
Also if you run alsaconf again after saving your settings all the work you have just done will be lost as alsaconf will re-write the conf file.
You can now safely run alsamixer again & you may see more settings to play with, also I had to manually add a capture & source channel in order to get my mic working, I did this in kmix on the kde desktop, don't know what the gnome equivalent is.
If like me your Skype only allowed you to use pulse-audio in the audio settings then & here comes the heracy.
GET RID OF PULSE-AUDIO, but as pulse-audio cannot be removed without taking 95% of your install with it you have to think laterally, prevent it from loading on boot by re-naming it's bin file.

Code: Select all

mv /usr/bin/pulseaudio /usr/bin/pulsesucks

After I side-lined pulse everything was peaches & cream, I now have 8 different audio devices I can select from in Skype, one of which is a digital capture channel for mic.

Hope this helps.
cheers: catalyst64
Desktop HP Pavilion a1040a
Intel P4: 515J processor: 2.93 Ghz: 1.5 Gb ram
2 x sata HDD
ATI Radeon X300 SE PCI-Ex
Sabayon-9 Gnome x86
Laptop HP Pavillion dv6-7031tx Netbook
Intel core i7 3610 2.3 Ghz
Nvidia GeForce GT 630m
Sabayon-9 Kde

Young Hen
Posts: 20
Joined: Mon Dec 14, 2009 4:18

Re: upgrade Time

Post by rj_whitten » Wed Dec 16, 2009 6:47

Ok most issues have been fixed. For the sound problem I just removed Pulseaudio and everything works fine. even with the new Skype "Beta" .

The gnome-power-manager was being a tedious fix so make things work out I killed it and removed it from my startup applications. Now I can use the computer without it turning off (going into stand-by randomly) during use. The brightness is still controlled without gnome-power-manager so I didn't see a reason to keep the defective program going.

For compiz I haven't noticed the laggy / jumpyness on 5.1 on the acer however it still happens on my IBM but thats still on 4.2.

Post Reply