[Solved] KDE networkmanager bug??

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

[Solved] KDE networkmanager bug??

Postby miso » Fri Oct 20, 2006 14:49

Hi there,

Running a linksys PCI card which according to Sabayon is all good. It has recognised the card (uses the right driver for it, which comes up in the internet menu in KDE), Knetwork manager see's it, lists the network and shows the signal strength. The card's green light is on, and it all seems to be working. However, whether I use Knetworkmanager in KDE or Gnome's network manager, it cannot activate the card. It thinks about it for awhile then it stops. I've tried # rc-update add net.ra0 default
and it seems fine. In iwconfig it lists the card etc. Just don't understand why it won't fire up despite this.

Any ideas?
Last edited by miso on Sat Oct 21, 2006 16:07, edited 1 time in total.
miso
Baby Hen
 
Posts: 5
Joined: Sat Sep 09, 2006 15:34

Postby Dark_MaGe » Fri Oct 20, 2006 19:05

I need you to post lspci, iwconfig and iwlist outputs
Dark_MaGe
Your Farmer
 
Posts: 1699
Joined: Thu Jun 29, 2006 8:19
Location: Catania Italy

Postby miso » Sat Oct 21, 2006 12:06

Ok, problem solved...

For some reason, sabayon was not connecting to the internet via the router, so I ran the set up wizard on my router and it connected fine. If anyone else has connection problems on set up, you mightwant to try this.

As for the knetwork manager - it looks to be bugged. I was connected and talking to my router, but the network manager was saying that the device wasn't even on. Same for the networks config in KDE - according to that, my ra0 link wasn't even active - it was and it works. KDE's network stuff all seems to be bugged. If you are using the RT2500 driver, Sabayon will recognise and load it fine, despite what the GUI is telling you. So ignore it.

Make sure you # rc-update add net.ra0 default

and it should be fine. If not, restart your router or run the set up wizard on it again.
miso
Baby Hen
 
Posts: 5
Joined: Sat Sep 09, 2006 15:34

Postby Dark_MaGe » Sat Oct 21, 2006 12:57

add [SOLVED] to the topic
Dark_MaGe
Your Farmer
 
Posts: 1699
Joined: Thu Jun 29, 2006 8:19
Location: Catania Italy


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests