emerge update error

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

emerge update error

Postby bg3075 » Tue Nov 17, 2009 4:17

When trying to update all packages from terminal:
Code: Select all
emerge --update --deep --newuse world
I get an error:
Code: Select all
>>> Emerging (20 of 105) net-firewall/ipset-4.1
 * ipset-4.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                     [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                     [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                    [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                   [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Could not find a Makefile in the kernel source directory.
 * Please ensure that /usr/src/linux points to a complete set of Linux sources
 * Could not find a usable .config in the kernel source directory.
 * Please ensure that /usr/src/linux points to a configured set of Linux sources.
 * If you are using KBUILD_OUTPUT, please set the environment var so that
 * it points to the necessary object directory so that it might find .config.
 * ERROR: net-firewall/ipset-4.1 failed:
 *   Kernel not configured; no .config found in
 *
 * Call stack:
 *           ebuild.sh, line  49:  Called pkg_setup
 *    ipset-4.1.ebuild, line  41:  Called linux_chkconfig_builtin 'MODULES'
 *   linux-info.eclass, line 311:  Called require_configured_kernel
 *   linux-info.eclass, line 264:  Called die
 * The specific snippet of code:
 *         die "Kernel not configured; no .config found in ${KV_OUT_DIR}"
 *
 * If you need support, post the output of 'emerge --info =net-firewall/ipset-4.1',
 * the complete build log and the output of 'emerge -pqv =net-firewall/ipset-4.1'.
 * The complete build log is located at '/var/lib/entropy/logs/net-firewall:ipset-4.1:20091117-023339.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-firewall/ipset-4.1/temp/die.env'.
 * S: '/var/tmp/portage/net-firewall/ipset-4.1/work/ipset-4.1'

>>> Failed to emerge net-firewall/ipset-4.1, Log file:

>>>  '/var/lib/entropy/logs/net-firewall:ipset-4.1:20091117-023339.log'

 * Regenerating GNU info directory index...
 * Processed 150 info files.
The log file consists of the same. What may be the problem? Or, can I somehow let emerge know to exclude this package update?
Barry
sabayon 4.2 / Windows XP MCE
Intel 2.4 Ghz
nvidia GeForce 8600
4 GB DDR
bg3075
Baby Hen
 
Posts: 12
Joined: Wed Nov 11, 2009 5:48

Re: emerge update error

Postby wolfden » Tue Nov 17, 2009 5:03

viewtopic.php?f=54&t=17718

are you sure you want to be using portage? If you are new, you may want to stick with entropy
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: Ashtasu and 2 guests

cron