Trouble installing Miro-TV program

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Trouble installing Miro-TV program

Postby bg3075 » Sat Nov 14, 2009 0:30

Sorry, I am a newbie (to Gentoo/Sabayon). I previously had Fedora, but decided Sabayon may be easier to share with XBox 360. Anyway, I have tried to install the Miro tv player, via emerge, which returned that install failed. I tried the same thing, first, with version 2.5.3, which did the same. I don't know why, but have the log file results below. Please help.
Code: Select all
      >>> Unpacking source...
      >>> Unpacking Miro-2.0.5.tar.gz to /var/tmp/portage/media-tv/miro-2.0.5/work
      >>> Source unpacked in /var/tmp/portage/media-tv/miro-2.0.5/work
      >>> Preparing source in /var/tmp/portage/media-tv/miro-2.0.5/work/Miro-2.0.5/platform/gtk-x11 ...
      >>> Source prepared.
      >>> Configuring source in /var/tmp/portage/media-tv/miro-2.0.5/work/Miro-2.0.5/platform/gtk-x11 ...
      >>> Source configured.
      >>> Compiling source in /var/tmp/portage/media-tv/miro-2.0.5/work/Miro-2.0.5/platform/gtk-x11 ...
      python setup.py build
      /var/tmp/portage/media-tv/miro-2.0.5/work/Miro-2.0.5/portable/util.py:38: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
      import sha
      Using boost_python-mt
      libtorrent-rasterbar (0.13 or later) and python bindings are installed--using system version.
      Package config error:
      pkg-config --list-all outputted the following error:
      Failed to open '/usr/lib/pkgconfig/cblas.pc': No such file or directory
      Variable 'exec_prefix' not defined in '/usr/lib/pkgconfig/vmguestlib.pc'

      * ERROR: media-tv/miro-2.0.5 failed:
      * Building failed
      *
      * Call stack:
      * ebuild.sh, line 49: Called src_compile
      * environment, line 3718: Called distutils_src_compile
      * environment, line 1095: Called die
      * The specific snippet of code:
      * ${python} setup.py "${DISTUTILS_GLOBAL_OPTIONS[@]}" build "$@" || die "Building failed";
      *
      * If you need support, post the output of 'emerge --info =media-tv/miro-2.0.5',
      * the complete build log and the output of 'emerge -pqv =media-tv/miro-2.0.5'.
      * This ebuild is from an overlay named 'sabayon': '/usr/local/portage/layman/sabayon/'
      * The complete build log is located at '/var/lib/entropy/logs/media-tv:miro-2.0.5:20091113-031554.log'.
      * The ebuild environment file is located at '/var/tmp/portage/media-tv/miro-2.0.5/temp/environment'.
      * S: '/var/tmp/portage/media-tv/miro-2.0.5/work/Miro-2.0.5/platform/gtk-x11'

I even tried "3. Using downloaded ebuilds" at http://linuxreviews.org/gentoo/ebuilds/#toc3, with same results.

_________________
Barry
sabayon 4.2 / Windows XP MCE
Intel 2.4 Ghz
nvidia GeForce 8600
4 GB DDR
bg3075
Baby Hen
 
Posts: 12
Joined: Wed Nov 11, 2009 5:48

Re: Trouble installing Miro-TV program

Postby wolfden » Tue Nov 17, 2009 3:22

did you emerge --sync first?
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron