I can't print, a few short questions.

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

I can't print, a few short questions.

Postby Sockpuppet » Fri Nov 13, 2009 9:01

My operative system is Sabayon 5.0 KDE.

When I installed, I chose to disable four services that I can't remember the names of, except cups (got a printer?). Well, yes I have a printer, but untickled all of them including that one. My memory told me that there was two different printing systems, of is completely correct (four actually, but two of them rather useless). Well, but there showed up no other alternatives than cups when I fired up the controlpanel and printing (in KDE, of whom used to have so many options that it lead to vertigo.)

You may wonder why I chose to untickle the cups alternative, well, I have a printer, that's correct, but it's an usb one, and according to my logic sense I shouldn't need to have an open port in my firewall as of it's not a network printer, I've may missed out on something here.

It would actually take less time to reinstall the system than to try to solve this one, but I'm too stubborn to give in to a problem whom I know is possible to solve without reinstallation (eventually still is there even if reinstalled).

I've read many manuals, and the questions crawling in my mind are:

1. Am I correct about the USB-printer don't need an open port for cups? (I'm probably not)

2. As the former assumtion is probably not correct, what port to open? (631?)
(I've found how to open a port: iptables -A INPUT -p tcp --dport 22 -j ACCEPT, exchange the -A with -D to close it)
(I've also found a genious way to let the port be closed, but still listen to it http://www.linuxquestions.org/questions/linux-security-4/closing-port-631-ipp-382763/)

3. If the assumtion in 1. is correct, I've read that a solution could be to downgrade cups to version 1.3.11, as it there have support for usb-printers. I've managed to mask version 1.4.1 in both portage and entropy though. After I've read man equo and man emerge a bunch of times, and done a lot of creative commands in both I cannot see that downgrading under them is an option (correct me if I'm wrong). So I've tried to compile ver. 1.3.11, that seemed to work smooth, so I checked out in entropy, there it seems like I have ver 1.4.1, so i considered to remove it, would have been a pretty stupid move, as the veiredest and seemingly not related programs also would go down at same time.

4. Is there anything else I should consider? (Windows? Typewriter?)
Sockpuppet
Baby Hen
 
Posts: 7
Joined: Tue Oct 13, 2009 2:01

Re: I can't print, a few short questions.

Postby wolfden » Fri Nov 13, 2009 11:41

I think this:
http://en.gentoo-wiki.com/wiki/CUPS

will clear the air as it explains it in simple terms.

:D
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: I can't print, a few short questions.

Postby Sockpuppet » Mon Nov 16, 2009 0:12

Yes it did! :D

Theoretically I should have been there by now.
I still have a tiny problem, but I'll struggle a little, and see if I can work it out.

(And I'm sorry for a late reply, I've just managed to stay away from the computer 1,5 day, not bad for me. :lol: )
Sockpuppet
Baby Hen
 
Posts: 7
Joined: Tue Oct 13, 2009 2:01


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron