smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: Samba stopped working

Postby iamkrazee » Mon Nov 09, 2009 21:13

Latest world upgrade, up'd my KDE 4.3.2 to 4.3.3 and now it's working. We're all good!
iamkrazee
Young Hen
 
Posts: 34
Joined: Mon Apr 02, 2007 13:25

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby E.M.G. » Tue Nov 10, 2009 0:11

now after this update I have a samba shares icon and when I click it I see my windows workgroup, which I am also in this workgroup but when I click on the icon I get an authorization dialog box and no matter what combo I've tried I can't access the workgroup ... bottom of dolphin says access denied. I've tried, my user name and pw, root and the pw, and my windows logon and pw, nothing works... any ideas ??
E.M.G.
Simple Hen
 
Posts: 80
Joined: Tue Jun 24, 2008 18:50
Location: 42.44°N 73.11°W

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby iamkrazee » Thu Nov 12, 2009 8:31

Actually browsing with names has almost never worked for me. It's too inconsistent. Your best bet is to go by IP address.

example :

in dolphin address bar you type :
Code: Select all
smb://192.168.1.31/


You know...
iamkrazee
Young Hen
 
Posts: 34
Joined: Mon Apr 02, 2007 13:25

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby E.M.G. » Thu Nov 12, 2009 15:42

iamkrazee wrote:Actually browsing with names has almost never worked for me. It's too inconsistent. Your best bet is to go by IP address.

example :

in dolphin address bar you type :
Code: Select all
smb://192.168.1.31/


You know...

Yes ..if I use the ip it connects fine ... but my wife is less technical than I (she doesn't know what an IP is) ... so for her I need it to be "click simple" .... anyway ... I'm sure the devs will iron it out so I'll be patient and wait ... thanks
E.M.G.
Simple Hen
 
Posts: 80
Joined: Tue Jun 24, 2008 18:50
Location: 42.44°N 73.11°W

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby Fitzcarraldo » Thu Nov 12, 2009 18:34

If browsing Samba shares works with IP addresses but not with host names then it's probably because WinBind is not running or not configured correctly. I'm on a Windows PC at the moment so cannot investigate, but perhaps someone else can look at it.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby Fitzcarraldo » Fri Nov 13, 2009 2:28

I'm back on my SL laptop.

E.M.G., can you ping the Windows PC on your home network from your SL PC, using the host name of the Windows PC like so ("sa90" is the Computer Name of a Windows PC on my home network, as configured on that PC, i.e. I have not entered "sa90" in any configuration file on my SL laptop):

Code: Select all
# ping sa90
PING sa90.home (192.168.1.79) 56(84) bytes of data.
64 bytes from SA90.home (192.168.1.79): icmp_seq=1 ttl=128 time=5.69 ms
64 bytes from SA90.home (192.168.1.79): icmp_seq=2 ttl=128 time=5.19 ms
64 bytes from SA90.home (192.168.1.79): icmp_seq=3 ttl=128 time=3.22 ms
64 bytes from SA90.home (192.168.1.79): icmp_seq=4 ttl=128 time=3.28 ms
^C
--- sa90.home ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 3.225/4.348/5.695/1.112 ms
#]

And how about the nmblookup command? Does that show the IP address of the Windows PC like so?:

Code: Select all
# nmblookup sa90
WARNING: The "printer admin" option is deprecated
querying sa90 on 192.168.1.255
192.168.1.79 sa90<00>
#

If those two commands are working then launch Konqueror and click on Network Folders | Samba Shares, and you should see an icon for your home Windows network (mine's called "Workgroup").

Now, on my Windows PC "sa90" I have a user called "Fitzcarraldo". If I enter the address "smb:[email protected]/" (without the quotes) in the Konqueror address bar then I have access to my shared folder on the Windows PC. I was prompted for a username and password the first time, and I entered the Windows username (Fitzcarraldo) and that user's password for the Windows PC. If you enter a Samba address in the form I have indicated above, does that work for you?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby Fitzcarraldo » Fri Nov 13, 2009 2:51

Using Dolphin is similar to Konqueror, but not identical. Click on "Network" in the left panel of Dolphin. Then double-click on "Samba Shares" in the main panel of Dolphin. Your Windows home network should be shown (mine's called "Workgroup"). In the Dolphin address bar I enter the address "[email protected]/Workgroup" (without the quotes). I'm prompted for the username and password of the user on the Windows PC, and I enter the username as "[email protected]/Workgroup" (without the quotes) and I enter Fitzcarraldo's password for the Windows PC. Then the contents of the shared folder on the Windows PC are displayed in Dolphin's main panel and the address in the Dolphin address bar changes to "[email protected]".
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby E.M.G. » Fri Nov 13, 2009 2:52

Fitzcarraldo

Yes ping works correctly nmblookup works correctly ... in dophin and/or konqueror I can enter smb://192.168.2.8 and browse
I can enter smb://lvrmdktp <-- (name of windows machine) and browse the shares
I can enter smb:[email protected] I can browse the shares

its after I click samba shares , in dolphin, there I see my windows workgroup icon .... click that icon and the authorization dialog box
pops up .... then no matter what I put in there it fails...
E.M.G.
Simple Hen
 
Posts: 80
Joined: Tue Jun 24, 2008 18:50
Location: 42.44°N 73.11°W

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby Fitzcarraldo » Fri Nov 13, 2009 3:13

Same happens to me, but if you look at the Konqueror address bar it's displaying by default the address "smb://workgroup/" (because, in my case, "Workgroup" is the name of my Windows home network). The username and password it's asking for is not for the PC, but for the network address "smb://workgroup/" which is the entire Windows home network (which could have several PCs in it, not just one). I don't know if this is a new security feature of the latest version of Samba, or whether there is a configurable parameter to make Samba allow the file manager to view all the nodes (PCs, routers, networked printers, NAS, etc.) in the whole network without having to enter a password like it used to be, but there is a sort of logic to what is happening. The important thing is that automatic translation of name to IP address is working for you.

With Konqueror, once you are browsing the shared folder on the Windows PC, just bookmark it, and from then on you can easily navigate to it. With Dolphin, you can right-click in the left panel and select "Add Entry..." and add an icon to be able to navigate immediately to a Windows shared folder; in my case I specified the location for one of these as "smb:[email protected]" (without the quotes).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: smb problem after KDE 4.3.2 update: Sabayon 5.0 KDE [Solved]

Postby E.M.G. » Fri Nov 13, 2009 3:24

thanks Fitzcarraldo ... I just added it to the left side of dolphin .. thats also what the wife uses on her laptop so thats what I'll do ... even though its a bug to me it is a good security feature ... if that IS what it is ... lol
E.M.G.
Simple Hen
 
Posts: 80
Joined: Tue Jun 24, 2008 18:50
Location: 42.44°N 73.11°W

PreviousNext

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest