Wrong Keyboard

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Wrong Keyboard

Postby Il Neo » Thu Nov 05, 2009 4:26

Hello,
I am new to Sabayon but not new to Linux.
I recently installed Sabayon 5 and ran the updates (there were over 800 in total).

I am experiencing some strange problems with Sabayon.
When I installed Sabayon I selected the US keyboard which is what I have, yet that does not seem to be what was installed.
For instance shift 2 should produce the at symbol but instead gives me a "
The question mark is a É instead.
The double quotation mark is ` instead.

I tried to locate a spot in Sabayon where I could select the type of keyboard but could not find it (if indeed this is the cause of the problem).

Another problem that I am experiencing is that my speakers keep cracking or popping at random for no apparent reason.

I would greatly appreciate any help you may provide in helping me resolve these problems.
Il Neo
Young Hen
 
Posts: 29
Joined: Thu Nov 05, 2009 4:17

Re: Wrong Keyboard

Postby Marius » Thu Nov 05, 2009 6:43

If you use Gnome you should go to:

System > Preferences > Keyboard > Layouts

and check what is the default language. If you are not certain about exact keyboard layout used, you can always Add the language you want with the layout you want. In Sabayon's Gnome you are very conveniently presented with pretty keyboard diagrams showing the exact topology of the keyboard layout.

Afterwards you should simply remove the old default.
Marius
Simple Hen
 
Posts: 82
Joined: Thu Nov 01, 2007 5:48
Location: Berkeley, California

Re: Wrong Keyboard

Postby Il Neo » Fri Nov 06, 2009 5:10

Hello Marius,
I am using KDE and when I installed Sabayon 5 I selected English as the language and US keyboard.

I've just tried making some changes and will reboot to see if it helps.
Il Neo
Young Hen
 
Posts: 29
Joined: Thu Nov 05, 2009 4:17

Re: Wrong Keyboard

Postby Il Neo » Fri Nov 06, 2009 5:39

I had to select US keyboard instead of Canadian.
That fixed the keyboard problem, but now I have an American flag on display in the panel, but I am Canadian!
Il Neo
Young Hen
 
Posts: 29
Joined: Thu Nov 05, 2009 4:17

Re: Wrong Keyboard

Postby Fitzcarraldo » Fri Nov 06, 2009 14:47

Did you also do: Kickoff > Computer > System Settings > Regional & Language | Country or region, and select the region and country? Then try to select the keyboard (assuming you do have a Canadian format keyboard)?

EDIT: Once you have done that and rebooted, also have a look in the file /etc/env.d/02locale and check that all occurrences of "en_US" have been changed to "en_CA".
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Wrong Keyboard

Postby turquoise » Wed Nov 11, 2009 2:23

I am having a similar problem with canadian keyboard layouts. The only difference is that I'm trying to have the Canadian French layout instead of the Canadian Multilingual layout, which while it also has all the accent keys, is quite different (see: http://en.wikipedia.org/wiki/Keyboard_l ... l_Standard and compare with the Canadian French layout below!). I have been trying several layouts, but with the exception of the multilingual layouts, none seem to stick and revert to multilingual layout at the oddest moments, which is a pain in the place where the sun doesn't shine. I'm guessing Il Neo has the same problem, but with the Canadian English layout reverting to Multilingual layout.

As for background info, I had to boot the Live in English, with US English layout since it refused to work when I chose French language and Canadian keyboard layout. I did however choose French and French Canadian keyboard when I installed Sabayon to my hard drive.

Config of the keyboard layout switcher applet :
Keyboard Model : Generic 105-key (Intl) PC
Keyboard Layout : Canada
Layout variant : Default

Other choices for Layout variant are French (legacy), Multilingual, Multilingual first part, Multilingual second part, English, Dvorak, Inuktitut, Secwepemcstin, and Ktunaxa. However, I know Default is the layout variant I'm looking for because the keys are all in the right place when it does work.

I have added Canada and French to the country and languages settings, while removing English. My /etc/env.d/02locale contains the following :
LANG="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LANGUAGE="fr_FR.UTF-8"
GDM_LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"


Anyway, I might have found a possible solution which would be to set the keyboard parameters directly into the files in /etc/hal/fdi/policy folder. I will try it out and post the howto here if it works. Another solution would be to use Server Flags to avoid using Hal in the /etc/X11/xorg.conf file and enter manually the keyboard layout, which worked when I tried it on FreeBSD but is really only a workaround.
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Re: Wrong Keyboard

Postby turquoise » Thu Nov 12, 2009 23:45

The update to KDE 4.3.3 apparently solved the problem with the keyboard layout not "sticking", yay!

So to have the Canadian-English keyboard layout working properly, it should be a matter of doing the following :
Right-click on flag icon in system tray
Select configure
Add Canada to the keyboard layouts if not already done
Click on the flag
Choose the English variant (Layout Variant, lower left)
Click Apply.

I tested it and it works. Why the English layout isn't the default? I'm guessing that since the French Canadian one is the one that actually changes the layout, they decided to put that one as the default.

If it still doesn't work, then the solution would be to deactivate the keyboard layouts altogether. From what i could see, US layout is the default and it's the same as ca-eng so everything should be fine. If you really, really want to have Canadian English configured, then manually editing the file /etc/hal/fdi/policy/10-keymap.fdi should do the trick. The lines that need to added or changed are the following :

Code: Select all
<merge key="input.xkb.layout" type="string">ca</merge>
      <merge key="input.xkb.variant" type="string">eng</merge>
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest