cannot mount usb device

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 3
Joined: Wed Jan 17, 2007 15:57

cannot mount usb device

Post by shlobby » Tue Oct 27, 2009 22:14

hey there..
i have the following problem:

i have re-partitioned my external usbdrive via gparted.
not my system doesnt mount any usb-device anymore..
does anyone know how to mount it manually and how to make my system mount usb-devices automatically? before i used gparted everything worked well..

thanks in advance

Old Dear Hen
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: cannot mount usb device

Post by joeoden » Wed Oct 28, 2009 1:40

shlobby wrote:does anyone know how to mount it manually
First find out if drive is being recognized, plug it in
Open a terminal as root and type 'blkid' or 'fdisk -l' so that you know what device to use

Code: Select all

abayon-joe joe # blkid
/dev/sda6: LABEL="data" UUID="15363341-bc9f-45d8-8396-bf2e32f8bad5" TYPE="ext3"                                                                               
/dev/sda1: UUID="885837385837247A" TYPE="ntfs"                                 
/dev/sda3: LABEL="normal" UUID="d140c825-66db-4ca4-807e-bda9fe97f31c" TYPE="ext4"                                                                             
/dev/sda4: UUID="74beb1a9-d447-4102-95b3-5636f056786c" TYPE="swap"             
/dev/sda5: UUID="6022EC9425E49984" LABEL="ntfs2" TYPE="ntfs"                   
/dev/sda7: LABEL="sab5" UUID="fca54737-1006-4654-a312-4e3808041754" TYPE="ext4"                                                                               
/dev/sda8: LABEL="test" UUID="ee50923c-fc77-40d4-8976-31f405d7d81d" TYPE="ext4"                                                                               
/dev/sdb1: LABEL="KINGSTON" UUID="3984-1431" TYPE="vfat"                       
/dev/sdb2: UUID="671791284BBC00B5" TYPE="ntfs"                                 
If you look at the above code you can see that I have /dev/sdb1: and /dev/sdb2: these must be the partitions on my USB drive because they were not listed when I typed blkid before plugging in the drive

If I wanted to mount the first partition of that drive the old school way then the first thing to do is create a mount point, so in a terminal as root I would type
mkdir /mnt/temp

And then to mount the drive in a terminal as root I would type
mount /dev/sdb1 /mnt/temp

Note: mount will try to determine what type of file system is on the partition, sometimes you will have to supply options with the command mount, to learn which options you need, in a normal terminal type
man mount

When I want to remove the drive I have to un-mount it first, so in a terminal as root I would type
umount /mnt/temp

Then I would just disconnect the drive

If your USB drive is listed with the 'blkid' or 'fdisk -l' command then you would mount the drive using the GUI, which one are you using Gnome or KDE and what branch of Sabayon are you using 4 or 5
shlobby wrote:i have re-partitioned my external usbdrive via gparted
If your USB drive TYPE= is not listed with the 'blkid' or 'fdisk -l' command, then you forgot to format the partition

There is a lot of info about mount on the web if you haven't added the firefox search engine by wolfden, then do it now
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!

Post Reply