running cedega

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

running cedega

Postby lemons69 » Fri Oct 09, 2009 2:50

when ever i use the 'cedega' command as a prefix i get the following:

/usr/lib/transgaming_cedega/Point2Play_gui.py:35: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
import re, popen2, string
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
F1 2002-02-16 03:18:54,532 CRITICAL Unable to load GTK2 Python bindings: No module named gtk


To be completely honest, I dont even know where to start. IF someone could point me in the right direction that would be great
lemons69
Baby Hen
 
Posts: 6
Joined: Thu Sep 03, 2009 7:26

Re: running cedega

Postby xlnagla » Sat Oct 10, 2009 5:41

It would be prudent to ensure that pygtk, pygtkglext, and pygtksourceview are installed on your system. This may resolve your python module problems. Use sulfur, equo (entropy), or emerge (portage) to install them.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: running cedega

Postby lemons69 » Sun Oct 11, 2009 1:47

Ok I ran
equo install pygtk
equo install pygtklext
and equo install pygtksourceview, but i still get exactly the same message when i try to start cedega
lemons69
Baby Hen
 
Posts: 6
Joined: Thu Sep 03, 2009 7:26

Re: running cedega

Postby xlnagla » Sun Oct 11, 2009 18:07

Interesting. Is there a configuration file for cedega anywhere which allows you to specify where it can find python libraries? The packages I recommended to you were the only python-gtk packages that are in gentoo, so one of them should totally have worked... try installing glade too, as that's a normal cedega dependency.

Out of curiosity, did you use our package manager to install cedega? If you did not, then I would highly recommend you uninstall cedega by whatever method you originally installed it and use equo to re-install it. We don't have fetch restriction turned on (for some odd reason), so you can completely install it through equo. If you did use entropy to install cedega, run an equo deptest && equo libtest to see if equo can find packages to fit your missing modules.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: running cedega

Postby lemons69 » Mon Oct 12, 2009 19:45

I did install it through entropy, but i will definitely uninstall and try again. I have reinstalled once or twice, but its always worth another shot.

results of equo deptest && equo libtest

Code: Select all
lemons Desktop # equo deptest && equo libtest
>>  @@ Running dependency test ...
>>  @@ Caching complete.
>>  @@ Libraries test
>>  @@ Collecting broken executables
>>  @@ Attention: don't worry about libraries that are shown here but not later.
>>    (17.1%) /usr/lib/xulrunner/plugins/libunixprintplugin.so [ libxpcom.so.1 :: libxul.so.1 ]
>>    (91.7%) /usr/lib/xulrunner/plugins/libnullplugin.so [ libxpcom.so.1 :: libxul.so.1 ]
>>    (95.1%) /usr/lib/openoffice/basis3.1/program/stocservices.uno.so [ libuno_cppu.so.3 :: libuno_cppuhelpergcc3.so.3 :: libuno_sal.so.3 ]
>>  @@ Matching broken libraries/executables
>>  @@ Libraries/Executables statistics:
>>  ## Not matched:
>>     => /usr/lib/openoffice/basis3.1/program/stocservices.uno.so
>>     => /usr/lib/xulrunner/plugins/libnullplugin.so
>>     => /usr/lib/xulrunner/plugins/libunixprintplugin.so
>>  ## Matched:
>>  @@ Caching complete.


Im not really sure what to get out of that really haha. And i ran equo install glade as root, still the same results. I will have to hunt around a bit for a config file, i will repost if I can find anything.
lemons69
Baby Hen
 
Posts: 6
Joined: Thu Sep 03, 2009 7:26

Re: running cedega

Postby xlnagla » Tue Oct 13, 2009 0:03

I don't know what to tell you - cedega's working perfectly through entropy here. It could be some versioning/compilation problems in the entropy version of cedega you're using - If you're really having trouble install it with portage (using emerge), just be sure to have your cedega key on you in order to download it first!

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 5 guests