sabayon 4.2 on fsc amilo xa 3530 ati driver install problem

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

sabayon 4.2 on fsc amilo xa 3530 ati driver install problem

Postby johnaA » Thu Oct 01, 2009 16:19

hello@all!

i have just installed the sabayon 4.2 os and when it stars up, it cannot load the fglrx driver. i also tried to load the radeon and radeonhd driver, setting it up in the xorg.conf, getting also a error that the fglrx module is still running and makes problems.

here my /var/log/Xorg.0.log and /etc/X11/xorg.conf for errorsearching, hope it will help!

Code: Select all
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.3.901 (1.6.4 RC 1)
Release Date: 2009-8-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.29-sabayon x86_64
Current Operating System: Linux johnbox 2.6.29-sabayon #1 SMP Thu Jun 11 13:33:04 UTC 2009 x86_64
Build Date: 01 October 2009  04:53:27PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct  1 17:00:48 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Main Layout"
(**) |-->Screen "Screen 0" (0)
(**) |   |-->Monitor "Generic Monitor"
(**) |   |-->Device "SabayonVga0"
(**) |-->Screen "Screen 1" (1)
(**) |   |-->Monitor "Generic Monitor"
(**) |   |-->Device "SabayonVga1"
(**) Option "AllowMouseOpenFail" "true"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
(==) ModulePath set to "/usr/lib64/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
   If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0xf10
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 5.0
   X.Org XInput driver : 4.0
   X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(!!) More than one possible primary device found
(--) PCI: (0:1:5:0) 1002:9612:1734:c08d ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] rev 0, Mem @ 0xa0000000/268435456, 0x9fdf0000/65536, 0x9fe00000/1048576, I/O @ 0x00009000/256
(--) PCI: (0:2:0:0) 1002:9591:1734:c09d ATI Technologies Inc Mobility Radeon HD 3650 rev 0, Mem @ 0xc0000000/536870912, 0x9fbf0000/65536, I/O @ 0x0000a000/256, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) System resource ranges:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [5] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [6] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [7] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [8] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [9] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [10] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [11] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [12] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [13] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [14] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [15] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [16] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [17] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [18] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [19] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [20] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [21] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [22] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [23] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [24] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [25] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [26] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [27] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [28] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [29] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [30] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [31] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [32] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [33] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
   [34] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [35] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "i2c"
(II) Module "i2c" already built-in
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) LoadModule: "vbe"
(II) Loading /usr/lib64/xorg/modules//libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.1.0
   ABI class: X.Org Video Driver, version 5.0
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "synaptics"
(II) Loading /usr/lib64/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.1.0
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 2.1
(EE) module ABI major version (2) doesn't match the server's version (4)
(II) UnloadModule: "synaptics"
(II) Unloading /usr/lib64/xorg/modules/input//synaptics_drv.so
(EE) Failed to load module "synaptics" (module requirement mismatch, 0)
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.6.3.901, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(WW) Warning, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.



Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "fglrx"
    BusID    "PCI:01:05"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Device"

    Identifier  "SabayonVga1"
    Driver      "fglrx"
    BusID    "PCI:02:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection



Section "Screen"

    Identifier    "Screen 1"
    Device        "SabayonVga1"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
    Screen 1    "Screen 1"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
johnaA
Baby Hen
 
Posts: 1
Joined: Thu Oct 01, 2009 9:01

Re: sabayon 4.2 on fsc amilo xa 3530 ati driver install problem

Postby micia » Fri Oct 02, 2009 9:39

did you update some package, or it did not work since the beginning?

You could try to login in console mode as root and check:
Code: Select all
eselect kernel list

and
Code: Select all
eselect opengl list


You can post their output here.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron