Compiz fusion is slow

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Compiz fusion is slow

Postby mattk132 » Thu Aug 13, 2009 1:04

Hey everybody I just installed fresh a few nights ago. This is my first time using Sabayon linux. And whenever I use compiz fusion I get very very slow frame rates. In windows I can play Cod4 at 70 fps so its not my hardware. Any help is greatly appreciated.
mattk132
Baby Hen
 
Posts: 5
Joined: Thu Aug 13, 2009 1:01

Re: Compiz fusion is slow

Postby joeoden » Thu Aug 13, 2009 3:01

More info please
what hardware, cpu, chipset, amount of ram, video card, what version of sabayon
How you start compiz

mattk132 wrote:In windows I can play Cod4 at 70 fps so its not my hardware.

If you mean in MS Windows, just because it works in MS does not mean it will work in linux
MS is not fussy about the hardware it runs on
Linux is very fussy about the hardware it runs on

For example I like to play sauerbraten,
when played under MS with my HP C700 (celeron m cpu 1.73 mhz, intel chipset, intel gm965/gl960 intergrated graphics, 2 gig ram and 250 gig hard drive) it works no problems,
when played under Sabayon 3.5 kde it works no problems,
when opened under Sabayon branch 4 kde resolution problems and locks up
when opened under Sabayon branch 5 kde works but fps is 10 and weapons are not displayed
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!
joeoden
Old Dear Hen
 
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: Compiz fusion is slow

Postby mattk132 » Thu Aug 13, 2009 3:05

Specs:
Processer: Intel Q6600
Graphics card: Nvidia gts 260
Ram: 4gb
Sabayon 4.1

I start compiz fusion by running: fusion-icon.
I've also tried compiz --replace but that doesn't help
mattk132
Baby Hen
 
Posts: 5
Joined: Thu Aug 13, 2009 1:01

Re: Compiz fusion is slow

Postby joeoden » Thu Aug 13, 2009 3:40

Your system has a lot more power than mine best desktop

I run kde
Make sure Enable desktop effects is unselected in System Setting- Desktop
Also in System Settings, there is an option to start compiz in Default Applications-Window Manger, and select compiz custom (create wrapper script 'compiz-kde-launcher' to launch it)

You might have problems enabling it, if you do try just selecting compiz if it does not start at starup then you should add it to Autostart in System Setting-Advanced tab-Autostart

I'm not sure of the settings for Gnome (I think gnome-control-center)

Maybe someone with same hardware as you might be able to help
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!
joeoden
Old Dear Hen
 
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: Compiz fusion is slow

Postby mattk132 » Thu Aug 13, 2009 16:20

I have used gnome until now and I'm a complete newb with KDE.
If you could give me detailed newby instructions to get to the areas you referred to in your last post that would be great.
Thank you so much.
mattk132
Baby Hen
 
Posts: 5
Joined: Thu Aug 13, 2009 1:01

Re: Compiz fusion is slow

Postby joeoden » Fri Aug 14, 2009 1:05

mattk132 wrote:If you could give me detailed newby instructions to get to the areas you referred

Click on Kickoff (the K on right hand side of the taskbar)
Move mouse to Computer
Click on System Settings

The System Setting window appears, the General tab page displayed by default, if you require an item from the advanced section click on the Advanced tab

Double click on Default Application
Click on Window Manger
Click on Use a different window manager:
From the drop down list select compiz custom (create wrapper script 'compiz-kde-launcher' to launch it)
Click the Apply button
Click the OK button
Click the Accept button
Close all open programs and restart computer

If you are going to have a problem then the Sorry - System Settings message appears
The running window manager has been reverted to the default KDE window manager KWin.

If you have a problem, Just add Compiz Fusion Icon to the Autostart from the advanced section
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!
joeoden
Old Dear Hen
 
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: Compiz fusion is slow

Postby mattk132 » Fri Aug 14, 2009 1:18

Thanks for the Newbie help.

I disabled desktop effects and started compiz at the beginning of my session.
But my frame rates are still unchanged.
mattk132
Baby Hen
 
Posts: 5
Joined: Thu Aug 13, 2009 1:01

Re: Compiz fusion is slow

Postby joeoden » Fri Aug 14, 2009 11:10

mattk132 wrote:But my frame rates are still unchanged

Could be driver or and a software setting problem, try updating your system
http://wiki.sabayonlinux.org/index.php? ... t_to_do.3F

Maybe try from a terminal as root (to become root type su press enter then type your password and press enter)
equo deptest
equo libtest

Only other thing I can suggest is try Compiz with the Sabayon live DVD
Place dvd in optical drive restart computer (make sure it boots from DVD)
Make sure the first item is selected (is by default anyway) press enter
When system has finished loading, double click the Compiz Fusion Icon on desktop and wait for it to load
Right click on the Compiz Fusion Icon in the systray (blue box next to clock) on the taskbar
Select and click on Settings Manager

The CompizConfig Settings Manager window will appear, now do some testing
Move your mouse to the Title Bar of the CompizConfig Settings Manager window (the Title Bar is the top of the window and has the name of the window in it (in this case CompizConfig Settings Manager))

Now click and hold the left mouse button (click and drag) on the Title Bar and now move your mouse around (from side to side as well as up and down), the window should wobble (Wobbly Windows effect) with no problems (not slow or/and jerky) If is slow or/and jerky (is a problem maybe driver settings, but don't hold me to that)

Next test I do is to enable Animations (window pops up and you should Disable Minimize Effect)
Enable Animations Add-On
Enable 3D Windows
Enable Vieport Switcher (to test Vieport Switcher move mouse to empty part of Desktop, click and hold your wheel on the mouse and move your mouse) the desktop turns into a cube that moves around as you move your mouse. If is slow or/and jerky (is a problem)

I like to use the Dream effect for the opening of all types of windows and the Burn effect for the closing of all types of windows, you can access these options by clicking on the word Animations (I wont tell you how, but try experimenting)
If is slow or/and jerky (is a problem)

Now if all the above settings are working to your satisfaction while using the Live DVD
You could try exporting the profile (click on Preferences in the CompizConfig Settings Manager window) from the live DVD and import the saved profile to the copy of Sabayon you have installed on your hard drive

If it Compiz still is slow after the import
I would suggest to create another partition on your hard drive and install a clean copy of Sabayon because you may have changed some settings without realizing (I know it sounds a bit overboard but don't forget that Sabayon is a rolling release (you can still boot to your original when you want)) then once another clean install is done on your computer the same settings should work better than the live DVD

I have done this on one of my systems, one partition is for normal use and the other is for testing, on the testing one I recently installed some test programs and updates which broke the system, after getting the system running again Compiz is slow and jerky but on the normal one Compiz is working as it should

Hope you get it working
Joe
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!
joeoden
Old Dear Hen
 
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: Compiz fusion is slow

Postby mattk132 » Sat Aug 15, 2009 18:44

Thanks for all your help
mattk132
Baby Hen
 
Posts: 5
Joined: Thu Aug 13, 2009 1:01


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests