Firefox 3.5 Problem [Solved]

Anything that pertains to Portage

Moderator: Moderators

Firefox 3.5 Problem [Solved]

Postby AlmaFuerte » Sat Jul 25, 2009 17:17

Hi people! When i try to emerge firefox 3.5

Code: Select all
#emerge www-client/mozilla-firefox

everything appears fine until i get:

Code: Select all
cp: cannot stat `/usr/local/portage/layman/sabayon/www-client/mozilla-firefox/files/3.5.1/gentoo-default-prefs.js': No such file or directory
!!! newins: /usr/local/portage/layman/sabayon/www-client/mozilla-firefox/files/3.5.1/icon/mozilla-firefox-1.5.desktop does not exist
>>> Completed installing mozilla-firefox-3.5.1-r10 into /var/tmp/portage/www-client/mozilla-firefox-3.5.1-r10/image/

 * QA Notice: file does not exist:
 *
 *      newins: /usr/local/portage/layman/sabayon/www-client/mozilla-firefox/files/3.5.1/icon/mozilla-firefox-1.5.desktop does not exist


 * QA Notice: Pre-stripped files found:
 * /usr/lib64/mozilla-firefox/firefox
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/lib64/mozilla-firefox/components/libbrowserdirprovider.so
   usr/lib64/mozilla-firefox/components/libnkgnomevfs.so
   usr/lib64/mozilla-firefox/components/libbrowsercomps.so

>>> Installing (1 of 1) www-client/mozilla-firefox-3.5.1-r10
 * All the packages built against mozilla-firefox won't compile,
 * if after installing firefox 3.5 you get some blockers,
 * please add 'xulrunner' to your USE-flags.
 * any package that fails to build warrants a bug report.
 *
 * Updating desktop mime database ...

>>> Recording www-client/mozilla-firefox in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


Then, when i execute from console i get

Code: Select all
#firefox
Couldn't load XPCOM.


Any ideas??
Last edited by AlmaFuerte on Tue Jul 28, 2009 4:18, edited 1 time in total.
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Firefox 3.5 Problem

Postby wolfden » Sat Jul 25, 2009 18:18

Code: Select all
revdep-rebuild -p


are you sure u want to be mixing package managers?
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Firefox 3.5 Problem

Postby rpil » Sat Jul 25, 2009 19:10

To me, with the same command
Code: Select all
emerge www-client/mozilla-firefox 3.5

returns me
Code: Select all
there are no ebuilds to satisfy "www-client/mozilla-firefox".

Why is that? :(
rpil
Young Hen
 
Posts: 30
Joined: Thu May 29, 2008 13:59

Re: Firefox 3.5 Problem

Postby AlmaFuerte » Sat Jul 25, 2009 19:25

Because there are no ebuilds to satisfy that. You must do a sync, and then you got the latest version of firefox in portage.
Later, do

Code: Select all
#emerge www-client/mozilla-firefox


or you can tell portage via emerge what version do you want. See

Code: Select all
#man emerge

for more details.
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Firefox 3.5 Problem

Postby AlmaFuerte » Sat Jul 25, 2009 19:33

wolfden, when i do

Code: Select all
revdep-rebuild -p


not fix the problem. I try reintalling but the same happen.

are you sure u want to be mixing package managers?


I'm only using portage....
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Firefox 3.5 Problem

Postby wolfden » Sat Jul 25, 2009 19:36

AlmaFuerte wrote:wolfden, when i do

Code: Select all
revdep-rebuild -p


not fix the problem. I try reintalling but the same happen.

are you sure u want to be mixing package managers?


I'm only using portage....


it won't fix it, it's the pretend switch, you have to
Code: Select all
revdep-rebuild
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Firefox 3.5 Problem

Postby wolfden » Sat Jul 25, 2009 19:38

rpil wrote:To me, with the same command
Code: Select all
emerge www-client/mozilla-firefox 3.5

Why is that? :(


wrong command

If you are not familiar with portage, you should probably stick with entropy package manager:
http://wiki.sabayonlinux.org/index.php?title=Entropy

you can bust your system if you don't know what your are doing and mix the managers
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Firefox 3.5 Problem

Postby AlmaFuerte » Sat Jul 25, 2009 19:59

Yes, of course i run the command without the pretend option. That not fix the problem, when i reinstall firefox the same output appears. One thing that took my attention is that when i execute revdep-rebuild it says that all the xulrunner libs are broken...
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Firefox 3.5 Problem

Postby wolfden » Sat Jul 25, 2009 21:26

did revdep-rebuild install anything?

like xulrunner
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Firefox 3.5 Problem

Postby Thev00d00 » Sun Jul 26, 2009 19:17

what version of xulrunner do you have?
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Next

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest