emerge -auDN world not working

Anything that pertains to Portage

Moderator: Moderators

emerge -auDN world not working

Postby Amranu » Fri Jul 24, 2009 16:32

Whenever I try to do this I get:

Code: Select all
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

dev-python/PyQt4:0

  ('ebuild', '/', 'dev-python/PyQt4-4.5.2', 'merge') pulled in by
    >=dev-python/PyQt4-4.4.4-r1[dbus] required by ('installed', '/', 'kde-base/system-config-printer-kde-4.2.1', 'nomerge')                                           

  ('installed', '/', 'dev-python/PyQt4-4.5.1-r1', 'nomerge') pulled in by
    >=dev-python/PyQt4-4.5_pre1[dbus,svg,webkit,X] required by ('installed', '/', 'kde-base/pykde4-4.2.4-r2', 'nomerge')                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are       
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.                                             

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "<sys-kernel/genkernel-3.4.11" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-kernel/genkernel-3.4.10.905 (masked by: package.mask)
- sys-kernel/genkernel-3.4.10.904-r1 (masked by: package.mask)
- sys-kernel/genkernel-3.4.10.904 (masked by: package.mask)
- sys-kernel/genkernel-3.4.10-r5 (masked by: package.mask)
- sys-kernel/genkernel-3.4.10-r2 (masked by: package.mask)
- sys-kernel/genkernel-3.4.10-r1 (masked by: package.mask)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "sys-kernel/linux-sabayon-2.6.30" [ebuild])
(dependency required by "net-dialup/ppp-2.4.4-r23" [ebuild])
(dependency required by "net-dialup/pptpclient-1.7.2" [ebuild])
(dependency required by "world" [argument])
Amranu
Baby Hen
 
Posts: 6
Joined: Fri Jul 25, 2008 21:09

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest