hplip, linux-sabayon-sources, and 2.6.29 [Solved]

Anything that pertains to Portage

Moderator: Moderators

Post Reply
Advanced Hen
Posts: 200
Joined: Sun May 06, 2007 21:28

hplip, linux-sabayon-sources, and 2.6.29 [Solved]

Post by joe3 » Sun Jul 12, 2009 1:28

Just a quick post script to this subject. As I indicated below I found out how to get the 2.6.29 kernel source. The bigger issue of the corrupted kde moved to another thread. But the short skinny is that 3 attempst to emerge rhe same list of desired packages (each to a fresh clean install of the x86_64 kde version of Sabayon4.2) ended with a non functional kde... The forth attempt succeeded without error. The only differences besides the order in which the packages were emerged and the number of times the system was rebooted to test that the most recent few emerges hadn't ended with a non functional startkde was that on the 4th attempt I didn't unmask and install the latest portage??? Figure that?!?
Well I'm liking most of sabayon 4.2, (once e16 keeps me from pulling my hair out over the way kde4 does things)...
It was time to install my printer. I was in e16 so I couldn't just look at the kmenu for the printer tools... No problem I thought, they put the functionality of the old kcontrol in systemsettings did they not? (In my oppinion they did not!)
Though most of my sour grapes on that is the iconful interface. But it seams to me that one of the choices in the old kcontrol was the priner configureation/management tools. But if their hiding under one of those icons in system settings, I sure can't find them. Now I suppose, I could have just closed half a dozen applications, logged out of e16, fired up a kde session and used the kmenu... But I remembered a tool I used to have called hp-toolbox. If I remember right it was provided by hplip. So I opened a root shell and did an emerge hplip, Which installed 5 out of 6 items. Stopping on number 6 (hplip itself) because it wanted a symlink at /usr/src/linux to point at my kernel sources. (I don't roll my own kernels so it took a bit of googleing to learn that I needed "linux-sabayon" to get that, eix told me that my kernal was compiled with:

Installed versions: 2.6.29(2.6.29)(05:01:40 AM 07/09/2009)(dmraid splash -build -grub -no_sources -only_sources -symlink)

And like a dummy it didn't occur to me that the only available linux-sabayon-sources was for a higher kernel version:
Available versions: (2.6.30) (~)2.6.30
{build symlink}

Which I thought would build enough for me to point the symlink at the right kernel version But of course, Now I have a symlink pointing at the wrong version, and still don't have the sources for the 2.6.29 kernal to point a new symlink at...
One odd thing though, Imust not understand what the symlink vs -symlink in the (keywords?) means because while the available linux-sabayon-sources said "symlink" when I emerged it I got:

Installed versions: 2.6.30(2.6.30)(04:41:45 PM 07/11/2009)(-build -symlink)

Which, in spite of the "-symlink" did automaticaly create the link to a kernal I'm not likely to learn how to build any time soon. So I suspect that I should trash the symlink to avoid problems with some ebuild that expects it to be right such as the hplip... (Should I "rm /usr/src/linux" ? Or would I need to unmerge the whole dang linux-sabayon-sources package to stay out of trouble with it pointing at the wrong kernel???)

On another note, just before I emerged the wrong linux-sabayon-source I peeked at what "equo install --ask hplip" would do. And it wanted to install most of the same packages that emerge had added before it decided it couldn't complete the hplip install. Nearly the same version numbers. Thing is equo didn't seam to see the ones emerge just added. and that made me to nervous to let it try... Especialy when as far as I can see the xsane was the very same version:

>> ## [N] [sabayonlinux.org] media-gfx/xv-3.10a-r15|0
>> ## [N] [sabayonlinux.org] dev-perl/perl-tk-804.027|2
>> ## [N] [sabayonlinux.org] media-gfx/xsane-0.996|0
>> ## [N] [sabayonlinux.org] net-analyzer/net-snmp-|0
>> ## [N] [sabayonlinux.org] dev-python/imaging-1.1.6|4
>> ## [N] [sabayonlinux.org] dev-python/reportlab-2.1|0
>> ## [N] [sabayonlinux.org] net-print/hplip-3.9.2|0

* dev-perl/perl-tk
Latest version available: 804.028-r2
Latest version installed: 804.028-r2
Size of files: 6,765 kB
Homepage: http://search.cpan.org/dist/Tk
Description: A Perl Module for Tk
License: Artistic

* media-gfx/xsane
Latest version available: 0.996
Latest version installed: 0.996
Size of files: 3,265 kB
Homepage: http://www.xsane.org/
Description: graphical scanning frontend
License: GPL-2

* net-analyzer/net-snmp
Latest version available:
Latest version installed:
Size of files: 5,063 kB
Homepage: http://net-snmp.sourceforge.net/
Description: Software for generating and retrieving SNMP data
License: as-is BSD

* dev-python/imaging
Latest version available: 1.1.6-r1
Latest version installed: 1.1.6-r1
Size of files: 425 kB
Homepage: http://www.pythonware.com/products/pil/index.htm
Description: Python Imaging Library (PIL)
License: as-is

* dev-python/reportlab
Latest version available: 2.3
Latest version installed: 2.3
Size of files: 1,813 kB
Homepage: http://www.reportlab.org/
Description: Tools for generating printable PDF documents from any data source.
License: BSD

In any case I'd rather get hplip from emerge anyway, How do I get the linux-sabayon-source for the kernel I'm using?


Last edited by joe3 on Mon Jul 20, 2009 3:56, edited 1 time in total.

Generally Awesome (tm)
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: hplip, linux-sabayon-sources, and 2.6.29 with -symlink

Post by Thev00d00 » Sun Jul 12, 2009 11:47

Code: Select all

eselect kernel list
eselect kernel set #
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me

Advanced Hen
Posts: 200
Joined: Sun May 06, 2007 21:28

the 2.6.29 symlink is [solved] But there's a bigger problem!

Post by joe3 » Sun Jul 12, 2009 17:11

Thank you for responding Thev00d00. But before 'eselect kernel list' could display more than that 2.6.30 kernel I'm not using, I needed to get the kernel source to the 2.6.29 kernal that the Sabayon 4.2 (KDE)dvd installer didn't give me...
Fortunately I tripped over some old crib notes that reminded me how to specify a particular version of a package in an emerge command... Thus 'emerge -a =sys-kernel/linux-sabayon-2.6.29' reinstalled the 2.6.29 kernel, (this time with sources and of course genkernel etc...).

However at the moment I have bigger fish to worry about. But I'm not sure which forum to post about it in.

I'm not sure if the emerge I did last night was responsible for some missing files or not, But I can't imagine what else happened, to cause a critical kde4-config file to disappear. Which renders kde4 unstartable, and evedentaly keeps /usr/kde/4.2/bin from being included in the system defined user path

Last night, while I was looking around for those crib notes I just mentioned, I wanted to use kwrite, which I didn't have on this installation yet. I don't remember what other packages emerge wanted to install with it, but at least one of them almost sounded like support stuff that I shouldn't need because I do still have kde... But I simply figured that the new portage was able to detect that I was running e16, and perhaps was including file to prevent the error messages I sometimes used to get (with 3.5) about some kde application not being able to talk to some kde daemon process...
I know that at that point my path still included /usr/kde/4.2/bin, when I started that emerge because to get a root shell to do the emerge with, I opened a fresh konsole screen with this e16 keybinding 'KeyDown SC Prior exec konsole --profile BlackYellow -e medosumc' (medosumc is a one line script that executes AFTER the konsole is created to do an " su -c mc ") And a NEW Konsole screen opened for it. But since I was tired, I switched to watching TV And the only other thing I did on my computer was, on my way to bed I looked at the tail end of emerge's output to be sure that it didn't list any errors, Closed the e16 gui, and triggered a shutdown via ctl+alt+del in the virtual console I'd run startx from...

When I booted this morning I thought I'd see about using kde to install my printer. So I coppied my xinitrc-kde file to ~/.xinitrc , and ran startx. But unlike 3 days ago when I last ran kde, I got a pop-up message stating that there wasn't a file at: "/usr/kde/4.2/bin/kde4-config" And when I clicked on it, I was back in the virtual console... So I rebooted sabayon4.2, (this time without the nox kernel argument, half way expecting kdm to fail, But I'm not even sure I got kdm, The login screen was way to minimalistic, and didn't include a means of selecting what kind of session I wanted. I logged in anyway and got some minimalistic window manager...
I rebooted again (with nox) reinstated my e16 version .xinitrc, and ran startx. e16 is still working, But ksnapshot couldn't start, and yakuake complained about not finding konsole in my path... Fortunately I have one xterm listed in the xinitrc so I was able to use it to open a few more, as well as firefox. IN one of the xterms I did the following to determine that (A) my $PATH variable is still correct, and (B) the executable for konsole isn't where it's supposed to be...

Code: Select all

JtWdyP -> /home/jtwdyp
> which konsole
which: no konsole in (/home/jtwdyp/bin:/home/jtwdyp/bin1st:/usr/local/bin:/usr/bin:/bin:/usr/share/e16usr/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.2:/opt/blackdown-jdk-
JtWdyP -> /home/jtwdyp
I noticed that it included an /usr/kde/3.5/bin But not an /usr/kde/4.2/bin... Thus:

Code: Select all

JtWdyP -> /home/jtwdyp
> /usr/kde/4.2/bin/konsole
JtWdyP -> /home/jtwdyp
Did open a konsole, But I note that it's not using the keybinding changes I made to the konsole's default profile, nor does
( Settings -> Manage Profiles) find the alternate (colors/fonts) version profiles I set up, such as the 'BlackYellow' one I use for root shells... (I do hope that restoring the missing "/usr/kde/4.2/bin/kde4-config" file gets my profile settings back)
But I don't have a copy of the "/usr/kde/4.2/bin/kde4-config" file. I'd hate to have to re-emerge kde4.2 to get one.

Can anyone tell me where I can download a copy of the "/usr/kde/4.2/bin/kde4-config" file that is compatable with the kde4.2 provided by the Sabayon 4.2 (kde/amd-64 version) instalation dvd????


Post Reply