I don't know how to tackle this problem. Adding USE flags or what? there seems to be multiple problems with my installation. What should be the right order of getting them solved?
Code: Select all
emerge -auv world These are the packages that would be merged, in order: Calculating dependencies... done! !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: sys-auth/pambase:0 ('ebuild', '/', 'sys-auth/pambase-20090620.1', 'merge') pulled in by sys-auth/pambase:0 required by world >=sys-auth/pambase-20090430[consolekit,-gnome-keyring] required by ('ebuild', '/', 'gnome-base/gdm-2.20.10-r1', 'merge') ('installed', '/', 'sys-auth/pambase-20090620.1', 'nomerge') pulled in by sys-auth/pambase:0 required by world It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. !!! Problems have been detected with your world file !!! Please run emaint --check world !!! Ebuilds for the following packages are either all !!! masked or don't exist: x11-plugins/compiz-fusion-plugins-unsupported:0 net-misc/et131x:0 x11-themes/murrine media-sound/amarok:2 emerge: there are no ebuilds built with USE flags to satisfy ">=dev-python/PyQt4-4.5_pre1[dbus,svg,webkit,X]". !!! One of the following packages is required to complete your request: - dev-python/PyQt4-4.5.1-r1 (Change USE: +webkit) (dependency required by "kde-base/pykde4-4.2.4-r2" [ebuild]) (dependency required by "world" [argument])
Added 2 july 2009: "equo update && equo world" did the trick.