what to make out of this log? [Solved]

Anything that pertains to Portage

Moderator: Moderators

what to make out of this log? [Solved]

Postby agryppa » Wed Jul 01, 2009 23:04

Hi,
I don't know how to tackle this problem. Adding USE flags or what? there seems to be multiple problems with my installation. What should be the right order of getting them solved?

Code: Select all
emerge -auv world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

sys-auth/pambase:0

  ('ebuild', '/', 'sys-auth/pambase-20090620.1', 'merge') pulled in by
    sys-auth/pambase:0 required by world                             
    >=sys-auth/pambase-20090430[consolekit,-gnome-keyring] required by ('ebuild', '/', 'gnome-base/gdm-2.20.10-r1', 'merge')

  ('installed', '/', 'sys-auth/pambase-20090620.1', 'nomerge') pulled in by
    sys-auth/pambase:0 required by world                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
x11-plugins/compiz-fusion-plugins-unsupported:0 net-misc/et131x:0 x11-themes/murrine media-sound/amarok:2

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-python/PyQt4-4.5_pre1[dbus,svg,webkit,X]".
!!! One of the following packages is required to complete your request:
- dev-python/PyQt4-4.5.1-r1 (Change USE: +webkit)
(dependency required by "kde-base/pykde4-4.2.4-r2" [ebuild])
(dependency required by "world" [argument])



Added 2 july 2009: "equo update && equo world" did the trick.
Last edited by agryppa on Thu Jul 02, 2009 18:33, edited 1 time in total.
agryppa
Baby Hen
 
Posts: 15
Joined: Tue May 19, 2009 22:47

Re: what to make out of this log?

Postby wolfden » Thu Jul 02, 2009 6:36

are you sure u want to be using portage instead of entropy?

it tells you what is going on in error message if you look

Code: Select all
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected.


Code: Select all
!!! Problems have been detected with your world file
!!! Please run emaint --check world


Code: Select all
!!! One of the following packages is required to complete your request:
- dev-python/PyQt4-4.5.1-r1 (Change USE: +webkit)


but are you sure u don't want to be running

Code: Select all
equo update && equo world


?

If you haven't edited the config files it's kinda pointless to emerge world
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron