XFCE e Kernel superiore a 4.1.0 [Risolto]

Problemi relativi a KDE, GNOME o altri ambienti grafici? Scrivi pure qui!

Moderator: Moderators

Post Reply
kernuss
Young Hen
Posts: 24
Joined: Mon Jan 12, 2015 8:36

XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by kernuss » Mon Nov 30, 2015 16:32

Ciao a tutti!
Uso la versione 15.08 64bit con XFCE , driver proprietari nVidia aggiornati e, se lo avvio usando un kernel superiore a 4.0.1, dopo la schermata di boot resta con il cursore lampenggiante in alto a destra

Con il Kernel 4.1.0 tutto ok; ho provato sia con il 4.2.0, 4.2.5 e 4.3.0 installato via Rigo

Cosa dovrei controllare?
Last edited by kernuss on Tue Dec 01, 2015 22:14, edited 1 time in total.

User avatar
fiorello
Sagely Hen
Posts: 1242
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: XFCE e Kernel superiore a 4.1.0

Post by fiorello » Mon Nov 30, 2015 18:38

Ciao kernuss.

Ti consiglio di installare i nuovi drivers usando la konsole con il comando kernel-switcher dato da root, se ci sono degli errori te li mostra e li puo postare.

Esempio se voglio installare un nuovo kernel:

In una konsole scrivi → su → tasto invio

Code: Select all

equo update

equo upgrade --ask

Code: Select all

equo search linux-sabayon

Code: Select all

@@ Paquet: sys-kernel/linux-sabayon-4.1.12 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 4.1.12 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: 4.1.12 ~ tag: NoTag ~ révision: 0
╠          entaille:         4.1
╠          Page d'accueil:   https://github.com/Sabayon/kernel 
╠          Description:      Official Sabayon Linux Standard 
╠                            kernel image 
╠          License:          GPL-2 freedist
╠      @@ Paquet: sys-kernel/linux-sabayon-4.2.5 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 4.2.5 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: 4.2.5 ~ tag: NoTag ~ révision: 0
╠          entaille:         4.2
╠          Page d'accueil:   https://github.com/Sabayon/kernel 
╠          Description:      Official Sabayon Linux Standard 
╠                            kernel image 
╠          License:          GPL-2 freedist
╠      @@ Paquet: sys-kernel/linux-sabayon-4.3 branche: 5, [sabayonlinux.org] 
╠          Disponible:       version: 4.3 ~ tag: NoTag ~ révision: 0
╠          Installé:         version: Pas installé ~ tag: n/a ~ révision: n/a
╠          entaille:         4.3
╠          Page d'accueil:   https://github.com/Sabayon/kernel 
╠          Description:      Official Sabayon Linux Standard 
╠                            kernel image 
╠          License:          GPL-2 freedist
Per esempio se si vuole installare il kernel alla versione 4.2.5:

Code: Select all

kernel-switcher switch linux-sabayon-4.2.5

Code: Select all

eselect opengl set nvidia
Se non ci sono errori prima di riaccendere controlla con il tuo editore TXT favorito il contenuto del file:

Code: Select all

/etc/modprobe.d/nvidia.conf
Se nella stringa vedi:

Code: Select all

NVreg_DeviceFileGID=VIDEOGID
Modificala cosi:

Code: Select all

NVreg_DeviceFileGID=27

Code: Select all

reboot
Tienici al corrente.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* Nvidia GeForce GTX 560 TI *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

kernuss
Young Hen
Posts: 24
Joined: Mon Jan 12, 2015 8:36

Re: XFCE e Kernel superiore a 4.1.0

Post by kernuss » Tue Dec 01, 2015 21:40

Ciao Fiorello, grazie per la risposta
Ho scovato l' " arcano mistero" facendo partire in console mode con il 4.3.0 , in pratica ,quando vado a installare i driver nvidia per il kernel 4.3.0, mi installa sempre la versione per i 4.1.0 e quindi non parte il DE; non ho provato con il 4.2.5, ma PENSO che faccia la stessa cosa.... ho digitato il nome del driver completo di #4.3.0-sabayon e hopla'! Il DE e' apparso!
Grazie per la accurata procedura!

User avatar
sabayonino
Sagely Hen
Posts: 3233
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by sabayonino » Tue Dec 01, 2015 23:08

kernel-switcher ti era stato suggerito

elenco dei kernel disponibili

Code: Select all

# kernel-switcher list
scegli quello che più ti piace :mrgreen: (pari o dispari ? )

Code: Select all

# kernel-switcher switch -a sys-kernel/linux-sabayon-4.3

Code: Select all

╠  @@ calcolo delle dipendenze...
╠  @@ Questi sono i pacchetti che verrebbero installati:
╠  ## [N] [sabayonlinux.org] x11-drivers/nvidia-drivers-355.11#4.3.0-sabayon#4.3.0-sabayon|0   [355.11|0|4.3.0-sabayon]
╠  ## [N] [sabayonlinux.org] sys-kernel/linux-sabayon-4.3|0   [4.3|0]
╠  ## [N] [sabayonlinux.org] app-emulation/virtualbox-modules-5.0.10#4.3.0-sabayon#4.3.0-sabayon|1   [5.0.10|1|4.3.0-sabayon]
╠  @@ Pacchetti che richiedono di essere installati/aggiornati/retrocessi: 3
╠  @@ Pacchetti da rimuovere: 0
╠  @@ Pacchetti da installare: 0
╠  @@ Pacchetti da reinstallare: 3
╠  @@ Pacchetti da aggiornare: 0
╠  @@ Pacchetti da retrocedere: 0
╠  @@ Dimensione download: 0b
╠  @@ Spazio su disco liberato: 0.0b
╠  @@ Hai bisogno di almeno: 130.1MB di spazio libero
     Vuoi continuare ? [Si/No] 
et voilà

grub si aggiorna in automatico (idem lo switch di OpenGL) , riavvia , incrocia le dita e se tutto funziona rimuovi il vecchio kernel.

ciao
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

kernuss
Young Hen
Posts: 24
Joined: Mon Jan 12, 2015 8:36

Re: XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by kernuss » Wed Dec 02, 2015 10:08

Confermo sabayonino, ho fatto tutto quello che mi ha scritto fiorello ( altrimenti perchè dovrei postare sul forum ? XD ), kernel-switcher compreso; il punto era che non "agganciava" ,e non si autoaggiornava come hai postato tu, in automatico i driver nvidia 355.11#4.3.0 ma sempre ( anche in fase "equo i nvidia-drivers" con il kernel 4.3.0 selezionato) la versione 4.1.0 da sabayon-weekly ( vedo che tu invece hai sabayonlinux.org come mirror, giusto per indicare una delle tante differenze)
Ripeto, problema sicuramente di un parametro che non mettevo correttamente ( o non ho configurato ) io e non l'avrei notato se non avessi fatto " kernel-switcher switch linux-sabayon-4.2.5 " come indicato da fiorello

User avatar
messana
Advanced Hen
Posts: 245
Joined: Fri Mar 16, 2007 16:41
Location: Livorno-Toscana

Re: XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by messana » Sat Feb 06, 2016 10:56

Grazie Fiore le tue indicazioni sono stati utili anche per la mia Sabayon con kernel LTS e nvidia-drivers idoneo alla mia vecchia scheda video. ;-)
Image

User avatar
fiorello
Sagely Hen
Posts: 1242
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by fiorello » Sat Feb 06, 2016 11:38

Ciao Riccardo, sono veramente contento di rileggerti, Il tempo passa ma i bei ricordi rimangono indelebili, quante discussioni per la Sabayon tra esperti in chiacchere ... :lol:

Vorrei chiedere a te che fondalmentalmente se la memoria regge ancora sei uno Gnomista, come mai nel nel vassoio sistema della Gnome non c'è l'iconcina di Magneto pur essendo installato, se non mi sbaglio una volta era implementata di default.

Tchao speo di ribeccarti sul forum :D
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* Nvidia GeForce GTX 560 TI *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

User avatar
messana
Advanced Hen
Posts: 245
Joined: Fri Mar 16, 2007 16:41
Location: Livorno-Toscana

Re: XFCE e Kernel superiore a 4.1.0 [Risolto]

Post by messana » Sat Feb 06, 2016 13:21

Ciao Carissimo, l'iconcina è sostituita dalla spunta verde che indica che il sistema è aggiornato. Così credo. Io sto bene e mi fa piacere vederti sempre attivo su Sabayon. In questo tempo ho continuato ad usare linux e provare un po ditutto. Alla fine Sabayon resta nel cuore e l'ho trovata veramente rivoluzionaria. Ho usato per un pò di tempo la mitica Funtoo di Daniel Robbins (istruttiva), ed ho sempre sperato che potesse portare quello che Erculiani ha tradotto su Gentoo, la possibilità di consentire agli utenti di compilare oppure avere un'istaller che velocizzasse l'installazione.
Daniel Robbins è incredibile, sembra di parlare con il vicino di casa. ;-) ps w kde sempre.... ;-)
Questa sottp è una delle mie svariate versioni Funtoo.
Image
Sabayon
Image

Post Reply