Schermo nero dopo aggiornamento [Risolto]

Problemi relativi a KDE, GNOME o altri ambienti grafici? Scrivi pure qui!

Moderator: Moderators

Schermo nero dopo aggiornamento [Risolto]

Postby 71214n0 » Tue Feb 05, 2013 21:25

Ciao a tutti! Ho scaricato e installato Sabayon 10 MATE senza problemi, poi ho installato l'enorme mole di aggiornamenti che mi si indicava ma al riavvio ,finito il caricamento ,mi si presenta lo schermo nero con il cursore in alto che lampeggia. Detto questo ho provato nella console il comando X e alla fine mi dice "could not insert nvidia - no such device" oltre che a no screnns found" che è successo? Premetto che ho un portatile con Vga una vetusta Geforce Go6100, vi chiedo aiuo!
Last edited by 71214n0 on Wed Feb 06, 2013 20:31, edited 1 time in total.
71214n0
Baby Hen
 
Posts: 5
Joined: Tue Feb 05, 2013 21:15

Re: Schermo nero dopo aggiornamento

Postby 71214n0 » Tue Feb 05, 2013 21:39

Ah sì, provando a metter i driver vesa in xorg.conf l'ambiente grafico funziona ma la risoluzione massima non è un granchè...
71214n0
Baby Hen
 
Posts: 5
Joined: Tue Feb 05, 2013 21:15

Re: Schermo nero dopo aggiornamento

Postby belcocco » Tue Feb 05, 2013 22:19

Probabilmente durante l'aggiornamento è stato aggiornato il kernel e i driver nvidia sono rimasti quelli del kernel vecchio, che dovrebbe comunque esistere nel menù d'avvio di grub.
2 cose.
1) prova a postare qui il risultato del comando uname -a dato in console.
2) prova a scegliere un altro kernel all'avvio del sistema e dicci se partono i driver nvidia
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Schermo nero dopo aggiornamento

Postby 71214n0 » Wed Feb 06, 2013 18:27

Dunque uname -a mi dà

Linux tiz-sabayon 3.5.0-sabayon #1 SMP Tue Sep 11 08:32:37 UTC 2012 i686 AMD Turion(tm) 64 X2 Mobile Technology TL-50 AuthenticAMD GNU/Linux

;mentre nel grub mi si presenta solo il kernel 3.5.0
71214n0
Baby Hen
 
Posts: 5
Joined: Tue Feb 05, 2013 21:15

Re: Schermo nero dopo aggiornamento

Postby belcocco » Wed Feb 06, 2013 19:21

Fai una falsa installazione del driver nvidia per chip obsoleti (come li chiami tu :alien: ) con il comando:
#equo install x11-drivers/nvidia-drivers-173.14.36#3.5.0-sabayon --pretend

Vedi se richiama anche la dipendenza:
x11-drivers/nvidia-userspace-173.14.36

Dovrebbero esserci in totale 2 pacchetti da installare.
Se così fosse, procedi con un:
#equo install x11-drivers/nvidia-drivers-173.14.36#3.5.0-sabayon
e poi
#reboot
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Schermo nero dopo aggiornamento

Postby 71214n0 » Wed Feb 06, 2013 20:00

Perfetto, funziona! Con i driver 173 adesso va alla perfezione, grazie mille socio!

A proposito, adesso Magneto mi continua a indicare i driver da aggiornare. Posso in qualche maniera bloccarli di modo non debba aggiornarli per sbaglio una volta?
71214n0
Baby Hen
 
Posts: 5
Joined: Tue Feb 05, 2013 21:15

Re: Schermo nero dopo aggiornamento

Postby belcocco » Wed Feb 06, 2013 20:25

Magneto fa il suo mestiere. :lol:
Ma tu puoi masherare 'tutti' i driver nvidia con i comandi:
#equo mask x11-drivers/nvidia-drivers
#equo mask x11-drivers/nvidia-userspace
in modo che se ne stia zitto. :eye:

Se in futuro fosse necessario aggiornare il kernel con 'kernel-switcher ........', dovrai procedere (vado a memoria) allo smascheramento del solo pacchetto relativo al kernel (ad esempio 3.8.0) di tuo interesse con i comandi:
#equo unmask x11-drivers/nvidia-drivers-173.14.36#3.8.0
#equo unmask x11-drivers/nvidia-userspace

Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Schermo nero dopo aggiornamento

Postby 71214n0 » Wed Feb 06, 2013 20:30

ok! ora sono apposto, grazie ancora per l'aiuto!
71214n0
Baby Hen
 
Posts: 5
Joined: Tue Feb 05, 2013 21:15

Re: Schermo nero dopo aggiornamento [Risolto]

Postby belcocco » Wed Feb 06, 2013 20:46

de nada.
Alla prossima.
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Schermo nero dopo aggiornamento [Risolto]

Postby sabayonino » Wed Feb 06, 2013 20:58

la tua scheda video è supportata fino alla versione 304.64 dei drivers

http://www.nvidia.it/object/linux-displ ... er-it.html
GeForce 6 series:
6800 XT, 6800 XE, 6800 Ultra, 6800 Series GPU, 6800 LE, 6800 GT, 6800 GS/XT, 6800 GS, 6800, 6700 XL, 6610 XL, 6600 VE, 6600 LE, 6600 GT, 6600, 6500, 6250, 6200 TurboCache, 6200SE TurboCache, 6200 LE, 6200 A-LE, 6200, 6150SE nForce 430, 6150LE / Quadro NVS 210S, 6150 LE, 6150, 6100 nForce 420, 6100 nForce 405, 6100 nForce 400, 6100


Go6100 non c'è (la Go7100 si)

(o è la 6100 nForce)

Code: Select all
# lspci | grep VGA
User avatar
sabayonino
Sagely Hen
 
Posts: 2516
Joined: Sun Sep 21, 2008 1:12
Location: Italy


Return to Sabayon Linux Ambienti Grafici

Who is online

Users browsing this forum: No registered users and 3 guests