dove sono finite le icone nei menu? [Risolto]

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

User avatar
fiorello
Sagely Hen
Posts: 1349
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: dove sono finite le icone nei menu?

Post by fiorello » Mon May 06, 2019 21:34

Portage lo installa per primo è normale, prova a dare un:

Code: Select all

# equo deptest
Con kde non cera nessun file di configurazione da aggiornare, c'è solo un pacchetto che non è piu' disponibile nei repo e non l'ho rimosso.

Code: Select all

# equo upgrade
╠  @@ Calcul des mises à jour système: 
╠  @@ Rien à mettre à jour.
╠  @@ Il y a des paquets dans le système qui ne sont plus disponibles dans les dépôts en ligne.
╠  @@ Even if they are usually harmless, it is suggested (after proper verification) to remove them.
╠  @@ Voici les paquets qui seraient supprimés:
╠  ## [sabayonlinux.org] media-plugins/gst-plugins-xvid-0.10.23-r1 [241.1kB]
╠  @@ To automatically remove them, please run: equo upgrade --purge.
╠  @@ Rien à supprimer.
╠  @@ No configuration files to update.
Con Sabayon prendi l'abitudine di aggiornare il sistema con il terminale, ti da maggiori informazioni.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.20.0 *_* Sabayon KDE-5 *_*
Image

User avatar
fiorello
Sagely Hen
Posts: 1349
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: dove sono finite le icone nei menu?

Post by fiorello » Mon May 06, 2019 23:27

Ho installato e aggiornato questo desktop e riscontro il tuo stesso problema niente iconi dopo aggiornamento.

Non ho trovato nulla di utile in /var ma mi da due errori in fase di accensione, vediamo cosa dice sabayonino.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.20.0 *_* Sabayon KDE-5 *_*
Image

User avatar
sabayonino
Sagely Hen
Posts: 3354
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: dove sono finite le icone nei menu?

Post by sabayonino » Tue May 07, 2019 11:10

Cambia il tema e scegline uno chiaro perchè alcune icone sullo sfondo scuro non si vedono, cambia (riseleziona) lo stile degli elementi

Image
Image
Image

Code: Select all

$ equo s --installed lxqt -qv
lxqt-base/liblxqt-0.14.1
lxqt-base/lxqt-about-0.14.1
lxqt-base/lxqt-admin-0.14.1
lxqt-base/lxqt-config-0.14.1
lxqt-base/lxqt-globalkeys-0.14.1
lxqt-base/lxqt-meta-0.14.1
lxqt-base/lxqt-notificationd-0.14.1
lxqt-base/lxqt-panel-0.14.1
lxqt-base/lxqt-policykit-0.14.1
lxqt-base/lxqt-qtplugin-0.14.0
lxqt-base/lxqt-runner-0.14.1
lxqt-base/lxqt-session-0.14.1
x11-themes/lxqt-themes-0.14.0

User avatar
fiorello
Sagely Hen
Posts: 1349
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: dove sono finite le icone nei menu?

Post by fiorello » Tue May 07, 2019 11:55

Ciao Niko.

Ho passato la mattina su questo desktop, ho provato di tutto, installato i drivers nvidia, reinstallare il kernel, configurato xorg, installato tutti i pacchetti LXQt, smanettato nelle configurazioni del sistema e i differenti themi, ho cancellato i file di configurazione, penso che il problema venga dal gestore dei file PCManFM-Qt che non mostra le icones.

Image

Image

:|
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.20.0 *_* Sabayon KDE-5 *_*
Image

User avatar
sabayonino
Sagely Hen
Posts: 3354
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: dove sono finite le icone nei menu?

Post by sabayonino » Tue May 07, 2019 12:11

Guarda marcello.
Senza far niente , reinstallando i pacchetti lxqt
In partenza :
Image

e riselezionando /cambiando i temi :

Image
Image
Image
Image

1 - già cambiando il stile qt , da fusion (default) a oxygen/plasma , sono irapparse più delle metà delle icone.
2 - Selezionare un tema chiaro (alcune icone sullo sfondo scuro non si vedono)
3 - Se vuoi cambia il tema delle icone.
4 - magari un relogin , fa riapparire per miracolo ulteriori mancanze.

Non ho fatto altro.

User avatar
fiorello
Sagely Hen
Posts: 1349
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: dove sono finite le icone nei menu?

Post by fiorello » Tue May 07, 2019 13:28

Bene avanziamo, non sono un specialista di questi desktop, non ho controllato se prima degli aggiornamenti oxygen/plasma fosse implementato, io ho solo Fusion && Windows, come li hai implementati? è talmente scarno che manca anche un programma per scompattare i TAR, forse manca qualcosa.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.20.0 *_* Sabayon KDE-5 *_*
Image

User avatar
fiorello
Sagely Hen
Posts: 1349
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: dove sono finite le icone nei menu?

Post by fiorello » Tue May 07, 2019 14:11

Risolto, penso che l'aggiornamente abbia spazzato via kde-plasma/oxygen va reinstallato assieme a altre 2 librerie che equo installa automaticamente.

@ alexo, installa questo pacchetto:

Code: Select all

# equo install kde-plasma/oxygen-5.15.4
Image

Tienici al corrente.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux-4.20.0 *_* Sabayon KDE-5 *_*
Image

User avatar
sabayonino
Sagely Hen
Posts: 3354
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: dove sono finite le icone nei menu?

Post by sabayonino » Tue May 07, 2019 17:11

fiorello wrote:
Tue May 07, 2019 13:28
Bene avanziamo, non sono un specialista di questi desktop, non ho controllato se prima degli aggiornamenti oxygen/plasma fosse implementato, io ho solo Fusion && Windows, come li hai implementati?
Ho KDE nel sistema quindi potrei averli gia avuti dentro, gho semplicemente dato

Code: Select all

# equo i lxde-meta
e si è portato dietro :

Code: Select all

x11-misc/xdg-user-dirs-0.17
x11-misc/xdg-user-dirs-gtk-0.10-r1
lxde-base/lxmenu-data-0.1.5
dev-libs/libqtxdg-3.3.1
lxqt-base/liblxqt-0.14.1
lxqt-base/lxqt-globalkeys-0.14.1
x11-libs/libfm-extra-1.2.5
lxde-base/menu-cache-1.1.0
media-sound/pavucontrol-qt-0.14.1
lxqt-base/lxqt-panel-0.14.1
dev-qt/qttranslations-5.12.3
lxqt-base/lxqt-policykit-0.14.1
lxqt-base/lxqt-admin-0.14.1
x11-libs/libfm-qt-0.14.1-r1
lxqt-base/lxqt-qtplugin-0.14.0
media-libs/libid3tag-0.15.1b-r4
media-libs/imlib2-1.5.1-r1
x11-wm/openbox-3.6.1-r1
x11-misc/obconf-qt-0.13.0
lxqt-base/lxqt-notificationd-0.14.1
x11-misc/pcmanfm-qt-0.14.1-r1
lxqt-base/lxqt-about-0.14.1
lxqt-base/lxqt-config-0.14.1
dev-cpp/muParser-2.2.5
lxqt-base/lxqt-runner-0.14.1
x11-themes/lxqt-themes-0.14.0
lxqt-base/lxqt-session-0.14.1
lxqt-base/lxqt-meta-0.14.1
è talmente scarno che manca anche un programma per scompattare i TAR, forse manca qualcosa.
Questo è un ambiente basato sule QT , quindi puoi utilizzare le applicazioni native di KDE ... ma occhio. Essendo pacchetti precompilati con le relative dipendenze , sicuramente si porta dietro anche mezzo KDE. , ma nulla vieta di utilizzare anche applicazioni GTK

Per la gestione archivi , c'è sempre ARK ... oppure il buon vecchio terminale che mai ti lascia a piedi :P

alexo
Baby Hen
Posts: 10
Joined: Thu Apr 11, 2019 16:24

Re: dove sono finite le icone nei menu?

Post by alexo » Tue May 07, 2019 19:02

Grazie al vostro sollecito intervento ho eseguito il comando suggerito da fiorello:

Code: Select all

equo install kde-plasma/oxygen-5.15.4
e dopo il riavvio le icone sono riapparse tutte, ovviamente quelle del nuovo tema oxigen appena installato.

Per dare conferma a quanto afferma sabayonino su LXQt
Questo è un ambiente basato sule QT , quindi puoi utilizzare le applicazioni native di KDE ... ma occhio. Essendo pacchetti precompilati con le relative dipendenze , sicuramente si porta dietro anche mezzo KDE. , ma nulla vieta di utilizzare anche applicazioni GTK
sì sono riuscito ad eseguire correttamente applicazioni Gnome GTK senza alcun problema.

Voglio dire a fiorioello che LXQt nasce piccolo ma se ci installi i pacchetti che occorrono mano a mano che ne hai la necessità, riesce a far funzionare anche un vecchio notebook Acer Aspire 5315 che ha circa se non più di 10 anni.

Grazie, problema risolto.

alexo
Baby Hen
Posts: 10
Joined: Thu Apr 11, 2019 16:24

Re: dove sono finite le icone nei menu? [Risolto]

Post by alexo » Tue May 07, 2019 20:43

@fiorello

questo è l'output del comando che mi hai consigliato:

Code: Select all

sudo equo deptest
Password: 
╠  @@ Esecuzione test dipendenze...
╠  @@  (150/850) Controllo sys-apps/net-tools-1.60_p201806260╠  @@ Queste sono le dipendenze non trovate:
╠    # >=sys-apps/sysvinit-2.86-r6
╠       # Richiesto da:
╠       # sys-apps/openrc-0.38.3
╠  @@ Installazione pacchetti disponibili in 10 secondi ...
☢ Impossibile trovare package_matches.
l'ho eseguito dopo aver installato kde-plasma/oxygen-5.15.4. Stranamente mi indica una dipendenza non soddisfatta che però non riesce a risolvere.
Cosa ne pensi?

Post Reply