Problema con portachiavi [Risolto]

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

Post Reply
tasso...
Baby Hen
Posts: 5
Joined: Mon Jun 19, 2017 18:55

Problema con portachiavi [Risolto]

Post by tasso... » Wed Jun 21, 2017 7:44

Salve, sono un nuovo utente Sabayon, ho installato da due giorni la distribuzione con Gnome.
Dopo aver riavviato il sistema ho voluto cambiare la password utente da riga di comando con passwd, perchè non ero riuscito ad inserire la password che normalmente uso in fase di installazione. Da quel momento qualsiasi cosa faccio mi appare il popup del portachiavi che mi chiede di inserire la password e non riesco a fargli adare bene ne quella nuova ne la vecchia.
Come risolvere il problema?
Grazie in anticipo

User avatar
fiorello
Sagely Hen
Posts: 1262
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: problema con portachiavi

Post by fiorello » Wed Jun 21, 2017 13:25

Ti posto la procedura per cambiare la o le passwd, da live via DVD && chiavetta USB.

Apri un terminale (konsole) digita:

Code: Select all

su
Per identificare il disco e la partizioni → / sistema digita:

Code: Select all

parted -l
Dopo avere identificato il device:

Code: Select all

mkdir /mnt/temp

mount /dev/sda1 /mnt/temp 
   
chroot /mnt/temp /bin/bash
Per cambiare la passwd utente digita:

Code: Select all

passwd username  

Per cambiare la passwd di root digita:

Code: Select all

passwd 

Code: Select all

exit

reboot
Nota bene:

@ supponendo che sda1 sia il device giusto.

@ dove username è il nome utente a cui vuoi cambiare la password.

Tchao e benvenuto sul forum. :D
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

tasso...
Baby Hen
Posts: 5
Joined: Mon Jun 19, 2017 18:55

Re: problema con portachiavi

Post by tasso... » Wed Jun 21, 2017 16:51

Grazie per il benvenuto
Ho provato ma probabilmente sbaglio qualcosa nel'identificare il device giusto
una volta lanciato parted -l ottengo questo:

Modello: ATA Hitachi HTS54251 (scsi)
Disco /dev/sda: 160GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco:

Numero Inizio Fine Dimensione Tipo File system Flag
1 1049kB 525MB 524MB primary ext4 avvio
2 525MB 160GB 160GB primary lvm

scusami ma ho provato sia con sda1 che sda2 dove sbaglio?

User avatar
sabayonino
Sagely Hen
Posts: 3279
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: problema con portachiavi

Post by sabayonino » Wed Jun 21, 2017 19:51

@Fiore : a procedura da te è indicata per un partizionamento standard
Se l'utente affronta l'installazione con partizionamento automatico quasi sicuramente sarà con LVM

https://wiki.sabayon.org/index.php?titl ... _Mount_LVM

in linea di massima le partizioni LVM da live vengono già attivate basta solo montarle individuandone il gruppo lvm

Esempio

Code: Select all

# lvdisplay
  --- Logical volume ---
  LV Path                /dev/sabayon_sabayon/swap
  LV Name                swap
  VG Name                sabayon_sabayon
  LV UUID                n4yuuT-CNgj-M6kf-4PDy-Ndme-ePMB-dAf8Xx
  LV Write Access        read/write
  LV Creation host, time sabayon, 2017-06-16 19:33:17 +0000
  LV Status              NOT available
  LV Size                3,88 GiB
  Current LE             992
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/sabayon_sabayon/home
  LV Name                home
  VG Name                sabayon_sabayon
  LV UUID                BlhByF-Rurg-usjY-3OuU-Jf3R-LmG1-gSN8i4
  LV Write Access        read/write
  LV Creation host, time sabayon, 2017-06-16 19:33:17 +0000
  LV Status              NOT available
  LV Size                67,64 GiB
  Current LE             17317
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/sabayon_sabayon/root
  LV Name                root
  VG Name                sabayon_sabayon
  LV UUID                VFjItR-NpFJ-Np9y-AEdr-FYKr-IW90-du2sdg
  LV Write Access        read/write
  LV Creation host, time sabayon, 2017-06-16 19:33:19 +0000
  LV Status              NOT available
  LV Size                50,00 GiB
  Current LE             12800
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
Qui abbiamo 3 volumi e i loro device : root (il sistema) , home (la home utente) , e swap


dobbiamo solo montare root (il filesystem principale dove è installato il sistema)

Code: Select all

# mkdir -p /mnt/sabayon && mount /dev/sabayon_sabayon/root /mnt/sabayon
e poi procedere al mount dei filesystem virtuali

Code: Select all

# mount -t proc  /proc /mnt/sabayon/proc && mount --rbind /dev /mnt/sabayon/dev && mount /sys /mnt/sabayon/sys
procedere al chroot

Code: Select all

# chroot /mnt/sabayon /bin/bash 
source /etc/profile
reimpostare la password

ma mi sembra strano che non l'abbia presa con lavvio normale

come hai proceduto al cambio ?

Code: Select all

# passwd <utente>
mi sembra strano che durante l'installazione non abbia impostato la password , il form è appena sotto alla casella dell'utente
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

tasso...
Baby Hen
Posts: 5
Joined: Mon Jun 19, 2017 18:55

Re: problema con portachiavi

Post by tasso... » Thu Jun 22, 2017 7:42

si durante l'installazione ho impostato tutto correttamente e funzionava, ho aggiornato uttto il sistema e tutto andava bene, solo successivamente ho da terminale dato il comando # passwd <utente> per cambiare la password e da quel momento il portachiavi ha iniziato a darmi il problema del post....ora provo a montare le partizioni come mi hai indicato e sicuramente risolverò...grazie in anticipo

tasso...
Baby Hen
Posts: 5
Joined: Mon Jun 19, 2017 18:55

Re: problema con portachiavi

Post by tasso... » Thu Jun 22, 2017 10:07

ho provato ma evidentemente sbaglio ancora..

sabayon sabayonuser # lvdisplay
--- Logical volume ---
LV Path /dev/sabayon_tasso/root
LV Name root
VG Name sabayon_tasso
LV UUID Ah5N9u-oApy-AJSm-7B0u-E3C3-j6sl-M33Yic
LV Write Access read/write
LV Creation host, time tasso, 2017-06-19 16:28:34 +0000
LV Status NOT available
LV Size 50.00 GiB
Current LE 12800
Segments 1
Allocation inherit
Read ahead sectors auto

--- Logical volume ---
LV Path /dev/sabayon_tasso/home
LV Name home
VG Name sabayon_tasso
LV UUID vHGjSx-ZyDe-AtO5-qEtB-NbHZ-K8vj-27eM3F
LV Write Access read/write
LV Creation host, time tasso, 2017-06-19 16:28:40 +0000
LV Status NOT available
LV Size 96.55 GiB
Current LE 24718
Segments 1
Allocation inherit
Read ahead sectors auto

--- Logical volume ---
LV Path /dev/sabayon_tasso/swap
LV Name swap
VG Name sabayon_tasso
LV UUID nrcVlR-CJZB-8RTD-5PtP-yc7X-FUzH-Jhgark
LV Write Access read/write
LV Creation host, time tasso, 2017-06-19 16:28:46 +0000
LV Status NOT available
LV Size 2.00 GiB
Current LE 512
Segments 1
Allocation inherit
Read ahead sectors auto

sabayon sabayonuser # mkdir -p /mnt/sabayon && mount /dev/sabayon_tasso/root /mnt/sabayon/
mount: special device /dev/sabayon_tasso/root does not exist
sabayon sabayonuser #

dove ho sbagliato, mi sembrava di aver messo tutto secondo output di lvdisplay

User avatar
sabayonino
Sagely Hen
Posts: 3279
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: problema con portachiavi

Post by sabayonino » Thu Jun 22, 2017 11:12

se i volumi sono attivi in /dev/sabayon_tasso dovresti avere i simlink indicati da lvdisplay

se non ci sono prova ad abilitare i volumi LVM

Code: Select all

# lvchange -ay /dev/sabayon_tasso/root
ripeti il mount
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

tasso...
Baby Hen
Posts: 5
Joined: Mon Jun 19, 2017 18:55

Re: problema con portachiavi

Post by tasso... » Fri Jun 23, 2017 10:35

PERFETTO...tutto risolto
Grazie Per l'aiuto :-)))

Post Reply