Steam non parte [Risolto]

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

Post Reply
User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Steam non parte [Risolto]

Post by ermandrea » Sat Jan 30, 2016 17:59

Buonasera a tutti,
non avevo mai lanciato steam da quando ho reinstallato sabayon, ma quando l'ho fatto ho notato che non mi parte, da cosa potrebbe dipendere?
Last edited by ermandrea on Tue Feb 02, 2016 16:03, edited 1 time in total.
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
fiorello
Sagely Hen
Posts: 1264
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: Steam non parte

Post by fiorello » Sat Jan 30, 2016 21:37

Prova a reinstallare l'applicazione:

Code: Select all

# equo i -a steam-meta
Fai partire il programma da utente:

Code: Select all

# exit

Code: Select all

$ steam
Posta eventuali errori.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Steam non parte

Post by ermandrea » Sun Jan 31, 2016 0:05

~ $ steam
/home/andrea/.local/share/Steam/steam.sh: riga 159: DISTRIB_RELEASE: variabile non assegnata
/home/andrea/.local/share/Steam/steam.sh: riga 159: DISTRIB_RELEASE: variabile non assegnata
Running Steam on sabayon 64-bit
/home/andrea/.local/share/Steam/steam.sh: riga 159: DISTRIB_RELEASE: variabile non assegnata
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1451690000)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
fiorello
Sagely Hen
Posts: 1264
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: Steam non parte

Post by fiorello » Mon Feb 01, 2016 12:03

Dopo avere letto questo post, cerca e rinomina queste due librerie:

Code: Select all

libstdc++ 

libgcc_s 
Con una scheda Nvidia non ho problemi.

PS: pensa a mettere in firma la tua hardaware, tchao.
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Steam non parte

Post by ermandrea » Tue Feb 02, 2016 10:09

Scusami, non ho capito molto, nel post che mi hai fatto leggere lui rimuove le due librerie? Come le dovrei rinominare? ...sono una frana
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
fiorello
Sagely Hen
Posts: 1264
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France

Re: Steam non parte

Post by fiorello » Tue Feb 02, 2016 11:07

I file sono nella home → visualizza → vizualizza file nascoste:

Code: Select all

/home/NOME_UTENTE/.local/share/Steam
Tieni presente che non so leggere l'Inglese ...vado a tastoni, prova col rimuovere tutta la cartella Steam, reinstalla il programma e fallo ripartire con l'aiuto del terminale, se ti da lo stesso errore, prova a rimuovere i file copiando i comandi che trovi nel link che ti ho postato, se poi non va ancora devi sperare che qualcuno che sa leggere e interpretare l'Inglese si degni di aiutare. :|
ASRock Fatal1ty Z68 Professional Gen3 *_* Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz *_* MSI GeForce® GTX 1050 Ti 4GT OC *_* AR5416 Wireless Network Adapter {AR5008802.11(a) bgn} *_* Mémoire totale 8 Gio *_* linux4.15.0 *_* Sabayon KDE-5 *_*
Image

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Steam non parte

Post by ermandrea » Tue Feb 02, 2016 14:10

Grazie mille fiorello! Risolto con i comandi nel link! Adesso funziona!
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

Post Reply