dopo aggiornamento sabayon non parte

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

dopo aggiornamento sabayon non parte

Postby zakunin » Sun Jul 28, 2013 17:10

Ciao a tutti,

Dopo l'aggiornamento di oggi, sabayon non vuol saperne di partire.

Ho installato il kernel 3.4 e 3.2. Grub mi dà alcuni errori all'avvio ma già lo faceva prima dell'aggiornamento e tutto funzionava (errore: file not found).

Se lascio che grub macini (parte quindi il kernel 3.4), sabayon parte e si pianta sulla schermata "set keymap to it" senza che possa interagirci (con alt+f2 se non sbaglio);
Se provo la recovery mode del kernel 3.4 mi ritrovo di fronte a questo errore:
Code: Select all
mdadm: no arrays found in config file or automatically 3 logical volume(s) in volume group "vg_sabayon" now active.


per il kernel 3.2: partendo normalmente sembra caricarsi tutto ma arrivati alla fine mi ritrovo davanti ad una schermata nera (probabilmente problema di driver)
con la recovery mode e pswd di root: se do
Code: Select all
equo update

ottengo
Code: Select all
invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8...please execute LC_ALL=en_US.UTF-8 /usr/bin/equo update
Trying to force en_US.UTF 8.

Non so...mi pare grave...aiuto! :(
Last edited by zakunin on Sun Jul 28, 2013 17:58, edited 2 times in total.
zakunin
Simple Hen
 
Posts: 48
Joined: Tue May 01, 2012 9:49

Re: dopo aggiornamento sabayon non parte

Postby zakunin » Sun Jul 28, 2013 17:50

Ho risolto installando il kernel 3.10 ed i relativi driver; non mi spiego comunque l'improvviso malfunzionamento del kernel 3.4. Ora accedo normalmente al sistema. Rimangono errori in grub (error: file not found) e un dubbio:

Code: Select all
sabayon zakunin # equo deptest
>>  @@ Esecuzione test dipendenze...
>>  @@ Queste sono le dipendenze non trovate:
>>    # ~sys-apps/entropy-1.0_rc85
>>       # Richiesto da:
>>       # sys-apps/entropy-client-services-1.0_rc85
>>    # ~x11-drivers/nvidia-userspace-313.30[-tools]
>>       # Richiesto da:
>>       # x11-drivers/nvidia-drivers-313.30#3.2.0-sabayon
>>    # ~x11-drivers/nvidia-userspace-313.30
>>       # Richiesto da:
>>       # x11-drivers/nvidia-drivers-313.30#3.2.0-sabayon
>>    # ~x11-drivers/nvidia-userspace-313.30[multilib]
>>       # Richiesto da:
>>       # x11-drivers/nvidia-drivers-313.30#3.2.0-sabayon
>>    # >=sys-fs/udev-096
>>       # Richiesto da:
>>       # net-wireless/prism54-firmware-1.0.4.3
>>    # ~x11-drivers/nvidia-userspace-313.30[X]
>>       # Richiesto da:
>>       # x11-drivers/nvidia-drivers-313.30#3.2.0-sabayon
>>  @@ Installazione pacchetti disponibili in 10 secondi ...
>> Nessun pacchetto trovato.
(1, False)


come faccio ad eliminare questi errori (che si sono presentati dopo il problema del primo post)? grazie!
zakunin
Simple Hen
 
Posts: 48
Joined: Tue May 01, 2012 9:49

Re: dopo aggiornamento sabayon non parte

Postby Provia » Mon Jul 29, 2013 7:47

Forse gli errori delle dipendenze si risolvono se elimini i due vecchi kernel? Prova ad eliminarli e poi prova ad aggiornare il grub per vedere se risolve anche l'altro problema. Magari sono consigli stupidi ma forse da errore sulle dipendenze perchè i driver per quei vecchi kernel non sono più supportati in entropy.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: dopo aggiornamento sabayon non parte

Postby sabayonino » Mon Jul 29, 2013 12:29

mdadm gestisce il demone per il raid

se non hai dischi in raid (software) puoi rimuovere il servizio dal boot


Openrc
Code: Select all
# rc-update del mdadm


se ti da errore del tipo che il servizio non è in "default" specifica "boot"
Code: Select all
# rc-update del mdadm boot


per systemd controlla i servizi di systemd (ancora non mi ci sono affezionato ... trovo systemd nella gestione , complicato e confusionario)


idem se non hai partizioni LVM , rimuovi il servizio lvm come sopra.

e questi errori non so se dipendano dal kernel (o forse si per mancanza dei moduli raid ed lvm ???)
User avatar
sabayonino
Sagely Hen
 
Posts: 2580
Joined: Sun Sep 21, 2008 1:12
Location: Italy


Return to Sabayon Linux Area Principianti

Who is online

Users browsing this forum: No registered users and 1 guest