xorg.conf di aticonfig

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

xorg.conf di aticonfig

Postby velti » Fri May 03, 2013 17:52

Ciao a tutti!

Ho installato i driver proprietari ati, ma ho un problema con la creazione del file xorg.conf.

Premetto che senza file di configurazione riesco tranquillamente ad entrare in xfce, ma le opzioni di default non sono ottimali (si vede abbastanza sfocato)

Quando creo xorg.conf attraverso il comando

Code: Select all
aticonfig --initial


e successivamente eseguo

Code: Select all
startxfce4


mi viene dato questo errore:
Code: Select all
[  3679.574]
X.Org X Server 1.13.3
Release Date: 2013-03-07
[  3679.583] X Protocol Version 11, Revision 0
[  3679.585] Build Operating System: Linux 3.7.0-server i686 Gentoo
[  3679.588] Current Operating System: Linux jester 3.8.0-sabayon #1 SMP Sat Apr 27 18:24:52 UTC 2013 i686
[  3679.588] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86-3.8.0-sabayon ro nomodeset splash=silent,theme:sabayon video=vesafb:ywrap,mtrr:3 gfxpayload=1024x768x16 console=tty1 quiet dokeymap keymap=it domdadm resume=swap:/dev/mapper/vg_jester-lv_swap real_resume=/dev/mapper/vg_jester-lv_swap dolvm root=/dev/mapper/vg_jester-lv_root docrypt
[  3679.597] Build Date: 17 March 2013  09:57:06PM
[  3679.599] 
[  3679.602] Current version of pixman: 0.29.2
[  3679.606]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3679.606] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3679.615] (==) Log file: "/var/log/Xorg.0.log", Time: Fri May  3 18:46:31 2013
[  3679.617] (==) Using config file: "/etc/X11/xorg.conf"
[  3679.620] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  3679.622] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3679.622] (==) ServerLayout "aticonfig Layout"
[  3679.622] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[  3679.622] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[  3679.622] (**) |   |-->Device "aticonfig-Device[0]-0"
[  3679.622] (==) Automatically adding devices
[  3679.622] (==) Automatically enabling devices
[  3679.622] (==) Automatically adding GPU devices
[  3679.622] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3679.622]    Entry deleted from font path.
[  3679.622] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3679.622]    Entry deleted from font path.
[  3679.622] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3679.622]    Entry deleted from font path.
[  3679.623] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  3679.623]    Entry deleted from font path.
[  3679.623]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  3679.623] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  3679.623]    Entry deleted from font path.
[  3679.623]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  3679.623] (==) FontPath set to:
   /usr/share/fonts/misc/
[  3679.623] (==) ModulePath set to "/usr/lib/xorg/modules"
[  3679.623] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  3679.623] (II) Loader magic: 0x8268600
[  3679.623] (II) Module ABI versions:
[  3679.623]    X.Org ANSI C Emulation: 0.4
[  3679.623]    X.Org Video Driver: 13.1
[  3679.623]    X.Org XInput driver : 18.0
[  3679.623]    X.Org Server Extension : 7.0
[  3679.624] (--) PCI:*(0:1:0:0) 1002:6760:1043:2001 rev 0, Mem @ 0xc0000000/268435456, 0xdfe20000/131072, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[  3679.624] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  3679.626] Initializing built-in extension Generic Event Extension
[  3679.628] Initializing built-in extension SHAPE
[  3679.631] Initializing built-in extension MIT-SHM
[  3679.633] Initializing built-in extension XInputExtension
[  3679.635] Initializing built-in extension XTEST
[  3679.637] Initializing built-in extension BIG-REQUESTS
[  3679.639] Initializing built-in extension SYNC
[  3679.642] Initializing built-in extension XKEYBOARD
[  3679.644] Initializing built-in extension XC-MISC
[  3679.646] Initializing built-in extension XINERAMA
[  3679.648] Initializing built-in extension XFIXES
[  3679.650] Initializing built-in extension RENDER
[  3679.652] Initializing built-in extension RANDR
[  3679.654] Initializing built-in extension COMPOSITE
[  3679.656] Initializing built-in extension DAMAGE
[  3679.658] Initializing built-in extension MIT-SCREEN-SAVER
[  3679.660] Initializing built-in extension DOUBLE-BUFFER
[  3679.662] Initializing built-in extension RECORD
[  3679.664] Initializing built-in extension DPMS
[  3679.665] Initializing built-in extension X-Resource
[  3679.667] Initializing built-in extension XVideo
[  3679.669] Initializing built-in extension XVideo-MotionCompensation
[  3679.671] Initializing built-in extension XFree86-VidModeExtension
[  3679.673] Initializing built-in extension XFree86-DGA
[  3679.675] Initializing built-in extension XFree86-DRI
[  3679.676] Initializing built-in extension DRI2
[  3679.676] (II) "glx" will be loaded by default.
[  3679.676] (II) LoadModule: "glx"
[  3679.677] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  3679.677] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[  3679.677]    compiled for 6.9.0, module version = 1.0.0
[  3679.679] Loading extension GLX
[  3679.679] (II) LoadModule: "fglrx"
[  3679.679] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[  3679.679] (EE)
[  3679.680] (EE) Backtrace:
[  3679.682] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81f4109]
[  3679.683] (EE) 1: /usr/bin/X (0x8048000+0x1afe8a) [0x81f7e8a]
[  3679.685] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb77bd410]
[  3679.686] (EE) 3: /lib/ld-linux.so.2 (0xb77be000+0x6849) [0xb77c4849]
[  3679.687] (EE) 4: /lib/ld-linux.so.2 (0xb77be000+0x8104) [0xb77c6104]
[  3679.689] (EE) 5: /lib/ld-linux.so.2 (0xb77be000+0x12cad) [0xb77d0cad]
[  3679.690] (EE) 6: /lib/ld-linux.so.2 (0xb77be000+0xec2e) [0xb77ccc2e]
[  3679.691] (EE) 7: /lib/ld-linux.so.2 (0xb77be000+0x12754) [0xb77d0754]
[  3679.692] (EE) 8: /lib/libdl.so.2 (0xb76fc000+0xe7e) [0xb76fce7e]
[  3679.694] (EE) 9: /lib/ld-linux.so.2 (0xb77be000+0xec2e) [0xb77ccc2e]
[  3679.695] (EE) 10: /lib/libdl.so.2 (0xb76fc000+0x15d2) [0xb76fd5d2]
[  3679.696] (EE) 11: /lib/libdl.so.2 (dlopen+0x47) [0xb76fcf37]
[  3679.697] (EE) 12: /usr/bin/X (0x8048000+0x6a630) [0x80b2630]
[  3679.698] (EE) 13: /usr/bin/X (0x8048000+0x6bbdc) [0x80b3bdc]
[  3679.699] (EE) 14: /usr/bin/X (xf86LoadModules+0xe7) [0x80c54c7]
[  3679.701] (EE) 15: /usr/bin/X (InitOutput+0x7c8) [0x80c5ce8]
[  3679.702] (EE) 16: /usr/bin/X (0x8048000+0x22380) [0x806a380]
[  3679.703] (EE) 17: /lib/libc.so.6 (__libc_start_main+0xf5) [0xb744c875]
[  3679.704] (EE) 18: /usr/bin/X (0x8048000+0x22909) [0x806a909]
[  3679.706] (EE)
[  3679.707] (EE) Segmentation fault at address 0x4
[  3679.711]
Fatal server error:
[  3679.712] Caught signal 11 (Segmentation fault). Server aborting
[  3679.713]
[  3679.714] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3679.719] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3679.721] (EE)


il file xorg.conf creato dal comando è questo

Code: Select all
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection




Qualcuno di voi sa come aituarmi?
Grazie Mille ! :D
velti
Baby Hen
 
Posts: 5
Joined: Fri May 03, 2013 17:38

Re: xorg.conf di aticonfig

Postby Fitzcarraldo » Sun May 05, 2013 0:12

1. Log out of the DE and wait for the log-in page to be displayed.
2. Press Ctrl-Alt-F1 (or F2, or F3 etc., up to F6) to get to a VT.
3. Log-in as root user.
4. Enter the command /etc/init.d/xdm stop to stop X Windows.
5. Enter the command rm /etc/ati/amdpcsdb to delete the Catalyst driver's database.
6. Enter the command /opt/bin/aticonfig --initial -f to create and initialise the Catalyst driver's database.
7. Enter the command /etc/init.d/xdm restart to restart X Windows.
8. Press Ctrl-Alt-F7 to get to the new log-in window.
9. Log-in to the DE.

N.B. I'm assuming you are using OpenRC, not systemd.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xorg.conf di aticonfig

Postby velti » Sun May 05, 2013 1:38

Fitzcarraldo wrote:1. Log out of the DE and wait for the log-in page to be displayed.
2. Press Ctrl-Alt-F1 (or F2, or F3 etc., up to F6) to get to a VT.
3. Log-in as root user.
4. Enter the command /etc/init.d/xdm stop to stop X Windows.
5. Enter the command rm /etc/ati/amdpcsdb to delete the Catalyst driver's database.
6. Enter the command /opt/bin/aticonfig --initial -f to create and initialise the Catalyst driver's database.
7. Enter the command /etc/init.d/xdm restart to restart X Windows.
8. Press Ctrl-Alt-F7 to get to the new log-in window.
9. Log-in to the DE.

N.B. I'm assuming you are using OpenRC, not systemd.


I have followed your instructions even if I'm using systemd...unfortunately I'm getting the same error

Thanks for your reply
velti
Baby Hen
 
Posts: 5
Joined: Fri May 03, 2013 17:38

Re: xorg.conf di aticonfig

Postby Fitzcarraldo » Sun May 05, 2013 3:11

Qual è il modello di scheda grafica ATI che hai nel tuo PC?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xorg.conf di aticonfig

Postby velti » Sun May 05, 2013 13:11

Fitzcarraldo wrote:Qual è il modello di scheda grafica ATI che hai nel tuo PC?



Radeon HD6470M

Code: Select all
lspci | grep VGA

Code: Select all
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M/7400M Series]
velti
Baby Hen
 
Posts: 5
Joined: Fri May 03, 2013 17:38

Re: xorg.conf di aticonfig

Postby picard12 » Fri May 24, 2013 17:28

Io ho risolto facendo ricreare da zero xorg, rinominandolo e poi da dando il comando aticonfig --initial come indicato nei post precedenti.
picard12
Growing Hen
 
Posts: 114
Joined: Thu Jan 27, 2011 5:26


Return to Sabayon Linux Area Principianti

Who is online

Users browsing this forum: No registered users and 1 guest

cron