PSI doesnt't start - segfault

Ogólne dyskusje o Sabayon Linux

Moderator: Moderators

Post Reply
tomosky
Baby Hen
Posts: 4
Joined: Fri Apr 16, 2010 21:48

PSI doesnt't start - segfault

Post by tomosky » Tue Jun 21, 2011 9:45

Przy próbie uruchomienia aplikacji psi (komunikator-klient) leci błąd widoczny poniżej, aplikacja nie zostaje uruchomiona:
(When I try start psi, in the console show an error:)

Code: Select all

~ $ psi
qca-gnupg: disabling keyring monitoring due to buggy Qt version

(psi:7465): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
Unable to load element 'v4lsrc'.

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstAppVideoSink'

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstRtpBin'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstVideoMaxRate'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstLiveAdder'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstAudioresample'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstSpeexDSP'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(psi:7465): GLib-GObject-WARNING **: cannot register existing type `GstRtpJitterBuffer'

(psi:7465): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(psi:7465): GLib-GObject-WARNING **: attempt to retrieve private data for invalid type '<invalid>'
Naruszenie ochrony pamięci

po usunięciu katalogu .psi program sie uruchamia, mogę ponownie założyć konto od pocztku i sie zalogować. Po wyłączeniu PSI i próbie ponownego włączenia leci wcześniej opisany błąd.

(after remove directory "/home/$login/.psi" I can run once this program(and configure it from the begining), but after shutdown bugs occurs again).

tomosky
Baby Hen
Posts: 4
Joined: Fri Apr 16, 2010 21:48

Re: PSI doesnt't start - segfault

Post by tomosky » Sun Sep 30, 2012 1:02

Witam,

prawdopodobnie problem robi domyślnie doinstalowywany pakiet psimedia. Po jego usunieciu, problem powinien ustąpić.

Możesz usunąć poprzez konsolę (zalogowany jako root)

Code: Select all

equo remove psimedia

Post Reply