Problem z aktualizacją systemu

Ogólne dyskusje o Sabayon Linux

Moderator: Moderators

Post Reply
zet7419
Baby Hen
Posts: 1
Joined: Mon Dec 27, 2010 16:22

Problem z aktualizacją systemu

Post by zet7419 » Mon Dec 27, 2010 18:44

Witam, :)

W trakcie aktualizacji systemu otrzymałem w konsoli następujące komunikaty:

Code: Select all

The following updates are masked by LICENSE changes:
- net-wireless/broadcom-sta-5.60.246.6 (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=sys-devel/binutils-2.20.1-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/binutils-2.21.51.0.4 (masked by: package.mask, missing keyword)
/etc/portage/package.mask:
#Joost Ruis: Tagged for Sabayon 6

- sys-devel/binutils-2.21.51.0.3 (masked by: package.mask, missing keyword)
- sys-devel/binutils-2.21.51.0.2 (masked by: package.mask, missing keyword)
- sys-devel/binutils-2.21.51.0.1 (masked by: package.mask, missing keyword)
- sys-devel/binutils-2.21 (masked by: package.mask)
- sys-devel/binutils-2.20.1-r1 (masked by: package.mask)

(dependency required by "sys-fs/lvm2-2.02.74" [ebuild])
(dependency required by "sys-fs/cryptsetup-1.1.3-r1" [ebuild])
(dependency required by "sys-apps/hal-0.5.14-r4" [ebuild])
(dependency required by "app-misc/hal-info-20091130" [installed])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook. 
Jestem nowym użytkownikiem systemu Sabayon i słabo orientuje się w sprawach konfiguracji i aktualizacji.Na chłopski rozum wnioskuję że powinienem niektóre pakiety odmaskować aby prawidłowo zaktualizować system.Jeśli tak to jak mógłbym to najprościej zrobić?

Pozdrawiam i z góry bardzo dziękuję za okazaną pomoc! :?

[td]Linux sabayon 2.6.31-sabayon HP Compaq 6820s[/td]

rafalz
Baby Hen
Posts: 5
Joined: Tue Nov 30, 2010 21:02

Re: Problem z aktualizacją systemu

Post by rafalz » Thu Dec 30, 2010 16:50

Witam,

W przypadku broadcoma pakiet jest zamaskowany ze względu na licencje i wystarczy że w pliku "/etc/make.conf" odhaszujesz (usuniesz znak "#") linijkę:

Code: Select all

#ACCEPT_LICENSE="*"
dzięki czemu odgórnie będą akceptowane licencje wszystkich pakietów, które takowej akceptacji wymagają.

Co do pliku package.mask zazwyczaj wystarczy zahashowac linijki znazwą pakietu.

Jakieś problemy z broadcomem że starasz się instalować sterowniki z portage?

btw zapraszam na polskie forum Sabayona sabayon.pl

raman
Advanced Hen
Posts: 236
Joined: Mon Sep 06, 2010 17:18
Location: Poland

Re: Problem z aktualizacją systemu

Post by raman » Wed Jan 12, 2011 22:48

Czemu instalujesz prze emerge, a nie entropy?

Post Reply