Unity i zależności

Ogólne dyskusje o Sabayon Linux

Moderator: Moderators

Post Reply
Draqun
Baby Hen
Posts: 9
Joined: Mon Aug 09, 2010 11:50

Unity i zależności

Post by Draqun » Fri Oct 01, 2010 18:27

Chciałem zainstalować sobie w moim GNOME pakiet Unity shell jednak jest problem. Nie jest on obecny ani w Entropy ani w Portage więc possałem sobie paczkę. Oczywiście już na początku dostałem listę zależności, jakie muszę spełnić. Wszystko szło całkiem nieźle jednak przy niektórych zależnościach wymiękam. :shock:

To mi wywala gdy wywołam make.

Code: Select all

configure: error: Package requirements (clutter-1.0 >= 1.0
                  clutter-gtk-0.10 >= 0.10
                  clutk-0.3 >= 0.3.45
                  dbus-glib-1
                  dbusmenu-glib >= 0.3.6
                  dee-1.0 >= 0.2.0
                  glib-2.0 >= 2.22
                  gobject-2.0 >= 2.22
                  gtk+-2.0 >= 2.18
                  gdk-x11-2.0 >= 2.18
                  gio-2.0 >= 2.18
                  gee-1.0
                  gconf-2.0
                  gnome-desktop-2.0
                  indicator >= 0.3.14
                  libbamf >= 0.2
                  libgnomeui-2.0
                  pango >= 1.6.0
                  unique-1.0
                  unity-misc
                  utouch-grail
                  xcb-icccm
                  x11) were not met:

No package 'clutk-0.3' found
No package 'dbusmenu-glib' found
No package 'dee-1.0' found
No package 'indicator' found
No package 'libbamf' found
No package 'unity-misc' found
No package 'utouch-grail' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_CFLAGS
and BASE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
To natomiast wywala mi gdy instaluje zależności. Czegoś mi brakuje, ale nie wiem czego.

Code: Select all

Couldn't find include 'Gtk-2.0.gir' (search path: ['.', '../libdbusmenu-glib', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0'])
make[2]: *** [DbusmenuGtk-0.2.gir] Błąd 1
make[2]: Opuszczenie katalogu `/home/draqun/Downloads/Unity/libdbusmenu-0.3.16/libdbusmenu-gtk'
make[1]: *** [all-recursive] Błąd 1
make[1]: Opuszczenie katalogu `/home/draqun/Downloads/Unity/libdbusmenu-0.3.16'
make: *** [all] Błąd 2
Jakieś pomysły? Jakiej zależności może brakować?

PS. szukam troszke z Wujkiem Google, jednak nie widzę aby ktokolwiek uporał się z takim problemem.
Image

Post Reply